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Los trabajos de protección para varios servidores protegidos producen errores

Este artículo le ayuda a corregir los mensajes de error sobre los detalles del trabajo con errores para varios servidores protegidos en Administrador de protección de datos (DPM).

Versión original del producto: System Center Administrador de protección de datos
Número de KB original: 971411

Síntomas

Recibirá uno o varios de los siguientes mensajes de error sobre los trabajos con errores para varios servidores protegidos en System Center Administrador de protección de datos. Estos errores pueden producirse para varios tipos de trabajos, como la sincronización, los puntos de recuperación y la comprobación de coherencia.

Tipo: Estado del punto de recuperación: Descripción con error: error inesperado durante la ejecución del trabajo. (Id. 104 Detalles: Código de error interno: 0x80990A51)

Tipo: Estado de copia de seguridad en cinta: Descripción con error: DPM no pudo comunicarse con el agente de protección en Server_name.com porque se deniega el acceso. (Id. 42 Detalles: Acceso denegado (0x80070005))

DPM no pudo comunicarse con el servicio del Agente de protección en ProtectedServer.Contoso.local. (Id. 308 Detalles: El servidor RPC no está disponible (0x800706BA))

Error en la operación del agente de protección porque DPM no pudo comunicarse con el servicio agente de protección en protected.server.contoso.com. (Id. 308 Detalles: El servidor RPC no está disponible (0x800706BA))

Tipo: Estado del punto de recuperación: Descripción con error: el agente de protección en Server_name.com no pudo responder temporalmente porque estaba en un estado inesperado. (Id. 60 Detalles: Código de error interno: 0x809909B0)

El servicio DPM no pudo comunicarse con el agente de protección en ProtectedServer.Contoso.local. (Id. 52 Detalles: el host remoto (0x80072746) cerró forzadamente una conexión existente)

El servicio DPM no pudo comunicarse con el agente de protección en ProtectedServer.Contoso.local. (Id. 52 Detalles: el período de tiempo de espera del semáforo ha expirado (0x80070079))

DPM no pudo comunicarse con el agente de protección en ProtectedServer.Contoso.local porque el agente no responde. (Id. 43 Detalles: Código de error interno: 0x8099090E)

DPM no pudo comunicarse con ProtectedServer.Contoso.local porque el equipo no es accesible. (Id. 41 Detalles: No se pudo realizar ninguna conexión porque la máquina de destino la rechazó activamente (0x8007274D))

Causa

Este problema se produce si la red está experimentando una latencia alta o si la red está saturada con transferencias de datos. Cuando se cumplen estas condiciones, se retrasa el tráfico DCOM. Esto hace que los agentes agoten el tiempo de espera de forma intermitente.

Solución alternativa

Para solucionar este problema, siga estos pasos para agregar algunas entradas del Registro en el servidor DPM y el servidor protegido.

  1. En el Bloc de notas, pegue las siguientes entradas en el archivo y guarde el archivo como DPMAgentTimeout.reg.

    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft Data Protection Manager\Agent]
    "ConnectionNoActivityTimeoutForNonCCJobs"=dword:00001c20
    "ConnectionNoActivityTimeout"=dword:00001c20
    "AbortAgentOnLockTimeout"=dword:00000001
    "CommandTimeout"=dword:1b7740
    
    [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters]
    "TcpMaxDataRetransmissions"=dword:00000010
    
  2. Haga clic con el botón derecho en el archivo DPMAgentTimeout.reg y seleccione Combinar.

  3. Reinicie el servicio DPMRA o el servidor para que los cambios surtan efecto.

Si el problema persiste, habilite la limitación de DPM del 85 al 90 por ciento para asegurarse de que el ancho de banda está disponible para las llamadas DCOM. Puede habilitar la limitación de ancho de banda para cada servidor protegido en la pestaña Agentes de la pestaña Administración .

Para obtener más información sobre el TcpMaxDataRetransmissions valor, vea Cómo modificar el tiempo de espera máximo de retransmisión TCP/IP. Además, ejecute software antivirus en el servidor DPM.

Más información

Hay diferentes canales para el control y la información de datos que pasa entre el servidor DPM y un servidor protegido. La ruta de acceso de control usa el canal DCOM (RPC) y la ruta de acceso de datos usa TCP/IP. Si la ruta de acceso de datos satura completamente la red (incluso durante un breve período), es posible que se produzca un error en las llamadas DCOM. Si se produce un error en las llamadas, esto hace que se produzca un error en el trabajo. Para evitar este problema, habilite la limitación de los servidores protegidos para limitar el uso de red de la ruta de acceso de datos al 85 %.

De forma predeterminada, la limitación no está habilitada en DPM porque la limitación requiere que la calidad del servicio (QoS) se instale en el servidor DPM y en el servidor protegido.

Si la configuración del 85 % no resuelve completamente el problema, aumente el nivel de limitación del servidor protegido que tiene el problema.

Si esta solución no resuelve el problema, es posible que el servidor DPM esté sobrecargado. Intente reorganizar los grupos de protección para que las copias de seguridad estén escalonadas o para que las sincronizaciones se produzcan en momentos escalonados.