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Este artículo le ayuda a solucionar un problema en el que no se puede acceder a la vista de equipos UNIX/Linux en Microsoft System Center 2012 R2 Operations Manager.
Versión original del producto: System Center 2012 R2 Operations Manager
Número de KB original: 4075004
Síntomas
No puede acceder a la vista equipos UNIX/Linux en el panel Administración de System Center 2012 R2 Operations Manager. Cuando se produce este problema, recibirá el siguiente mensaje de error:
Fecha: <DateTime>
Aplicación: Operations Manager
Versión de la aplicación: <VersionNumber>
Gravedad: error
Mensaje:
System.NullReferenceException: referencia de objeto no establecida en una instancia de un objeto .
en Microsoft.SystemCenter.CrossPlatform.UI.OM.Integration.UnixComputerOperatingSystemHelper.JoinCollections(IEnumerable'1 managementServers, IEnumerable'1 resourcePools, IEnumerable'1 unixcomputers, IEnumerable'1 operatingSystems)
en Microsoft.SystemCenter.CrossPlatform.UI.OM.Integration.UnixComputerOperatingSystemHelper.GetUnixComputerOperatingSystemInstances(String criteria)
en Microsoft.SystemCenter.CrossPlatform.UI.OM.Integration.Administration.UnixAgentQuery.DoQuery(String criteria)
en Microsoft.EnterpriseManagement.Mom.Internal.UI.Cache.Query'1.DoQuery(String criteria, Nullable'1 lastModified)
at Microsoft.EnterpriseManagement.Mom.Internal.UI.Cache.Query'1.FullUpdateQuery(CacheSession session, IndexTable& indexTable, Boolean forceUpdate, DateTime queryTime)
at Microsoft.EnterpriseManagement.Mom.Internal.UI.Cache.Query'1.InternalSyncQuery(CacheSession session, IndexTable indexTable, UpdateReason reason, UpdateType updateType)
at Microsoft.EnterpriseManagement.Mom.Internal.UI.Cache.Query'1.InternalQuery(CacheSession session, UpdateReason reason)
en Microsoft.EnterpriseManagement.Mom.Internal.UI.Cache.Query'1.TryDoQuery(motivo updateReason, sesión CacheSession)
at Microsoft.EnterpriseManagement.Mom.Internal.UI.Console.ConsoleJobExceptionHandler.ExecuteJob(IComponent component, EventHandler'1 job, Object sender, ConsoleJobEventArgs args)
Causa
El problema se produce si se elimina el grupo de recursos de supervisión de UNIX/Linux.
Solución
Para resolver el problema, siga estos pasos:
Cree un grupo de recursos para la supervisión de UNIX/Linux. Asigne al nuevo grupo un nombre diferente al nombre del grupo de recursos eliminado.
Agregue los servidores de administración que realizan la supervisión de UNIX/Linux al nuevo grupo de recursos.
Configure las cuentas de ejecución de UNIX/Linux que va a distribuir el nuevo grupo de recursos. Para ello, siga estos pasos:
En la consola del operador, vaya a Administración>Ejecutar como configuración>cuentas de UNIX/Linux.
Para cada cuenta, siga estos pasos:
- Haga clic con el botón derecho en la cuenta y seleccione Propiedades.
- En la página Seguridad de distribución del Asistente para cuentas de ejecución de UNIX/Linux, seleccione Más seguro.
- En Equipos seleccionados y grupos de recursos, seleccione Agregar.
- Seleccione Buscar por nombre del grupo de recursos y, a continuación, seleccione Buscar.
- Seleccione el nuevo grupo de recursos que se crea en el paso 1, seleccione Agregar y, a continuación, seleccione Aceptar.
Ejecute el siguiente cmdlet de PowerShell para recuperar los equipos UNIX y Linux administrados:
Get-SCXAgent
Compruebe que los agentes asociados al grupo de recursos eliminados siguen existiendo y que la relación permanece.
Ejecute el siguiente comando para cambiar el grupo de recursos de administración al que se crea en el paso 1:
$SCXPool = Get-SCOMResourcePool -DisplayName "<New Resource Pool Name>" Get-SCXAgent | Set-SCXResourcePool -ResourcePool $SCXPool