Compartir a través de


La consola de Virtual Machine Manager no se inicia y recibe el identificador de error 1602.

En este artículo se corrige un problema en el que se produce el identificador de error 1602 al iniciar la consola de Virtual Machine Manager (VMM).

Versión original del producto: Microsoft System Center Virtual Machine Manager
Número de KB original: 3020448

Síntomas

Al intentar iniciar la consola VMM en System Center Virtual Machine Manager o versiones posteriores, la consola no se inicia y recibe el siguiente mensaje de error:

No se puede conectar al servidor de administración de VMM server_name. El servicio Virtual Machine Manager en ese servidor no respondió. Compruebe que Virtual Machine Manager se ha instalado en el servidor y que el servicio Virtual Machine Manager se está ejecutando. A continuación, intente conectarse de nuevo. Si el problema persiste, reinicie el servicio Virtual Machine Manager. Identificador: 1602

También puede observar que el servicio System Center Virtual Machine Manager está detenido. Al intentar iniciar el servicio, recibirá el siguiente mensaje de error:

Windows no pudo iniciar el servicio System Center Virtual Machine Manager en el equipo local. El servicio no devolvió un error. Esto podría ser un error interno de Windows o un error de servicio interno. Si el problema continúa, póngase en contacto con el administrador del sistema.

Además, se registra un error similar al siguiente en el registro de aplicación en el servidor de Virtual Machine Manager:

Nombre de registro: Application
Origen: Runtime de .NET
Fecha:
Identificador de evento: 1026
Categoría de tarea: None
Nivel: Error
Palabras clave: clásica
Usuario: N/D
Equipo:
Descripción:
Aplicación: vmmservice.exe
Versión del marco: v4.0.30319
Descripción: el proceso se finalizó debido a una excepción no controlada.
Información de excepción: System.FormatException
Pila:
at System.DateTime.Parse(System.String, System.IFormatProvider)
at System.Convert.ToDateTime(System.String)
at Microsoft.VirtualManager.DB.ServerGlobalSettings.ReadServerData(System.Guid)
at Microsoft.VirtualManager.DB.ServerGlobalSettings.get_Instance()
en Microsoft.VirtualManager.Engine.VirtualManagerService.StartSQL()
en Microsoft.VirtualManager.Engine.VirtualManagerService.ExecuteRealEngineStartup()
en Microsoft.VirtualManager.Engine.VirtualManagerService.TryStart(System.Object)
at System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
en System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
at System.Threading.TimerQueueTimer.CallCallback()
at System.Threading.TimerQueueTimer.Fire()
at System.Threading.TimerQueue.FireNextTimers()

Causa

Este problema puede producirse si hay un tipo de datos incorrecto dentro de una o varias filas de la tbl_VMM_GlobalSetting tabla en la base de datos de Virtual Machine Manager.

Solución

Para resolver este problema, realice una copia de seguridad completa de la base de datos de Virtual Machine Manager y, a continuación, ejecute la siguiente consulta SQL en la base de datos de Virtual Machine Manager:

update tbl_VMM_GlobalSetting
set PropertyValue = NULL where PropertyName ='UpgradeTime'

Nota:

Para obtener información sobre cómo ejecutar esta consulta, consulte la sección Más información .

Una vez completada la consulta SQL, inicie el servicio System Center Virtual Machine Manager. La consola debería iniciarse y conectarse correctamente.

Más información

Para ejecutar la consulta SQL en la base de datos de Virtual Machine Manager, siga estos pasos.

  1. Realice una copia de seguridad de la base de datos de Virtual Machine Manager:

    1. En la consola de Virtual Machine Manager, abra el área de trabajo Configuración .
    2. En la pestaña Inicio , en el grupo Copia de seguridad , seleccione Copia de seguridad.
    3. En el cuadro de diálogo Copia de seguridad de Virtual Machine Manager, especifique dónde guardar el archivo de copia de seguridad y, a continuación, seleccione Aceptar.

    Nota:

    Puedes comprobar el estado de la copia de seguridad en el área de trabajo Trabajos.

  2. Detenga el servicio Virtual Machine Manager.

  3. Abra Microsoft SQL Server Management Studio y vaya a la base de datos VirtualManagerDB .

    Vaya a la base de datos VirtualManagerDB en Microsoft SQL Server Management Studio.

  4. En la barra de herramientas, seleccione Nueva consulta.

    Haz clic en el botón Nueva consulta de la barra de herramientas.

  5. Copie y pegue la consulta siguiente en la ventana:

    update tbl_VMM_GlobalSetting
    set PropertyValue = NULL
    where PropertyName ='UpgradeTime'
    

    Seleccione ! Ejecute para ejecutar la consulta. Asegúrese de que la consulta finaliza correctamente. Los resultados serán similares a la siguiente captura de pantalla:

    Resultado de la consulta que se devuelve después de ejecutar Execute.

  6. Reinicie el servicio Virtual Machine Manager.

Para obtener más información sobre cómo usar SQL Server Management Studio, consulte ¿Qué es SQL Server Management Studio (SSMS)?