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No se puede autenticar debido a una actualización incorrecta del controlador de tarjeta inteligente piV

En este artículo se describe cómo resolver un problema en el que los usuarios no pueden iniciar sesión en Windows hasta que se quite el controlador incorrecto.

Se aplica a: Windows 10, versión 2004, Windows 10, versión 1909, Windows 10, versión 1903
Número de KB original: 4563240

Resumen

Si usa una tarjeta inteligente de verificación de identidad personal (PIV) o cualquier dispositivo multifunción que use tarjetas inteligentes PIV que se basan en el Minidriver de tarjeta inteligente de la Bandeja de entrada de Windows, es posible que haya recibido una actualización incorrecta del controlador. Al intentar usar una tarjeta inteligente para autenticarse en Windows, es posible que reciba mensajes de error como "Esta tarjeta inteligente no se puede usar" o "La operación requiere una tarjeta inteligente diferente".

La actualización incorrecta contiene la aplicación de proveedor "FEITIAN - SmartCard - 1.0.0.3" que instala el controlador feitian xPass Smart Card. Se trata de una actualización legítima y firmada publicada por un asociado comprobado. Sin embargo, se ha dirigido involuntariamente a un conjunto más amplio de dispositivos de los que originalmente se ha diseñado para.

El controlador se ha extraído del sistema de publicación de Windows Update. Para mitigar los efectos adversos, cualquier usuario que recibió la actualización tiene que revertir manualmente al controlador de bandeja de entrada de Windows. Para obtener más información, consulte la sección "Resolución".

Síntomas

Observa uno o varios de los síntomas siguientes:

  • Intenta iniciar sesión en Windows mediante una tarjeta inteligente PIV o un dispositivo (como YubiKey) que admita tarjetas inteligentes PIV y se base en el Minidriver de tarjeta inteligente de la Bandeja de entrada de Windows. Sin embargo, no puede iniciar sesión.
  • Intenta iniciar sesión en Windows mediante un dispositivo inteligente PIV sin marca Feitian. Sin embargo, no puede iniciar sesión. Si el dispositivo admite funcionalidades de Fast Identity Online (FIDO), como U2F o FIDO2, esas funcionalidades siguen funcionando.
  • El controlador de tarjeta inteligente xPass no es válido y no interactúa correctamente con otros dispositivos que no son Feitian que dependen del controlador de la bandeja de entrada. Esto genera mensajes de error como "No se puede usar esta tarjeta inteligente".

En el ejemplo siguiente se muestran los resultados del comando certutil -scinfo que se ejecuta en un equipo afectado. Los certificados se generaron como parte de una inscripción de Microsoft AD CS. Sin embargo, ya no pueden interactuar con el dispositivo PIV YubiKey después de instalar el controlador de tarjeta inteligente xPass.

Captura de pantalla de la salida del comando certutil -scinfo, que indica que hay un problema con el controlador de tarjeta inteligente PIV.

Causa

La versión 1.0.0.3 del controlador Feitian xPass Smart Card especifica SCFILTER\CID_2777BE07-6993-4513-BD80-C184FCB0AB2D como identificador compatible en el archivo .inf de su paquete de controladores. Sin embargo, el minidriver de tarjeta inteligente de la bandeja de entrada de Windows para tarjetas inteligentes PIV (Dispositivo de identidad (NIST SP 800-73 [PIV])) usa el mismo identificador compatible. Si conecta un dispositivo que no sea Feitian que use el controlador de bandeja de entrada al equipo, Windows reconoce el controlador Feitian como compatible. Windows descarga, instala y carga el controlador Feitian.

Para obtener más información sobre cómo Windows selecciona controladores para un dispositivo, vea Información general sobre el proceso de selección de controladores y Cómo Windows selecciona un controlador para un dispositivo.

Solución

Si el controlador feitian xPass Smart Card se ha instalado en el equipo, tiene que quitarlo para revertir al controlador de identidad de bandeja de entrada (NIST SP 800-73 [PIV]). Después de quitar el controlador de tarjeta inteligente xPass, Windows carga automáticamente el controlador de bandeja de entrada para el dispositivo.

Para ello, puede eliminar manualmente el controlador o crear y ejecutar un script para eliminarlo.

Determinar si el equipo se ve afectado

En Configuración, seleccione Actualizaciones y historial de actualizaciones de vista de seguridad>. Debería poder identificar la actualización del controlador en la lista.

Captura de pantalla de la lista Actualización de controladores en la lista historial de actualizaciones de Windows.

Eliminar manualmente el controlador

Para quitar manualmente el controlador, siga estos pasos:

  1. Conecte el dispositivo de tarjeta inteligente al equipo.

  2. Inicie el Administrador de dispositivos. Puedes iniciar Administrador de dispositivos desde Panel de control, o presionando Windows + R y después escribiendo devmgmt.msc.

  3. Seleccione Tarjetas inteligentes, haga clic con el botón derecho en xPass Smart Card y, a continuación, seleccione Desinstalar dispositivo.

    Captura de pantalla de la opción Desinstalar dispositivo de xPass Smard Card en Administrador de dispositivos.

  4. Cuando se le solicite, seleccione Eliminar el software del controlador para este dispositivo y, a continuación, seleccione Desinstalar.

    Captura de pantalla de la opción Eliminar el software del controlador para este dispositivo en el cuadro de diálogo Desinstalar dispositivo.

Creación de un script para eliminar el controlador

Para automatizar la eliminación del controlador, cree un script que se pueda ejecutar en un archivo por lotes. El script identifica el nombre del archivo .inf del controlador y usa PnPUtil.exe para eliminar el controlador. El script puede eliminar el controlador incluso si una tarjeta inteligente o un dispositivo de tarjeta inteligente no está conectado al equipo. Para crear y usar este script, siga estos pasos:

  1. Cree un archivo por lotes que contenga la siguiente secuencia de comandos:

    @echo off
    
    for /r %windir%\System32\DriverStore\FileRepository %%i in (*eps_piv_csp11.inf*) do (@echo %%i  
    pnputil /delete-driver %%i /uninstall /force)
    
    pause
    
  2. En el equipo afectado, ejecute el archivo por lotes en una ventana del símbolo del sistema administrativo.

Más información

Si ha seguido los pasos descritos en la sección "Resolución", pero necesita ayuda adicional, vaya al sitio web de Soporte técnico de Microsoft.