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Error del sistema 126 al iniciar el servicio Windows Modules Installer (TrustedInstaller): no se encontró el módulo específico

Este artículo ayuda a corregir el error 126 del sistema que se produce al iniciar el servicio Windows Modules Installer.

Se aplica a: Windows 7 Service Pack 1, Windows Server 2008 R2 Service Pack 1
Número de KB original: 959077

Síntomas

Al iniciar el servicio Windows Modules Installer, recibirá el siguiente mensaje de error:

Captura de pantalla del error 126 del servicio Windows Modules Installer.

También recibirá un mensaje de error en el símbolo del sistema:

Captura de pantalla del mensaje de error en el símbolo del sistema: error del sistema 126 se ha producido.

Causa

Este problema se produce si se cambia la siguiente subclave del Registro:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Component Based Servicing\Version

Solución

Para resolver este problema, debe volver a crear el valor de cadena expandible de la subclave del Registro que se menciona en la sección Causa .

En primer lugar, debe comprobar si existe la subclave del Registro. Para ello, inicie el Editor del Registro y, a continuación, vaya a la subclave que se menciona en la sección Causa . Si la subclave no existe, debe crearla. Para ello, siga estos pasos:

  1. Busque el C:\Windows\Servicing\Version directorio y anote el nombre de la subcarpeta en este directorio. Se le denominará como 6.1.7600.16385. Este es el identificador de TrustedInstaller.

  2. Copie el nombre de la subcarpeta en el Portapapeles y péguelo en el Bloc de notas para el mantenimiento seguro.

    Captura de pantalla del nombre de la subcarpeta en este directorio.

    Nota:

    En este ejemplo, el identificador trustedInstaller es 6.1.7601.17592.

  3. En el C:\Windows\WinSxS directorio, busque una subcarpeta cuyo nombre comience por una de las cadenas siguientes. (En los siguientes nombres de subcarpeta, el marcador de posición TrustedInstaller ID representa el id. de TrustedInstaller).

    Para Windows de 32 bits: x86_microsoft-windows-servicingstack_31bf3856ad364e35_ TrustedInstaller ID _none

    Para Windows de 64 bits: amd64_microsoft-windows-servicingstack_31bf3856ad364e35_ TrustedInstaller ID _none

  4. Copie el nombre de la subcarpeta en el Portapapeles y péguelo en el Bloc de notas para el mantenimiento seguro.

    Captura de pantalla del resultado de búsqueda del nombre de la subcarpeta En el directorio C:\Windows\WinSxS.

  5. Cree la subclave HKLM\Software\Microsoft\Windows\CurrentVersion\Component Based Servicing\Versiondel Registro .

    Nota:

    Para crear esta clave, debe ser propietario de la clave de mantenimiento basada en componentes. A continuación, tendrá que conceder permisos de acceso total.

  6. En la clave versión que creó en el paso 5, cree un valor de cadena expandible (o edítelo si ya existe). Para ello, use el identificador trustedInstaller como nombre y use la ruta de acceso completa de la carpeta que identificó en el paso 3 como valor.

    Nota:

    En la ruta de acceso completa, debe usar %SystemRoot%\WinSxS\folder_name en lugar de C:\Windows\WinSxS\folder_name.

    Captura de pantalla de una configuración de valor de cadena de ejemplo de la clave de versión.

  7. Haga clic en Aceptar y, a continuación, salga del Editor del Registro.

Ahora puede iniciar el servicio Windows Modules Installer (TrustedInstaller) como de costumbre.

Recolección de datos

Si necesita ayuda del soporte técnico de Microsoft, le recomendamos que recopile la información siguiendo los pasos mencionados en Recopilación de información mediante TSS para problemas relacionados con la implementación.