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En este artículo se describe cómo resolver un problema en el que el servicio LanManWorkstation no se inicia y Windows genera el error 2250.
Se aplica a: Windows Server 2022, Windows Server 2019, Windows 11, Windows 10
Síntomas
El servicio LanmanWorkstation no se inicia y Windows genera el siguiente mensaje:
Windows no pudo iniciar la estación de trabajo en el equipo local. Para obtener más información, revise el registro de eventos del sistema. Si se trata de un servicio que no es de Microsoft, póngase en contacto con el proveedor de servicios y consulte el código de error 2250 específico del servicio.
Nota:
Este comportamiento podría afectar a otros servicios además del servicio LanmanWorkstation.
Causa
Este error suele indicar que falta la siguiente entrada del Registro volátil:
Subclave del Registro:
HKLM\SYSTEM\CurrentControlSet\Control\ComputerName\ActiveComputerName
- Tipo de registro: REG_SZ
- Clave del Registro:
ComputerName
- Valor: <Computer_Name>
Este valor debe ser el mismo que el valor de la siguiente entrada no volátil:
Subclave del Registro:
HKLM\SYSTEM\CurrentControlSet\Control\ComputerName\ComputerName
- Tipo de registro: REG_SZ
- Clave del Registro: NombreDeEquipo
- Valor: <Computer_Name>
Nota:
En ambas entradas del Registro, <Computer_Name> representa el nombre del equipo local.
Solución
Importante
Esta sección, método o tarea contiene pasos que le indican cómo modificar el Registro. No obstante, pueden producirse problemas graves si modifica el registro de manera incorrecta. Por lo tanto, asegúrese de que sigue estos pasos con atención. Como medida de protección, haga una copia de seguridad del registro antes de modificarlo para poder restaurarlo si se produce algún problema. Para obtener más información sobre cómo realizar copias de seguridad y restaurar el registro, vea Cómo hacer copia de seguridad y restaurar el registro en Windows.
Para resolver este problema, agregue la entrada del Registro que falta en el equipo afectado. Use el Editor del Registro para crear manualmente la entrada o abra una ventana del símbolo del sistema administrativo y, a continuación, ejecute el siguiente comando:
reg add HKLM\SYSTEM\CurrentControlSet\Control\ComputerName\ActiveComputerName /t REG_SZ /v ComputerName /d <Computer_Name> /f
Nota:
En este comando, <Computer_Name> representa el nombre del equipo local.
Después de editar el registro, reinicie el equipo.