Nota
El acceso a esta página requiere autorización. Puede intentar iniciar sesión o cambiar directorios.
El acceso a esta página requiere autorización. Puede intentar cambiar los directorios.
En este artículo se proporciona una solución a un problema por el que falta la opción Microsoft: EAP protegido (PEAP) en algunos casos.
Se aplica a: Windows 7 Service Pack 1
Número de KB original: 2699785
Síntomas
Hay varios síntomas para el problema:
- Microsoft: Puede que falte la opción EAP (PEAP) protegida al crear el perfil inalámbrico en un cliente.
- Microsoft: la opción EAP (PEAP) protegida puede faltar una vez que iniciemos la transferencia de archivos mediante el Asistente para transferencia sencilla de ventanas.
- El Administrador de conexiones de acceso remoto no se inicia.
Causa
La ubicación predeterminada del archivo SymRasMan.dll es %SystemRoot%\System32\rastls.dll. Al instalar Symantec Antivirus o Symantec Endpoint Protection, la ubicación predeterminada se cambia y edita en el Registro en C:\Archivos de programa\ Symantec\Symantec Endpoint Protection \SymRasMan.dll. Después de desinstalar esta ubicación no se invierte. El problema se produce debido a un problema con las claves del Registro que no se revierten a los valores predeterminados o .dll archivos indicados en los valores del Registro no existen después de quitar Symantec Endpoint Protection 11.0.
Estos dos subárboles del Registro se ven afectados:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RasMan\PPP\EAP\25
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RasMan\PPP\EAP\13
Los valores de las claves siguientes en EAP se modifican de C:\System32\rastls.dll a C:\Archivos de programa\Symantec\Symantec Endpoint Protection\SymRasMan.dll.
- ConfigUiPath
- IdentityPath
- InteractiveUIPath
- Ruta de acceso
4 nuevas claves del Registro con su valor como C:\Windows\ System32\rastls.dll se crean.
- ConfigUiPathBack
- IdentityPathBack
- InteractiveUIPathBack
- PathBack
Solución
Importante
Esta sección, método o tarea contiene pasos que le indican cómo modificar el Registro. No obstante, pueden producirse problemas graves si modifica el registro de manera incorrecta. Por lo tanto, asegúrese de que sigue estos pasos con atención. Para la protección añadida, realice una copia de seguridad del Registro antes de modificarlo. A continuación, puede restaurar el Registro si se produce un problema.
Para resolver este problema, modifique el Registro para corregir los valores de ConfigUiPath, IdentityPath, InteractiveUIPath y Path. Para ello, siga estos pasos:
Haga clic en Inicio, en Ejecutar, escriba regedit& y, después, haga clic en Aceptar.
Busque la siguiente subclave del Registro y haga clic en ella:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RasMan\PPP\EAP\13
.Seleccione la carpeta 13.
Cambie el valor de las claves: ConfigUiPath, IdentityPath, InteractiveUIPath y Path a: C:\Windows\ System32\rastls.dll
Vaya a
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RasMan\PPP\EAP\25
.Seleccione la carpeta 25.
Cambie el valor de las claves: ConfigUiPath, IdentityPath, InteractiveUIPath y Path a: C:\Windows\ System32\rastls.dll.
Elimine las siguientes claves en la carpeta 13 y 25.
Ubicación:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RasMan\PPP\EAP\13
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RasMan\PPP\EAP\25
Claves del Registro:
- ConfigUiPathBack
- IdentityPathBack
- InteractiveUIPathBack
- PathBack
Existe el editor del Registro y, a continuación, reinicia el equipo.