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NMI_HARDWARE_FAILURE error cuando se desencadena una NMI en Windows

En este artículo se describe un comportamiento por diseño en el que el NMI_HARDWARE_FAILURE error se produce cuando se desencadena una interrupción no enmascarable (NMI).

Número de KB original: 2750146

Síntomas

En un equipo Windows, un NMI puede desencadenarse manualmente al presionar un conmutador NMI en el equipo o debido a un error de hardware.

En este caso, Windows deja de ejecutarse y muestra una pantalla azul, que indica "Su PC se encontró con un problema y necesita reiniciarse". Incluye el siguiente código de error: NMI_HARDWARE_FAILURE.

Después, el equipo puede guardar un archivo de volcado de memoria y puede reiniciarse automáticamente, en función de la configuración especificada en "Inicio y recuperación" en la "Configuración avanzada del sistema" en el panel de control Sistema.

Causa

El comportamiento cuando se encuentra una NMI ha cambiado en comparación con las versiones anteriores de Windows. En Windows 7, Windows Server 2008 R2 y versiones anteriores, la respuesta cuando el sistema encontró una NMI dependía de la configuración del valor del Registro "NMICrashDump". Para obtener más información sobre el valor del Registro NMICrashDump y el control de las NMIs en versiones anteriores de Windows, haga clic en el número de artículo siguiente para ver el artículo en Microsoft Knowledge Base:
927069 Cómo generar un archivo de volcado de memoria completo o un archivo de volcado de memoria del kernel mediante un NMI en un sistema basado en Windows

En Windows 8 y Windows Server 2012, este comportamiento no es configurable. Una NMI siempre producirá una comprobación de errores 0x80 (NMI_HARDWARE_FAILURE). Esto equivale al comportamiento en versiones anteriores de Windows en las que el valor del Registro "NMICrashDump" estaba presente y establecido en un valor de 1.

Más información

Este comportamiento es por diseño.