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La configuración del proveedor de red se quita durante una actualización local a Windows 10

En este artículo se proporcionan soluciones alternativas a un problema en el que se quita la configuración del proveedor de red durante una actualización local a Windows 10.

Se aplica a: Windows 10, versión 1809, Windows 10, versión 1709, Windows 10, versión 1703, Windows 10, versión 1607
Número de KB original: 4013822

Síntomas

Al realizar una actualización local a Windows 10, versión 1809, versión 1709, versión 1703 o versión 1607, la configuración del proveedor de red de terceros se quita del equipo.

Causa

Se trata de un problema conocido en el proceso de actualización de Windows 10. Después de la actualización, se restablece la lista de proveedores (HKLM\SYSTEM\CurrentControlSet\Control\NetworkProvider) y se quita la configuración del Registro del proveedor de terceros (en HKLM\System\CurrentControlSet\Services\).

Solución alternativa

Importante

Esta sección, método o tarea contiene pasos que le indican cómo modificar el Registro. No obstante, pueden producirse problemas graves si modifica el registro de manera incorrecta. Por lo tanto, asegúrese de que sigue estos pasos con atención. Para la protección añadida, realice una copia de seguridad del Registro antes de modificarlo. A continuación, puede restaurar el Registro si se produce un problema. Para obtener más información sobre cómo realizar copias de seguridad y restaurar el registro, vaya al siguiente artículo de Microsoft Knowledge Base:
322756 Hacer una copia de seguridad del Registro y restaurarlo en Windows

Para evitar este problema, utilice uno de los métodos siguientes.

Método 1

  1. Antes de actualizar, realice manualmente una copia de seguridad del contenido de la lista de proveedores en HKLM\SYSTEM\CurrentControlSet\Control\NetworkProvider y la configuración del proveedor de terceros correspondiente (en HKLM\System\CurrentControlSet\Services\).
  2. Ejecute la actualización.
  3. Una vez completada la actualización, restaure la configuración del Registro de la que se realizó una copia de seguridad en el paso 1.

Método 2

Si tiene problemas que afectan a la configuración del proveedor de red de terceros después de la actualización, restaure manualmente las claves del Registro eliminadas por el instalador.

Más información

Para comprobar la lista de proveedores de red, siga estos pasos:

  1. Abra el cuadro Ejecutar . Para ello, presione la tecla del logotipo de Windows ( )+R.

  2. Escriba ncpa.cpl y presione Entrar.

  3. Presione la tecla Alt para abrir la barra de menús.

  4. Seleccione Opciones avanzadas y, a continuación, haga clic en Configuración avanzada.

    Captura de pantalla del cuadro de diálogo Configuración avanzada.

Esta lista de proveedores de red de terceros se almacena en la siguiente ubicación del Registro:
HKLM\SYSTEM\CurrentControlSet\Control\NetworkProvider\Order\ProviderOrder
Valor predeterminado: RDPNP,LanmanWorkstation,webclient
HKLM\System\CurrentControlSet\Control\NetworkProvider\HwOrder\ProviderOrder
Valor predeterminado: RDPNP,LanmanWorkstation,webclient

Nota:

Cada valor de cadena tiene su propia configuración en HKLM\System\CurrentControlSet\Services.
Por ejemplo, a continuación se muestran los proveedores de red predeterminados:

  • HKLM\System\CurrentControlSet\Services\RDPNP\NetworkProvider
  • HKLM\System\CurrentControlSet\Services\LanmanWorkstation\NetworkProvider
  • HKLM\System\CurrentControlSet\Services\WebClient\NetworkProvider

El nombre del proveedor se quita de la lista y se quitan todas las claves del Registro agregadas.

Recolección de datos

Si necesita ayuda del soporte técnico de Microsoft, le recomendamos que recopile la información siguiendo los pasos mencionados en Recopilación de información mediante TSS para problemas relacionados con la implementación.