Compartir a través de


Error "El tiempo de espera de la operación" al crear una partición mediante la consola de administración de discos o DiskPart.exe

Este artículo ayuda a corregir el error "El tiempo de espera de la operación" al crear una partición mediante la consola de administración de discos o DiskPart.exe.

Se aplica a: Windows Server 2012 R2, Windows Server 2008 R2 Service Pack 1
Número de KB original: 2826890

Síntomas

  • Al intentar crear un nuevo volumen en Administración de discos (diskmgmt.msc), puede recibir el siguiente mensaje de error:

    No se pudo completar la operación porque la vista de la consola de administración de discos no está actualizada. Actualice la vista mediante la tarea de actualización. Si el problema persiste, cierre la consola de administración de discos y, a continuación, reinicie Administración de discos o reinicie el equipo.

  • Si intenta crear una nueva partición mediante Diskpart.exe, puede recibir un mensaje de error similar al siguiente:

    Error del servicio de disco virtual:
    La operación ha agotado el tiempo de espera.

    Diskpart ha realizado referencia a un objeto que no está actualizado.
    Actualice el objeto mediante el comando RESCAN.
    Si el problema persiste, salga de DiskPart, reinicie DiskPart o reinicie el equipo.

  • Además, puede ver una ventana emergente con la siguiente información:

    Se encontró nuevo hardware
    Windows debe instalar software de controlador para el dispositivo desconocido

Causa

Estos problemas se producen si falta volume.inf en %Systemroot%\inf la carpeta.

Solución

Para resolver el problema, siga estos pasos:

  1. Abra un símbolo del sistema con privilegios elevados. Para ello, haga clic en Inicio, Todos los programas, Accesorios, Símbolo del sistema y, a continuación, haga clic en Ejecutar como administrador.

  2. En el símbolo del sistema, escriba el siguiente comando y presione Entrar: sfc /verifyonly

  3. Si se encontraron problemas en el comando anterior, escriba el siguiente comando y presione Entrar. Deje que se complete la operación de comando:
    sfc /scannow

  4. Abra el Explorador de Windows y vaya a la carpeta.%Systemroot%\inf

  5. Compruebe si se ha reemplazado el archivo volume.inf . Si el archivo no se reemplaza, debe copiar volume.inf desde otro equipo que ejecute la misma versión de Windows, la misma versión de Service Pack y la misma arquitectura de CPU.

Recolección de datos

Si necesita ayuda del soporte técnico de Microsoft, le recomendamos que recopile la información siguiendo los pasos mencionados en Recopilación de información mediante TSS para problemas relacionados con la implementación.