Compartir a través de


La aplicación de Microsoft Store no se puede iniciar cuando un usuario instala una versión anterior a la versión actual instalada por otro usuario en Windows 10

En este artículo se proporciona ayuda para corregir un problema por el que la aplicación de Microsoft Store no se puede iniciar cuando un usuario instala una versión anterior a la versión actual instalada por otro usuario.

Se aplica a todas las ediciones de Windows 10
Número de KB original: 4055744

Síntoma

Considere el caso siguiente:

  • En un equipo basado en Windows 10, inicia sesión como usuario A e instala una aplicación de Microsoft Store. Por ejemplo, Minecraft: Education Edition, instalado por System Center Configuration Manager como una aplicación sin conexión.
  • Actualizas la aplicación a una versión más reciente en línea desde Microsoft Store y, a continuación, cierras la sesión como Usuario A.
  • Inicia sesión como usuario B e instala la versión anterior de la aplicación.

En este escenario, no puede usar la aplicación al iniciar sesión como usuario A. Además, al iniciar sesión como usuario B, no se puede actualizar la aplicación.

Este problema puede producirse cuando se usa System Center Configuration Manager para implementar la versión anterior de una aplicación sin conexión y, a continuación, el usuario actualiza la aplicación en línea desde Microsoft Store. Verá el error 0x3 en la consola de Configuration Manager al supervisar el estado de la aplicación.

Causa

Este problema se produce cuando el usuario B instala la versión anterior de la aplicación y la instalación reemplaza los archivos compartidos por versiones anteriores.

Solución alternativa

Los pasos siguientes pueden corregir este problema para los usuarios en un equipo específico:

  1. Confirme que el archivo activationStore.dat no existe en el directorio AppRepository. Por ejemplo: C:\ProgramData\Microsoft\Windows\AppRepository\Packages\Microsoft.MinecraftEducationEdition_0.21.0_x64__8wekyb3d8bbwe\ActivationStore.dat

  2. Ejecute el siguiente comando para establecer la clave del Registro para la aplicación específica. Por ejemplo, Minecraft (Microsoft.MinecraftEducationEdition_1.0.21.0_x64___8wekyb3d8bbwe):

    reg add HKLM\Software\Microsoft\Windows\CurrentVersion\AppModel\StateChange\PackageList\Microsoft.MinecraftEducationEdition_1.0.21.0_x64__8wekyb3d8bbwe /v PackageStatus /t REG_DWORD /d 2
    
  3. Copie el archivo application.appx en una carpeta local, por ejemplo: C:\Temp\Microsoft.MinecraftEducationEdition_1.0.21.0_x64__8wekyb3d8bbwe.appx.

  4. Establezca el siguiente comando para volver a implementar la aplicación para que se ejecute cada vez que un usuario inicie sesión. Por ejemplo, Minecraft (Microsoft.MinecraftEducationEdition_1.0.21.0_x64___8wekyb3d8bbwe):

    powershell.exe Add-AppxPackage -Path C:\Temp\Microsoft.MinecraftEducationEdition_1.0.21.0_x64__8wekyb3d8bbwe.appx
    

    Nota:

    Si usa Configuration Manager, no implemente el paquete de aplicación como una aplicación de Configuration Manager.

Solución

Si usa Configuration Manager, consulte Administración de aplicaciones desde el Microsoft Store para Empresas con System Center Configuration Manager para ayudar a elegir entre actualizaciones de aplicaciones en línea o sin conexión.

Este problema no se producirá en Windows 10 versión 1709 y se corregirá para las versiones anteriores en una próxima actualización de calidad.