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En este artículo se proporciona una solución a un problema por el que la pantalla negra de Windows al desbloquear un equipo.
Se aplica a: Windows 7 Service Pack 1
Número de KB original: 2431700
Síntomas
Considere el caso siguiente:
- Un equipo Windows Vista o Windows 7 ejecuta el modo gráfico "Aero".
- El equipo Windows Vista o Windows 7 está sujeto a restricciones de seguridad adicionales y software de seguridad, como puede ser el caso de la empresa, o con la configuración de seguridad y software obligatorios, como los requisitos de DISA o DoD.
- El equipo está bloqueado y se deja lo suficientemente largo como para que la pantalla vaya negra, que es de 20 minutos con la directiva de alimentación predeterminada de "Equilibrado".
- Una persona desbloquea el equipo escribiendo sus credenciales de usuario.
Después de escribir la credencial, la pantalla se pone en negro y permanece negra durante hasta 10 minutos o más. La máquina no está "bloqueada de forma dura", ya que la actividad periódica de la unidad de disco se puede anotar desde la luz indicadora de unidad de disco en el equipo, si es así equipado.
Causa
Un problema con algún nivel de software de seguridad hace que el Administrador de ventanas de escritorio espere una cantidad de tiempo no especificada.
Solución
Una solución temporal es detener y deshabilitar el servicio "Administrador de sesiones del Administrador de sesiones del Administrador de ventanas de escritorio". Al deshabilitar este servicio se desactivará la característica de visualización de gráficos "Aero", que deshabilitará ciertas características como Aero Peek, Aero Snap, Aero Shake, etc. Para deshabilitar este servicio:
- Haga clic en el botón Inicio , escriba services.msc y presione la tecla ENTRAR o haga clic en el icono que aparece en Programas en el cuadro Búsqueda instantánea.
- Busque y, a continuación, haga doble clic en el servicio Administrador de sesiones del Administrador de sesiones del Administrador de ventanas de escritorio.
- Busque la lista desplegable Tipo de inicio y cambie el valor a "disabled".
- Busque y haga clic en el botón con la etiqueta "Detener".
- Haga clic en el botón Aplicar y, a continuación, haga clic en el botón Aceptar .
Como alternativa, puede ejecutar los siguientes comandos desde un símbolo del sistema de CMD con privilegios elevados para establecer las propiedades de servicio del servicio Administrador de sesiones del Administrador de ventanas de escritorio para que no se ejecute y deshabilite:
net stop UxSms sc config UxSms start= disabled
Para devolver la configuración del servicio Administrador de sesiones del Administrador de sesiones del Administrador de ventanas de escritorio a la normalidad a través de la línea CMD:
sc config UxSms start= auto net start UxSms
Los controladores de pantalla actualizados pueden resolver este problema. Puede determinar el fabricante del adaptador de pantalla siguiendo estos pasos:
- Haga clic en Inicioy, en el cuadro de texto Buscar programas y carpeta, escriba MSINFO32 (sin comillas) y presione ENTRAR.
Nota:
Debería aparecer la herramienta Información del sistema.
- En la sección de la izquierda denominada Resumen del sistema, busque Componentes y, en Componentes , busque y haga clic en Mostrar.
- La sección derecha de Información del sistema ahora debería mostrar información sobre el sistema de visualización en el equipo. El elemento denominado "Name" debe indicar el tipo de adaptador de pantalla.
- En este momento puede ir al sitio web de Internet del proveedor o al proveedor de su equipo para buscar controladores actualizados.
- En algunos casos, puede ofrecer controladores de vídeo actualizados mediante la ejecución de Windows Update.
- Si no está seguro de qué controladores instalar, póngase en contacto con el proveedor del hardware del equipo para obtener ayuda para localizar un paquete de controladores de pantalla actualizado.
- Haga clic en Inicioy, en el cuadro de texto Buscar programas y carpeta, escriba MSINFO32 (sin comillas) y presione ENTRAR.
Otra solución consiste en detectar qué nivel de software de seguridad está causando el bloqueo temporal, que representa la pantalla negra y, por tanto, inutilizable. Esa capa de software tendría que desinstalarse o actualizarse para evitar la condición de bloqueo en el Administrador de ventanas de escritorio.
Más información
Un síntoma que se ha observado si esta condición es cierta es que el proceso DWM o Administrador de ventanas de escritorio consumirá una cantidad cada vez mayor de memoria, tal como se muestra en el Administrador de tareas.