Nota
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En este artículo se proporciona una resolución del error "No hay suficiente almacenamiento disponible para completar esta operación", cuando se usa un controlador de dominio para unir un equipo a un dominio.
Número de KB original: 935744
Síntomas
Cuando usa un controlador de dominio de versión de Microsoft Windows Server 2003 o posterior para unir un equipo cliente de Microsoft Windows XP o una versión posterior a un dominio, puede recibir un mensaje de error similar al siguiente en el equipo cliente:
Se produjo el siguiente error al intentar unirse al dominio "domain_name.com": No hay suficiente almacenamiento disponible para completar esta operación.
Además, el siguiente mensaje de advertencia puede iniciar sesión en el registro del sistema en el equipo cliente:
Causa
Este problema se produce porque el token kerberos que se genera durante la autenticación es mayor que el tamaño máximo fijo. En la versión de lanzamiento original de Microsoft Windows 2000, el valor predeterminado de la entrada del Registro MaxTokenSize era de 8000 bytes. En Windows 2000 con Service Pack 2 (SP2) y en versiones posteriores de Windows, el valor predeterminado de la entrada del Registro MaxTokenSize es de 12 000 bytes.
Por ejemplo, si un usuario es miembro de un grupo directamente o por pertenencia a otro grupo, el identificador de seguridad (SID) de ese grupo se agrega al token del usuario. Para que se agregue un SID al token del usuario, la información del SID se debe comunicar mediante el token kerberos. Si la información de SID necesaria supera el tamaño del token, la autenticación no se realiza correctamente.
Solución
Importante
Esta sección, método o tarea contiene pasos que le indican cómo modificar el Registro. No obstante, pueden producirse problemas graves si modifica el registro de manera incorrecta. Por lo tanto, asegúrese de que sigue estos pasos con atención. Para la protección añadida, realice una copia de seguridad del Registro antes de modificarlo. Después, puede restaurar el registro si se produce un problema. Para obtener más información acerca de cómo realizar una copia de seguridad y restaurar el Registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322756 Hacer una copia de seguridad del Registro y restaurarlo en Windows
Para resolver este problema, aumente el tamaño del token kerberos. Siga estos pasos en el equipo cliente que registra el evento Kerberos.
Haga clic en Inicio y en Ejecutar, escriba regedit y, luego, haga clic en Aceptar.
Busque la siguiente subclave del Registro y haga clic en ella:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\Kerberos\Parameters
Nota:
Si la clave Parameters no está presente, cree la clave. Para ello, siga estos pasos:
- Busque la siguiente subclave del Registro y haga clic en ella:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\Kerberos
- En el menú Editar , seleccione Nuevoy, a continuación, haga clic en Clave.
- Escriba Parámetros y presione ENTRAR.
- Busque la siguiente subclave del Registro y haga clic en ella:
En el menú Edición, seleccione Nuevo y haga clic en Valor DWORD.
Escriba MaxTokenSize y presione ENTRAR.
En el menú Editar , haga clic en Modificar.
En el área Base , haga clic en Decimal, escriba 65535 en el cuadro Datos de valor y, a continuación, haga clic en Aceptar.
Nota:
El valor predeterminado para la entrada del Registro MaxTokenSize es un valor decimal de 12 000. Se recomienda establecer este valor de entrada del Registro en un valor decimal de 65 535. Si establece incorrectamente este valor de entrada del Registro en un valor hexadecimal de 65 535, es posible que se produzca un error en las operaciones de autenticación Kerberos. Además, los programas pueden devolver errores.
Salga del Editor del Registro.
Reinicie el equipo.
Más información
Para obtener más información, haga clic en los números de artículo siguientes para ver los artículos de Microsoft Knowledge Base:
327825 Nueva resolución para problemas con la autenticación Kerberos cuando los usuarios pertenecen a muchos grupos