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En este artículo se resuelve el mensaje de error "Error en la llamada a procedimiento remoto y no se ejecutó". Este error se produce durante la replicación del controlador de dominio (DC) en Windows Server.
Se aplica a: Windows Server (todas las versiones con soporte)
Número de KB original: 4019721
Síntomas
Este error de replicación de Active Directory (AD) aparece en uno o varios de los siguientes formularios:
- Decimal: 1727
- Hexadecimal: 0x6bf
- Simbólico: RPC_S_CALL_FAILED_DNE
- Mensaje de error: Error en la llamada a procedimiento remoto y no se ejecutó.
Causa
Este problema se produce debido a uno de los siguientes motivos:
- Un problema de conectividad de red entre los dos controladores de dominio (CONTROLADORES). Vea las secciones siguientes para obtener información.
- Un problema de rendimiento provocado por la carga en el asociado de replicación. Este problema es menos común y suele ser transitorio por naturaleza. Vea las secciones siguientes para obtener información.
Acerca del problema de conectividad de red
Este problema se produce cuando el asociado de replicación del controlador de dominio no puede completar la conexión RPC al servicio RPC de la replicación de AD (DRSR UUID E3514235-4B06-11D1-AB04-00C04FC2DCD2). Más concretamente, el asociado de replicación puede enlazar con el asignador de puntos de conexión RPC, pero no puede completar el enlace RPC de DRSR.
Entre las posibles causas principales se incluyen las siguientes:
- servidores de seguridad
- enrutadores
- Optimizadores de WAN
- otros dispositivos de red intermedios
- controladores de filtro de red
Acerca del problema de rendimiento
Este problema se produce cuando se cumple una de las condiciones siguientes:
- El servidor está desfasado y no responde a tcp ACK ni al mensaje de respuesta. Por lo tanto, el remitente abandona la sesión TCP.
- La red es demasiado lenta o no confiable. No puede entregar el ACK TCP ni el mensaje de respuesta.
Solución
Para resolver este problema, determine los cambios recientes que afectarían a la red entre los dos controladores de dominio y deshaga esos cambios si es posible. Si no hay cambios recientes, debe examinar completamente la conectividad de red RPC entre los dos controladores de dominio. Para ello, siga los pasos de solución de problemas de alto nivel o los pasos de solución de problemas detallados.
Pasos de solución de problemas de alto nivel
Tome una captura de red de doble lado mientras reproduce el problema. Para ello, siga los pasos que se indican a continuación:
- Inicie una captura de red en ambos controladores de dominio.
- Inicie manualmente la replicación entre los dos controladores de dominio.
- Detenga ambos lados del seguimiento cuando reciba el error.
Examine la conversación RPC entre los dos controladores de dominio. Determine si alguna vez hay un caso en el que el mensaje que se envía desde el controlador de dominio del solicitante no incurre en una respuesta del asociado de replicación.
Nota:
En ocasiones, hay una respuesta parcial que incluye el ACK TCP de piggy-back para el mensaje de solicitud. Pero el tráfico se ha modificado o la respuesta no llega realmente al controlador de dominio del solicitante. Por lo tanto, la pila TCP no recibe una ACK.
Pasos de la solución de problemas detallada
Inicie una captura de red en ambos controladores de dominio antes de realizar los pasos siguientes para probar la conectividad del controlador de dominio.
Prueba de la conectividad del controlador de dominio de origen desde el controlador de dominio de destino
Siga estos pasos en el controlador de dominio de destino:
Compruebe si el controlador de dominio de origen está escuchando en el puerto TCP 135. Para ello, ejecute el
PortQry.exe -n -e 135
comando .Si el estado del puerto es FILTERED, es probable que el error de replicación de AD produzca un error y devuelva el error 1722 en su lugar. Intente resolver el error 1722 y compruebe si la replicación de AD se realiza correctamente. Si el problema persiste, reinicie los pasos de solución de problemas detallados.
Si el estado no es FILTERED, los comandos devuelven la base de datos del asignador de puntos de conexión RPC. Busque MS NT Directory DRS Interface para buscar el puerto de intervalo superior en la base de datos del asignador de puntos de conexión en la que escucha el controlador de dominio de origen para la replicación de AD. Puede obtener una o varias entradas. Anote los puertos de ncacn_ip_tcp.
Por ejemplo, obtendrá algo similar al ejemplo siguiente, que presenta dos puertos de intervalo superior 49159 y 49160:
UUID: e3514235-4b06-11d1-ab04-00c04fc2dcd2 MS NT Directory DRS Interface ncacn_ip_tcp:2012dc[49159] UUID: e3514235-4b06-11d1-ab04-00c04fc2dcd2 MS NT Directory DRS Interface ncacn_ip_tcp:2012dc[49160]
Nota:
Los puertos de intervalo superior son específicos del controlador de dominio y se asignan dinámicamente. Sin embargo, un administrador puede codificar de forma rígida el puerto que se usa para la replicación de AD mediante el siguiente valor del Registro.
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NTDS\Parameters
Valor del Registro: puerto TCP/IP
Tipo de valor: REG_DWORD
Datos de valor: (puerto disponible)Pruebe la conectividad del puerto TCP con los puertos de intervalo superior que tenga en cuenta. Para ello, ejecute el comando siguiente:
PortQry.exe -n <SourceDC> -e <Upper_Range_Port_Number>
Por ejemplo, ejecute los siguientes comandos:
PortQry.exe -n 2012dc -e 49159 PortQry.exe -n 2012dc -e 49160
Si el estado del puerto es FILTERED, revise el seguimiento de red que ha capturado para determinar dónde está bloqueado el paquete.
Pruebe DNS. Compruebe que el controlador de dominio de destino puede resolver los registros CNAME y HOST del controlador de dominio de origen. Y compruebe que la dirección IP resuelta es la dirección IP real del controlador de dominio de origen. Si DNS apunta a una dirección IP antigua o no válida, se realiza un intento de conexión RPC a un controlador de dominio de origen incorrecto.
Prueba de la conectividad del controlador de dominio de destino desde el controlador de dominio de origen
Repita el paso 1 al 3 en el controlador de dominio de origen.
Recolección de datos
Si necesita ayuda del soporte técnico de Microsoft, se recomienda recopilar la información siguiendo los pasos mencionados en Recopilación de información mediante TSS para problemas de replicación de Active Directory.