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En este artículo se describe un problema en el que la configuración del servicio hora de Windows está deshabilitada en el Registro después de actualizar a Windows Server 2016 o Windows 10 versión 1607.
Número de KB original: 3201265
Síntomas
Al realizar una actualización local en las siguientes rutas de actualización de sistemas operativos, el servicio hora de Windows no conserva su configuración. En su lugar, muestra los valores predeterminados de un servidor o estación de trabajo de grupo de trabajo.
Actualización de | Actualización a |
---|---|
Windows Server 2012 o Windows Server 2012 R2 | Windows Server 2016 |
Windows 7, Windows 8 o Windows 8.1 | Windows 10 Versión 1607 |
Roles afectados
Una vez completada la actualización local, es posible que se vean afectados los siguientes roles.
Controladores de dominios
Los controladores de dominio (DC) que hospedan el rol del emulador de PDC son el servidor de hora autoritativo predeterminado para el dominio. Normalmente, está configurado para sincronizarse con un origen de hora muy preciso. Todos los demás controladores de dominio sincronizan su tiempo con el PDC.
Después de realizar una actualización local, el PDC pierde su conexión al servidor horario externo con el que está configurado para sincronizarse. Tampoco anuncia que es un servidor horario.
Todos los demás controladores de dominio del dominio ya no anuncian que son servidores de hora y ya no usan la jerarquía de dominios para sincronizar su tiempo. Por lo tanto, es posible que su configuración de tiempo ya no esté sincronizada con la configuración de sus pares y los miembros del dominio ya no puedan sincronizar su tiempo.
Puede observar la siguiente advertencia en la salida de DCDIAG:
Advertencia: <DCNAME> no está anunciando como servidor de hora
También puede observar que el controlador de dominio no responde a las solicitudes de cliente NTP. Incluye errores que se producen al probar la disponibilidad del servidor NTP mediante la w32tm.exe /stripchart
herramienta . Por ejemplo, la salida de texto puede parecerse a la siguiente salida:
c:>w32tm /stripchart /computer: <DCName> Tracking <DCName> [10.1.1.100:123]. La hora actual es 10/28/2016 9:00:00 AM. Error 09:00:00: 0x800705B4:
Miembros del dominio
Los servidores y equipos miembros del dominio que se actualizan ya no están configurados para usar la jerarquía de dominios para sincronizar su tiempo. En su lugar, sincronizarán su tiempo con el time.windows.com
sitio web.
Servidor horario autoritativo
Los equipos Windows configurados manualmente como servidor de hora autoritativo pierden su configuración. Por lo tanto, es posible que los dispositivos configurados usen estos equipos para sincronizar su tiempo.
También puede observar que el servidor NTP autoritativo no responde a las solicitudes de cliente NTP. Incluye errores que se producen al probar la disponibilidad del servidor NTP mediante la w32tm.exe /stripchart
herramienta . Por ejemplo, la salida de texto puede parecerse a la siguiente salida:
c:>w32tm /stripchart /computer:myAuthoritativeTimeServer Tracking <myAuthoritativeTimeServer>> [10.1.1.100:<123]. La hora actual es <DateTime>. <Error dateTime> : 0x800705B4:
Nota:
Este problema no debe producirse cuando se realiza una actualización local de los siguientes sistemas operativos:
- Windows 10, versión 1507 a Windows 10, versión 1511
- Windows 10, versión 1511 a Windows 10, versión 1607
- Windows Server 2016 Technical Preview 5 (TP5) a Windows Server 2016 (RTM)
Causa
Se trata de un problema conocido en las rutas de actualización de Windows que aparecen en la sección "Síntomas". Este problema se produce porque los valores del Registro para el servicio de hora de Windows no se conservan durante una actualización. Por lo tanto, todos los valores del servicio de hora de Windows se revierten al estado predeterminado de un servidor miembro del grupo de trabajo o a un equipo independiente.
Solución alternativa
Importante
Esta sección, método o tarea contiene pasos que le indican cómo modificar el Registro. No obstante, pueden producirse problemas graves si modifica el registro de manera incorrecta. Por lo tanto, asegúrese de que sigue estos pasos con atención. Para la protección añadida, realice una copia de seguridad del Registro antes de modificarlo. A continuación, puede restaurar el Registro si se produce un problema. Para obtener más información sobre cómo realizar copias de seguridad y restaurar el registro, vaya al siguiente artículo de Microsoft Knowledge Base:
322756 Hacer una copia de seguridad del Registro y restaurarlo en Windows
Nota:
En los equipos unidos a un dominio y los controladores de dominio, el servicio Netlogon debe ejecutarse antes de que se pueda iniciar el servicio W32time. Después de actualizar el sistema, asegúrese de que Netlogon se está ejecutando antes de probar cualquiera de estas soluciones alternativas.
Para evitar este problema, utilice uno de los métodos siguientes.
Método 1
Antes de actualizar a Windows 10 versión 1607 o Windows Server 2016, realice manualmente una copia de seguridad del contenido en la clave del Registro w32time . Para ello, siga los pasos que se indican a continuación:
Abra el cuadro Ejecutar presionando la tecla del logotipo de Windows +R.
Escriba regedit y presione Entrar.
Busque y, a continuación, seleccione la siguiente entrada del Registro:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W32Time\
Seleccione Exportación de archivos>.
En el cuadro de diálogo Exportar archivo del Registro, seleccione la ubicación donde desea guardar la copia de seguridad y escriba un nombre para el archivo de copia de seguridad en el campo Nombre de archivo.
Haga clic en Guardar.
Guarde la configuración de W32time para la validación ejecutando los siguientes comandos en un símbolo del sistema con privilegios elevados:
Net start w32time w32tm /query /configuration /verbose > PreUpgradeW32timeConfiguration.txt
Ahora puede actualizar el equipo a Windows Server 2016 o Windows 10 versión 1607. Una vez completada la actualización, siga estos pasos para restaurar el contenido en la clave del Registro w32time:
Abra el cuadro Ejecutar presionando la tecla del logotipo de Windows +R.
Escriba regedit y presione Entrar.
Abra el cuadro Ejecutar presionando la tecla del logotipo de Windows +R.
Escriba regedit y presione Entrar.
En el Editor del Registro, seleccione Importación de archivos>.
En el cuadro de diálogo Importar archivo del Registro, seleccione la ubicación donde guardó la copia de seguridad, seleccione el archivo de copia de seguridad y, a continuación, seleccione Abrir.
Salga del Editor del Registro.
Ejecute el siguiente comando para quitar un desencadenador de servicio en desuso:
reg delete HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W32Time\TriggerInfo\1 /f
Reinicie el servicio W32time para habilitarlo para usar la nueva configuración. Para ello, ejecute los siguientes comandos en un símbolo del sistema con privilegios elevados:
net stop w32time net start w32time
Método 2
Si tiene problemas que afectan al servicio de hora de Windows después de actualizar a Windows Server 2016 o Windows 10 versión 1607, siga estos pasos para volver a registrar w32tm.exe
.
Nota:
Este procedimiento restaura la configuración predeterminada adecuada para el rol de equipo. No restaura ninguna personalización realizada por el administrador.
En un símbolo del sistema con privilegios elevados, ejecute la siguiente secuencia de comandos:
net stop w32time
w32tm.exe /unregister
w32tm.exe /register
net start w32time
Método 3
Si tiene problemas que afectan al servicio de hora de Windows después de actualizar a Windows Server 2016 o Windows 10 versión 1607, siga estos pasos para restaurar la configuración desde la carpeta Windows.old.
Importante
Solo los usuarios avanzados deben realizar los pasos siguientes.
Exporte la clave del Registro desde la carpeta Windows.old.
Abra el cuadro Ejecutar de Windows presionando la tecla del logotipo de Windows+R.
Escriba regedit y presione Entrar.
Busque y, a continuación, haga clic en
HKEY_LOCAL_MACHINE
.En el menú Archivo , haga clic en Cargar Hive.
Busque y, a continuación, haga clic en el
C:\Windows.old\Windows\System32\Config\System
archivo y, a continuación, haga clic en Abrir.En el cuadro de diálogo Cargar Hive , escriba Sin conexión y, a continuación, haga clic en Aceptar.
Expanda Sin conexión.
Busque la siguiente subclave del Registro y haga clic en ella:
ControlSet001\Services\W32Time\
Haga clic en Exportar archivo>.
En el cuadro de diálogo Exportar archivo del Registro, seleccione la ubicación en un disco duro local donde desea guardar el registro y escriba un nombre para el archivo de copia de seguridad en el campo Nombre de archivo.
Haga clic en Save(Guardar).
Busque la siguiente subclave del Registro y haga clic en ella:
HKEY_LOCAL_MACHINE\Offline
En el menú Archivo , haga clic en Descargar Hive y, a continuación, haga clic en Sí en el cuadro de diálogo Confirmar descarga de Hive .
Salga del editor del Registro.
Reinicie el equipo en modo de recuperación.
- Seleccione Start Settings Update &Security Recovery (Iniciar>configuración de actualización>y recuperación de seguridad)>
- En el panel derecho, haga clic en Reiniciar ahora en Inicio avanzado.
- Después de reiniciar el equipo, seleccione Solucionar problemas y, a continuación, seleccione Símbolo del sistema.
- Seleccione un usuario administrador local y, a continuación, inserte la contraseña.
Nota:
Esto reinicia el equipo en modo de recuperación y proporciona una ventana del símbolo del sistema.
Importe la clave del Registro guardada del paso 1.
En el símbolo del sistema, escriba regedit y presione Entrar.
Busque y, a continuación, seleccione
HKEY_LOCAL_MACHINE
En el menú Archivo , haga clic en Cargar Hive.
Busque y seleccione el
C:\Windows\System32\Config\System
archivo y, a continuación, haga clic en Abrir.En el cuadro de diálogo Cargar Hive , escriba Sin conexión y, a continuación, haga clic en Aceptar.
Expanda Sin conexión.
Busque la siguiente subclave del Registro y haga clic en ella:
ControlSet001\Services\W32Time\
Haga clic en Archivo>Importar.
En el cuadro de diálogo Importar archivo del Registro, seleccione la ubicación donde guardó la copia de seguridad, seleccione el archivo de copia de seguridad y, a continuación, haga clic en Abrir.
Busque la siguiente subclave del Registro y haga clic en ella:
HKEY_LOCAL_MACHINE\Offline
En el menú Archivo , haga clic en Descargar Hive y, a continuación, haga clic en Sí en el cuadro de diálogo Confirmar descarga de Hive .
Salga del Editor del Registro y reinicie el equipo en modo Normal.
Comprobación de los resultados de la solución alternativa
Para comprobar que el servicio hora de Windows ahora puede conservar su configuración, siga estos pasos:
Ejecute DCDiag.exe en controladores de dominio para asegurarse de que están anunciando como servidor de hora.
Asegúrese de que los controladores de dominio o los servidores NTP autoritativos responden a las solicitudes de cliente NTP sin errores. Por ejemplo, la salida del comando es similar a la siguiente:
c:<w32tm /stripchart /computer:<myTimeServer>
Seguimiento <de myTimeServer> [10.1.1.100:123].
La hora actual es <DateTime>.
<DateTime> d:+00.0013494s o:-00.0891868s [ * ]Para los usuarios avanzados, consulte la configuración de W32time y asegúrese de que los proveedores de hora están configurados según lo previsto. Si usó el método 1 como solución alternativa, puede comparar la configuración posterior a la actualización con los datos de preconfiguración guardados. Por ejemplo, la salida del comando es similar a la siguiente:
c:\ >w32tm /query /configuration /verbose > PostUpgradeW32timeConfiguration.txt
Referencias
Para obtener más información sobre los problemas relacionados con Netlogon, haga clic en el número de artículo siguiente para ver el artículo en Microsoft Knowledge Base:
3201247 servicio Netlogon no conserva la configuración después de actualizar a Windows Server 2016