Nota
El acceso a esta página requiere autorización. Puede intentar iniciar sesión o cambiar directorios.
El acceso a esta página requiere autorización. Puede intentar cambiar los directorios.
En este artículo se proporciona ayuda para resolver un conflicto de WinStoreUI.admx que se produce cuando central Store se actualiza mediante archivos ADMX de Windows 10 versión 1511.
Se aplica a: Windows Server (todas las versiones con soporte)
Número de KB original: 3190327
Síntomas
El archivo WinStoreUI.admx está disponible en Windows Server 2012 R2, pero no se incluye en la versión inicial de Windows 10. Sin embargo, después de actualizar el Almacén central con los archivos .admx de Windows 10 versión 1511, se muestra el siguiente error tan pronto como empiece a editar un objeto de directiva de grupo (GPO):
El espacio de nombres "Microsoft.Policies.WindowsStore" ya está definido como espacio de nombres de destino para otro archivo del almacén.
Comparar los archivos .admx de Windows Server 2012 R2 y Windows 10 versión 1511 muestra que WindowsStore.admx contiene la misma información que WinStoreUI.admx, además de algunas configuraciones de directiva adicionales. Después de eliminar WinStoreUI.admx, este error ya no se produce. Sin embargo, el conjunto resultante de directivas en un equipo basado en R2 2012 contiene el siguiente error:
Error al recopilar datos para plantillas administrativas. Se encontraron los siguientes errores
No se encontró un archivo de recursos adecuado para \\<domain>\sysvol\<domain.dns>policies\PolicyDefinitions\WinStoreUI.admx(error = 2): El sistema no encuentra el archivo especificado.
Causa
En La versión 1507 de Windows 10, se quitó el archivo .admx de la Tienda. Se ha restaurado el archivo .admx. Sin embargo, este archivo ahora tiene un nuevo nombre. Después de instalar la versión 1511, cuando los clientes actualizan su Tienda Central, ahora tienen dos archivos .admx que tienen una configuración idéntica. Dado que esto no está permitido, se produce el error descrito en la sección "Síntomas".
Los archivos .admx son los siguientes:
- Nombre del archivo de directiva de grupo de almacén original: winstoreui.admx
- Nuevo nombre de archivo de directiva de grupo de almacén: windowsstore.admx
Solución
Este problema se ha corregido en La versión 1511 de Windows 10 y en la actualización acumulativa más reciente. Los clientes afectados deben actualizar a esa versión si es posible. Para evitar que se produzca el error al abrir Gpedit.msc y al ejecutar Gpresult.exe, siga estos pasos:
- Compruebe que tiene winstoreui.admx y windowsstore.admx en la Tienda Central.
- Elimine los archivos winstoreui.admx y winstoreui.adml de central Store.
- Compruebe que tanto la apertura de Gpedit.msc como la ejecución de Gpresults.exe funcionen sin errores.