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En este artículo se explica cómo solucionar problemas de identificador de evento 1020 eventos en un servidor de archivos de bloque de mensajes del servidor (SMB).
Número de KB original: 4562940
Síntomas
En un servidor de archivos SMB basado en Windows Server, observará los eventos id. de evento 1020 de SMB-Server en el registro de eventos Microsoft-Windows-SMBServer/Operational . La información de estos eventos es similar al siguiente mensaje:
La operación del sistema de archivos ha tardado más de lo esperado.
Nombre de cliente: <Client-IP/Name>
Dirección de cliente: <Client-IP>:<Client-Port>
Nombre de usuario: <Nombre de usuario>
Identificador de sesión: <SMB-Session-ID>
Nombre del recurso compartido: <SMB-Share-Name>
Nombre de archivo: <Nombre de archivo>
Comando: <SMB-Command-Code>
Duración (en milisegundos): <Duración>
Umbral de advertencia (en milisegundos): 15000
Guía:
El sistema de archivos subyacente ha tardado demasiado tiempo en responder a una operación. Esto suele indicar un problema con el almacenamiento y no con SMB.
Cuando Windows registra estos eventos, también puede observar los siguientes síntomas:
- Los clientes del servidor SMB experimentan problemas de rendimiento. Dado que el servidor SMB accede al sistema de archivos local en nombre de sus clientes SMB, los problemas de rendimiento en el servidor SMB afectan directamente a los clientes. Las aplicaciones cliente pueden experimentar tiempos de espera muy largos si su interacción con el servidor SMB implica varias operaciones consecutivas y cada operación experimenta un retraso.
- Es posible que los clientes del servidor SMB tengan problemas para acceder a los recursos compartidos que administra el servidor SMB.
- Las aplicaciones locales del servidor SMB u otros componentes experimentan problemas de rendimiento. Es posible que esas aplicaciones y componentes no puedan registrar estos problemas de rendimiento.
- El servidor SMB parece dejar de responder.
Nota:
Los problemas de rendimiento podrían no afectar a todos los discos del servidor SMB al mismo tiempo o al mismo grado.
Causa
El identificador de evento 1020 indica que el sistema de archivos del servidor SMB no puede completar una operación de lectura y escritura (E/S) dentro del tiempo permitido. De forma predeterminada, el tiempo permitido es de 15 segundos. Normalmente, esperamos que estas operaciones finalicen dentro de un período de tiempo de milisegundos de un solo dígito.
El funcionamiento incorrecto de los controladores de filtro del sistema de archivos puede provocar retrasos de varios segundos. Los problemas que implican los discos físicos del servidor SMB también pueden provocar una reducción grave del rendimiento. Estos problemas incluyen lo siguiente:
- Los discos físicos están sobrecargados.
- VSS u otras soluciones de copia de seguridad están causando situaciones prolongadas de inmovilización de disco.
- La pila de red y almacenamiento de un hipervisor subyacente funciona mal.
- Las conexiones de red a los discos físicos están experimentando problemas.
- El propio dispositivo de almacenamiento (red de área de almacenamiento (SAN), el almacenamiento conectado a la red (NAS) u otro tipo) está experimentando problemas.
Los retrasos del sistema de archivos que son inferiores al umbral de 15 segundos no generan un evento de advertencia, pero reducen el rendimiento del servidor SMB.
Solución
Dado que la causa de estos retrasos en el sistema de archivos puede depender de los detalles de su entorno, normalmente tiene que recopilar más datos para aislar el problema específico.
Para empezar, revise el registro de eventos del servidor SMB. Los eventos id. de evento 1020 incluyen información que puede ayudarle a identificar detalles y patrones. Los datos del evento incluyen la duración exacta del retraso y el código de comando SMB que encontró el retraso. Para obtener una lista de códigos de comandos SMBv2, vea 2.2.1.2 Encabezado de paquete SMB2 - SYNC.
Recopilación de registros de seguimiento
Para diagnosticar aún más si el problema se origina desde el sistema operativo Windows (por ejemplo, controladores de filtro) o desde fuera (por ejemplo, hardware, hipervisor, red o almacenamiento), use una aplicación como Storport Trace para recopilar datos de seguimiento. Use una herramienta como StorPortPacman para comprobar los tiempos de respuesta del disco. StorPort realiza un seguimiento en el extremo inferior de la pila de almacenamiento de Windows y el servidor SMB (o cualquier otra aplicación) encuentra los retrasos en el extremo superior de la pila. Para obtener más información sobre StorPortPacman, consulte Desciphering Storport Traces 101( Deciphering Storport Traces 101).
Los tiempos de respuesta máximo altos en el nivel de StorPort indican que la causa de los problemas de rendimiento reside fuera del sistema operativo. Para determinar qué latencias encuentra el sistema desde sus discos lógicos en el nivel de aplicación (servidor de archivos), habilite el seguimiento de Perfmon o WPR. Estos datos de seguimiento también muestran latencias inferiores al umbral de advertencia de 15 segundos. Para obtener más información, consulte Medición de la latencia de disco con Windows Monitor de rendimiento (Perfmon).
Recopilación de datos de archivo de volcado de kernel
Para retrasos extremos (10 o más minutos) y en algunas otras condiciones, el servidor SMB crea un archivo de volcado de kernel activo. Esta información es valiosa para solucionar problemas.
Los eventos siguientes en el registro de eventos Microsoft-Windows-SMBServer/Operational indican si hay disponible un archivo de volcado de kernel activo:
- Id. de evento 1031: el servidor detectó un problema y ha capturado un volcado de kernel activo para recopilar información de depuración.
- Id. de evento 1032: el servidor detectó un problema, pero no pudo capturar un volcado de kernel activo para recopilar información de depuración.
Windows coloca los archivos de volcado en la carpeta %SystemRoot%\LiveKernelReports .