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El equipo no se inicia después de cambiar la partición activa mediante la herramienta Administración de discos

En este artículo se proporciona una solución a un problema por el que el equipo no se inicia después de marcar la partición principal como activa.

Número de KB original: 315261

Síntomas

Después de usar la herramienta de complemento Administración de discos de Windows para marcar la partición principal como activa, es posible que el equipo no se inicie y que reciba el siguiente mensaje de error:

Falta NTLDR.

Presione Control + Alt + Supr para reiniciar.

Causa

Este comportamiento se produce si la partición marcada como activa no contiene los archivos de arranque de Windows ni los archivos de arranque de otro sistema operativo. En los equipos basados en Intel, la partición del sistema debe ser una partición principal que se haya marcado como activa para fines de inicio. Esta partición debe encontrarse en el disco al que el equipo obtiene acceso al inicio. Solo puede haber una partición activa del sistema a la vez. Si desea usar otro sistema operativo, primero debe marcar su partición del sistema como activa antes de reiniciar el equipo.

Solución

Importante

Antes de realizar los pasos que se enumeran a continuación, asegúrese de que tiene una buena copia de seguridad de los archivos de datos críticos.

Para resolver este comportamiento, use uno de los procedimientos siguientes:

  • Pruebe a cambiar la partición activa iniciando en un disco de disquete y, a continuación, usando utilidades de disco para cambiar manualmente la partición activa:

    1. Arranque en un símbolo del sistema mediante un disco de arranque de Microsoft Windows 95, Microsoft Windows 98 o Microsoft Windows Millennium Edition (Me).
    2. En el símbolo del sistema, escriba fdisk y presione ENTRAR.
    3. Cuando se le pida que habilite la compatibilidad con discos grandes, haga clic en .
    4. Haga clic en Establecer partición activa, presione el número de la partición que desea activar y, a continuación, presione ENTRAR.
    5. Presione ESC.
    6. Quite el disco de arranque y, a continuación, reinicie el equipo.
  • Arranque el equipo mediante un disco de arranque de Windows XP. Para obtener más información, vea Crear un disco de reparación del sistema.

  • Si la partición que se ha marcado incorrectamente como activa tiene el formato en el sistema de archivos FAT, el sistema de archivos FAT32 o el sistema de archivos NTFS, puede usar la Consola de recuperación de Windows para corregir el comportamiento.

Para obtener más información, consulte ¿Cuáles son las opciones de recuperación del sistema en Windows?.

Nota:

La partición del sistema hace referencia al volumen de disco que contiene los archivos necesarios para iniciar Windows (por ejemplo, Ntldr, Boot.ini y Ntdetect.com). En los equipos basados en Intel x86, la partición del sistema debe ser una partición principal marcada como activa. En equipos Intel x86, esta siempre es la unidad 0, la unidad que el BIOS del sistema busca cuando se inicia el sistema operativo.

Con la Consola de recuperación, copie el archivo Ntldr desde el CD-ROM de Windows XP en el directorio raíz de la partición activa actual. Siga estos pasos:

  1. Inicie el equipo con los discos de disquete del programa de instalación de Windows XP o mediante el CD-ROM de Windows XP.

  2. En la pantalla Bienvenido a configuración , presione F10 o presione R para reparar.

  3. Presione C para iniciar la consola de recuperación.

  4. Copie el archivo Ntldr desde el CD-ROM de Windows XP a la raíz de la partición del sistema mediante los siguientes comandos, presionando ENTRAR después de cada comando:

  5. Escriba cd .. para ir a la raíz de la unidad C.

    Hay un espacio entre los puntos d y los dos puntos (..).

  6. Escriba la letra de la unidad CD-ROM.

  7. Escriba cd i386.

  8. Escriba Copy ntldr c:.

  9. Escriba Copy ntdetect.com c:.

  10. Escriba Bootcfg /add.

  11. Escriba Exit.

Si la partición no tiene formato mediante Windows, es posible que también tenga que ejecutar el comando fixboot de la consola de recuperación para que se pueda arrancar la partición activa.

Después de iniciar en Windows, se recomienda usar la herramienta de complemento Administración de discos de Windows para restablecer la partición del sistema original como partición activa y, a continuación, reiniciar el equipo.