Compartir a través de


El sistema deja de responder, el rendimiento del servidor de archivos es lento o se producen retrasos cuando se trabaja con archivos ubicados en un servidor de archivos

En este artículo se proporciona una solución a los problemas de rendimiento que se producen al trabajar con archivos ubicados en un servidor de archivos.

Número de KB original: 822219

Síntomas

Puede experimentar uno o varios de los síntomas siguientes al trabajar con archivos a través de la red:

  • Un servidor de archivos basado en Windows que está configurado como un servidor de archivos e impresión deja de responder y la funcionalidad del servidor de impresión y archivos se detiene temporalmente.

  • Experimenta un retraso inesperado al abrir, guardar, cerrar, eliminar o imprimir archivos que se encuentran en un recurso compartido.

  • Experimenta una disminución temporal del rendimiento cuando se usa un programa a través de la red. El rendimiento suele ralentizarse durante aproximadamente 40 a 45 segundos. Sin embargo, algunos retrasos pueden durar hasta 5 minutos.

  • Experimenta un retraso al realizar operaciones de copia de seguridad o copia de archivos.

  • El Explorador de Windows deja de responder cuando se conecta a un recurso compartido o ve una X roja en la unidad de red conectada en el Explorador de Windows.

  • Al iniciar sesión en el servidor de archivos, después de escribir el nombre y la contraseña en el cuadro de diálogo Iniciar sesión en Windows , aparece una pantalla en blanco. El escritorio no aparece.

  • Un programa que usa la llamada a procedimiento remoto (RPC) o usa canalizaciones con nombre para conectarse a un servidor de archivos deja de responder.

  • El servidor deja de responder temporalmente y uno o varios mensajes de identificador de evento similares a los mensajes siguientes aparecen en el registro del sistema en el servidor de archivos.

  • Recibirá un mensaje de error similar a uno de los siguientes mensajes al intentar conectarse a un recurso compartido:

    • Mensaje de error 1

      Error del sistema 53. No se ha encontrado la ruta de acceso de la red.

    • Mensaje de error 2

      Error del sistema 64. El nombre de red especificado ya no está disponible.

  • Está desconectado intermitentemente de los recursos de red y no puede volver a conectarse a los recursos de red en el servidor de archivos. Sin embargo, puede hacer ping al servidor y puede usar una sesión de Servicios de Escritorio remoto para conectarse al servidor.

  • Si varios usuarios intentan acceder a documentos de Microsoft Office en el servidor, el cuadro de diálogo Archivo está bloqueado para editarlo no siempre aparece cuando el segundo usuario abre el archivo.

  • Un seguimiento de red indica un retraso de 30 a 40 segundos entre un comando de cliente del servicio SMB y una respuesta del servidor de archivos.

  • Al intentar abrir un archivo de base de datos de Access 2.0 (archivo .mdb) en Microsoft Access 97, en Access 2000 o en Access 2002, puede recibir un mensaje de error similar al siguiente:

    Error de disco o red.

  • Al intentar abrir un archivo de Microsoft Word, puede recibir el siguiente mensaje de error:

    Word no pudo leer este archivo file_name. Restaure la conexión de red o reemplace el disco de disquete y vuelva a intentarlo.

Causa

Este problema puede producirse si un programa que no es de Microsoft instalado en el equipo usa un controlador de filtro en modo kernel obsoleto. El controlador de filtro en modo kernel puede estar obsoleto si se cumplen las condiciones siguientes:

  • Uno de los siguientes programas está instalado en el ordenador:

    • ARCserve Backup Agent for Open Files o ARCserve Open File Agent from Computer Associates International, Inc. está instalado en el equipo y el controlador Ofant.sys para el programa está obsoleto.

    • Open Transaction Manager está instalado en el equipo y el controlador Otman.sys para el programa está obsoleto.

      Nota:

      Open Transaction Manager se incluye con ciertos programas de VERITAS Software Corporation, pero también se puede instalar por separado del programa VERITAS. Por ejemplo, Open Transaction Manager puede incluirse con la opción Abrir archivo. Este programa puede incluirse con VERITAS Backup Exec.

    • Un programa VERITAS que usa el controlador Otman4.sys o Otman5.sys (como Abrir opción de archivo) está instalado en el ordenador y el controlador Otman4.sys o Otman5.sys para el programa está obsoleto.

  • El controlador del programa no es compatible con el controlador de filtro instalado en el equipo por un programa antivirus que no es de Microsoft. Como resultado, el controlador de filtro del servidor puede devolver un código de estado incorrecto al servicio Servidor. Por ejemplo, el controlador de filtro puede devolver un código de STATUS_SUCCESS en lugar de un código STATUS_OPLOCK_BREAK_IN_PROGRESS.

Solución

Para resolver este problema, póngase en contacto con el fabricante del programa para consultar la disponibilidad de una actualización del controlador de filtro. Para obtener más información sobre cómo ponerse en contacto con Computer Associates para obtener la actualización más reciente del controlador de Ofant.sys, visite Computer Associates.

Si instaló Open Transaction Manager por separado, póngase en contacto con Columbia Data Products, Inc. para obtener información sobre la disponibilidad de una actualización que puede resolver este problema. Para ponerse en contacto con Columbia Data Products, visite Columbia Data Products.

Para obtener más información sobre cómo ponerse en contacto con VERITAS, visite el soporte técnico de VERITAS.

Más información

Importante

Esta sección, método o tarea contiene pasos que le indican cómo modificar el Registro. No obstante, pueden producirse problemas graves si modifica el registro de manera incorrecta. Por lo tanto, asegúrese de que sigue estos pasos con atención. Para la protección añadida, realice una copia de seguridad del Registro antes de modificarlo. A continuación, puede restaurar el Registro si se produce un problema. Para obtener más información sobre cómo realizar copias de seguridad y restaurar el registro, vea Cómo hacer copia de seguridad y restaurar el registro en Windows.

Para solucionar temporalmente este problema, reinicie los servicios del servidor en el servidor. Para reiniciar los servicios del servidor, siga estos pasos:

  1. Haga clic en Inicio y luego en Ejecutar.

  2. En el cuadro Abrir , escriba cmd y, a continuación, haga clic en Aceptar.

  3. En el símbolo del sistema, escriba las líneas siguientes y presione Entrar después de cada línea:

    net stop server
    net start server
    

Para solucionar este problema, use cualquiera de los métodos siguientes:

  • Use registros de rendimiento y alertas para supervisar el contador Avg. Disk Queue Length del objeto de rendimiento PhysicalDisk . En condiciones normales, el número de solicitudes de entrada/salida en espera (E/S) normalmente no es superior a 1,5 a 2 veces el número de spindles que tiene el disco físico. La mayoría de los discos tienen un husillo, aunque la matriz redundante de dispositivos de discos independientes (RAID) normalmente tiene más de un eje. Cuando un programa ejecuta pequeñas operaciones sucesivas de E/S, verá un pico en el contador Longitud de cola de disco actual cuando se ponen en cola las operaciones enlazadas a E/S. También puede ver un aumento en el contador Modificadores de contexto/s del objeto de rendimiento Del sistema .

  • Deshabilite el bloqueo oportunista en el cliente o en el servidor. Para deshabilitar el bloqueo oportunista en el cliente, establezca el siguiente valor del Registro en 1:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MRXSmb\Parameters\OplocksDisabled

    Para deshabilitar el bloqueo oportunista en el servidor, establezca el siguiente valor del Registro en 0:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters\EnableOplocks

    Para obtener más información sobre cómo deshabilitar el bloqueo oportunista, consulte Configuración del bloqueo oportunista en Windows.

  • Edite el Registro para desactivar temporalmente el controlador de filtro.

    Para obtener más información sobre cómo desactivar temporalmente el controlador de filtro en modo kernel, vea Cómo desactivar temporalmente el controlador de filtro en modo kernel en Windows.

    La clave del Registro que almacena información para el controlador de Ofant.sys es Ofadriver.

Referencias

Aviso de declinación de responsabilidades sobre la información de terceros

Los productos de otros fabricantes que se mencionan en este artículo han sido creados por compañías independientes de Microsoft. Microsoft no ofrece ninguna garantía, ya sea implícita o de otro tipo, sobre la confiabilidad o el rendimiento de dichos productos.