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Este artículo ayuda a resolver un problema en el que no se pueden instalar controladores en máquinas virtuales hospedadas en VMware. Este problema se produce si no activa la casilla "Permitir que el servicio interactúe con el escritorio".
Se aplica a: Windows Server 2008 R2 Service Pack 1
Número de KB original: 3025586
Síntomas
Las máquinas virtuales de VMware no instalan ni actualizan correctamente un controlador si se cumplen las condiciones siguientes:
- El servicio Telnet Server se instala en un equipo que ejecuta Windows Server 2008 R2 Service Pack 1 (SP1) y tiene VMware vSphere instalado.
- Configure el servicio Telnet Server para que se inicie manual o automáticamente en Services Microsoft Management Console (MMC). Además, modifica el servicio Telnet Server para iniciar sesión con la cuenta del sistema local y no activa la casilla "Permitir que el servicio interactúe con el escritorio".
Al intentar instalar el controlador en Administrador de dispositivos en máquinas virtuales, se produce un error y recibe el siguiente mensaje de error:
Windows encontró software de controlador para el dispositivo, pero encontró un error al intentar instalarlo.
Además, se registra un registro similar al siguiente en el archivo setupapi.dev.log que se encuentra en la carpeta %windir%/inf:
dvi: {Plug and Play Service: Device Install for PCI\VEN_15AD&DEV_07B0&SUBSYS_07B015AD&REV_01\FF565000B37984FE00}
ump: Crear proceso de instalación: DrvInst.exe <DateTime>
ump: el proceso de instalación del servidor salió con código 0xc0000142 <DateTime>
ump: {Plug and Play Service: Device Install exit(c0000142)}
ndv: Error de instalación del dispositivo para el nuevo dispositivo... instalar controlador NULL.
dvi: {Plug and Play Service: Device Install for PCI\VEN_15AD&DEV_07B0&SUBSYS_07B015AD&REV_01\FF565000B37984FE00}
Causa
Este problema se produce por motivos de seguridad. El servicio Telnet Server realiza algunos cambios de permisos en la estación de ventana en la que se ejecuta durante la inicialización. Si configura el servicio Telnet Server para que se ejecute mediante la cuenta del sistema local sin la capacidad de interactuar con el escritorio, se inicia en una estación de ventana diferente. Esto puede causar problemas para otros procesos que también se ejecutan en la cuenta del sistema local y no interactúan con el escritorio. Uno de estos procesos es el proceso de instalación del controlador que se usa durante la instalación de un nuevo controlador de dispositivo.
Solución alternativa
Para solucionar este problema, no cambie el servicio Telnet Server para que se ejecute en la cuenta del sistema local. Se recomienda dejar el servicio Telnet Server en ejecución en su cuenta de servicio local predeterminada.
Si sigue sin resolver el problema, puede comprobar que la versión más reciente de VMWare Tools que está instalada. Si observa que no puede actualizar VMWare Tools o desinstalarlo, siga estos pasos:
Obtenga los archivos de instalación de la versión más reciente de VMWare Tools.
Haga clic en Inicio, haga clic en Ejecutar, escriba cmdy, a continuación, haga clic en Aceptar. Se abre una ventana del símbolo del sistema.
Cambie la unidad a la unidad de CD-ROM donde están los archivos de instalación de VMware Tools (por ejemplo, D:\).
Escriba setup /c y presione Entrar para forzar la eliminación de todas las entradas del Registro y eliminar la versión anterior de VMware Tools.
Nota
Para sistemas operativos invitados de 64 bits, escriba setup64 /c .
Se deben quitar las versiones anteriores de VMware Tools.
Instale la versión más reciente de VMware Tools y, a continuación, realice un reinicio después de comprobar que la configuración del inicio de sesión del servicio Telnet Server está establecida correctamente.
datos, recopilación
Si necesita ayuda del soporte técnico de Microsoft, le recomendamos que recopile la información siguiendo los pasos mencionados en Recopilación de información mediante TSS para problemas relacionados con la implementación.
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