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No puede ver roles y características y recibir código de error 0x800706BE en Administrador del servidor

En este artículo se proporciona una resolución para el problema que no puede ver roles y características y recibir código de error 0x800706BE en Administrador del servidor.

Número de KB original: 2461206

Síntomas

Considere el caso siguiente:

  1. Tiene un equipo que ejecuta Windows Server 2008 o Windows Server 2008 R2.
  2. Abra la ventana de Administrador del servidor para ver, agregar o quitar roles y características.

En este escenario, los roles y las características no se muestran con un golpe amarillo contra ellos en la ventana de Administrador del servidor. Recibirá el siguiente mensaje de error en la parte inferior de Administrador del servidor si intenta abrirlo:

Administrador del servidor
Error inesperado al actualizar Administrador del servidor: error en la llamada a procedimiento remoto. (Excepción de HRESULT: 0x800706BE)
Para obtener más información, consulte el registro de eventos: Diagnósticos, Visor de eventos, Registros de aplicaciones y servicios, Microsoft, Windows, Administrador del servidor, Operational).

Al mismo tiempo, el evento siguiente se agrega al registro Microsoft-Windows-ServerManager/Operational:

Nombre del registro: Microsoft-Windows-ServerManager/Operational
Origen: Microsoft-Windows-ServerManager
Fecha: <fecha y hora>
Identificador de evento: 1601
Categoría de tarea: None
Nivel: Error
Palabras clave:
Usuario: <nombre de usuario>
Equipo: <nombre de equipo>
Descripción:
No se pudo detectar el estado del sistema. Se encontró una excepción inesperada:
System.Runtime.InteropServices.COMException (0x800706BE): error en la llamada a procedimiento remoto. (Excepción de HRESULT: 0x800706BE)
at System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32 errorCode, IntPtr errorInfo)
at Microsoft.Windows.ServerManager.ComponentInstaller.CreateSessionAndPackage(IntPtr& session, IntPtr& package)
en Microsoft.Windows.ServerManager.ComponentInstaller.InitializeUpdateInfo()
en Microsoft.Windows.ServerManager.ComponentInstaller.Initialize()
en Microsoft.Windows.ServerManager.Common.Provider.RefreshDiscovery()
en Microsoft.Windows.ServerManager.LocalResult.PerformDiscovery()
en Microsoft.Windows.ServerManager.ServerManagerModel.CreateLocalResult(RefreshType refreshType)
at Microsoft.Windows.ServerManager.ServerManagerModel.InternalRefreshModelResult(Object state)

Causa

Algunos archivos de catálogo, archivos de manifiesto o archivos MUM están dañados en el equipo.

Solución

Estos son los pasos para corregir el problema:

  1. Obtenga microsoft Update Readiness Tool desde la ubicación: https://support.microsoft.com/kb/947821.

  2. Ejecute microsoft Update Readiness Tool en el equipo problemático.

  3. Abre el archivo %Systemroot%\Windows\logs\CBS\Checksur.log una vez completado el examen.

  4. La información dañada se comprueba en los archivos. Estos son algunos ejemplos:

    (f) CBS MUM Corrupt 0x00000000 servicing\Packages\Package_for_KB978601~31bf3856ad364e35~amd64~~6.0.1.0.mum Nombre de archivo esperado Package_for_KB978601_server~31bf3856ad364e35~amd64~6.0.1.0.mum no coincide con el nombre de archivo real
    (f) CBS MUM Corrupt 0x00000000 servicing\Packages\Package_for_KB979309~31bf3856ad364e35~amd64~~6.0.1.0.mum Nombre de archivo esperado Package_for_KB979309_server~31bf3856ad364e35~amd64~~6.0.1.0.mum no coincide con el nombre de archivo real

    O bien,

    (f) CBS MUM Corrupt 0x800B0100 servicing\Packages\Package_for_KB978601~31bf3856ad364e35~amd64~~6.0.1.0.mum servicing\Packages\Package_for_KB978601~31bf3856ad364e35~amd64~~6.0.1.0.cat El manifiesto del paquete no se puede validar mediante el catálogo correspondiente. (f) CBS MUM Corrupt 0x800B0100 servicing\Packages\Package_for_KB979309~31bf3856ad364e35~amd64~~6.0.1.0.mum servicing\Packages\Package_for_KB979309~31bf3856ad364e35~amd64~~6.0.1.0.cat El manifiesto del paquete no se puede validar mediante el manifiesto del paquete CBS MUM catálogo correspondiente

    O bien,

    (f) CBS MUM Missing 0x00000002 servicing\packages\Package_114_for_KB955839~31bf3856ad364e35~amd64~~6.0.1.0.mum (f) CBS MUM Missing 0x00000002 servicing\packages\Package_83_for_KB955839~31bf3856ad364e35~amd64~6.0.1.0.mum

    Más abajo verá lo siguiente:

    Archivos de reparación no disponibles:
    servicing\packages\Package_for_KB978601~31bf3856ad364e35~amd64~~6.0.1.0.mum
    servicing\packages\Package_for_KB979309~31bf3856ad364e35~amd64~~6.0.1.0.mum
    servicing\packages\Package_for_KB978601~31bf3856ad364e35~amd64~~6.0.1.0.cat
    servicing\packages\Package_for_KB979309~31bf3856ad364e35~amd64~~6.0.1.0.cat

Copie estos archivos en: %systemroot\Windows\Servicing\Packages.

  1. Primero debe tener control sobre esa carpeta. Para ello, use los siguientes comandos:

    takeown /F c:\Windows\Servicing\Packages /D y /R
    
  2. Ahora asigne control total mediante el siguiente comando. Le concederá control total sobre el directorio:

    cacls c:\Windows\Servicing\Packages /E /T /C /G "UserName": F
    
  3. Ahora debe recopilar los archivos que faltan o están dañados del checksur registro: descargue los archivos de KB para los archivos que faltan.

    servicing\packages\Package_for_ KB978601 ~31bf3856ad364e35~amd64~~6.0.1.0.mum

  4. Desempaquetarlos con el siguiente comando:

    Expand -F:\* UpdateKBXXXX.msu x:\DestinationDirectory
    
  5. Después de expandirlo, verá un archivo UpdateKBXXXX.cab. Expándalo también:

    Expand -F:\* UpdateKBXXXX.CAB x:\DestinationDirectoryCAB
    

    Dentro de este taxi tendrás que agarrar dos archivos: update.mum y update.cat.

  6. Cambie el nombre de los archivos update.mum y update.cab recopilados exactamente como están en el checksur.log:

    Por ejemplo: update.mum para KB978601 será Package_for_ KB978601 ~31bf3856ad364e35~amd64~~6.0.1.0.mum
    Haga lo mismo para todos los demás archivos que faltan o están dañados y colóquelos en el directorio especificado en checksur.log (/mantenimiento/paquetes).

Después de estos pasos, el problema debe corregirse, no es necesario reiniciar.

Nota:

Si Administrador del servidor no funciona incluso después de realizar estos pasos, vuelva a ejecutar Update Readiness Tool y compruebe los pasos descritos anteriormente.