Nota
El acceso a esta página requiere autorización. Puede intentar iniciar sesión o cambiar directorios.
El acceso a esta página requiere autorización. Puede intentar cambiar los directorios.
Este artículo le ayuda a resolver un problema que se produce cuando .NET Framework 4.Las aplicaciones x comparan cadenas japonesas.
Se aplica a: Windows 10 versión 2004, Windows 10 versión 20H2, Windows 10 versión 21H1, Windows 10 versión 21H2, Windows 10 versión 22H2
Síntomas
Ciertos caracteres japonés de ancho medio y ancho completo Katakana y Hiragana que tienen una marca consonante no se interpretan como el mismo carácter. Cuando se usa el CompareInfo.IndexOf
método y las IgnoreKanaType
opciones o IgnoreWidth
para CompareOptions
realizar una comparación, estos caracteres se evalúan como diferentes debido a un problema en la regla de ordenación.
Causa
A partir de la versión 2004, Windows 10 actualizó la versión de Compatibilidad con idiomas nacionales (NLS) a 6.3 y agregó compatibilidad con árabe y hebreo. Esta adición afecta a las reglas para ordenar comparaciones de cadenas japonesas que usan NLS para que las comparaciones generen resultados diferentes.
Solución alternativa
Advertencia
Pueden producirse problemas graves si modifica el Registro de manera incorrecta. Estos problemas podrían provocar que tenga que reinstalar el sistema operativo o incluso impedir que la máquina se inicie. Microsoft no puede garantizar que estos problemas se puedan solucionar. Antes de modificarlo, haz una copia de seguridad del registro para restaurarlo, por si se produjeran problemas. La modificación del Registro se hará bajo su propia responsabilidad.
Solución alternativa 1
Revierta la regla de ordenación nlS a la versión 6.2. Esta versión se usa en Windows 10, versión 1909 y versiones anteriores. Cuando tenga que compartir datos entre sistemas, considere la posibilidad de aplicar la solución alternativa de forma coherente. Si usa esta solución alternativa, realice pruebas y evaluaciones suficientes para mitigar los problemas causados por diferentes versiones de reglas de ordenación en varios sistemas.
Para usar esta solución alternativa, siga estos pasos:
Abra una ventana del símbolo del sistema (cmd.exe) como administrador.
Ejecute el siguiente comando:
reg add HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\Sorting\Versions /ve /d 0006020F /f
Reinicie el equipo o los procesos para ver el efecto completo.
Importante
Si no ha instalado KB4586853 o una actualización posterior en el equipo, establecer un valor no válido en esta entrada del Registro podría impedir que el equipo se inicie.
Solución alternativa 2
Establezca la regla de ordenación nlS en la versión 6.4. Esta versión se usa en Windows 11. Para ello, debe aplicar KB5014023 o una actualización posterior y actualizar la versión a la versión 1741 o una versión posterior. En este caso, la versión 22H2 ya se aplica y no tiene que actualizarse.
Aplique KB5014023 o una actualización posterior para Windows 10 versiones 2004, 20H2, 21H1 y 21H2.
Abra la ventana del símbolo del sistema (cmd.exe) como administrador.
Ejecute el siguiente comando:
reg add HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\Sorting\Versions /ve /d 00060403 /f
Reinicie el equipo o los procesos para ver el efecto completo.