Compartir a través de


esquematizar

Para ocultar una región de código en la vista, puedes contraerla para que aparezca bajo un símbolo de intercalación (>) en el editor de texto. A continuación, para expandir una región contraída, selecciona el símbolo de intercalación (>).

Sugerencia

Si prefiere usar el teclado, puede presionar CTRL+M+M para expandir o contraer.

Para contraer una región de esquematización, haga doble clic en cualquier línea de la región en el margen de esquematización, que aparece justo a la izquierda del código. Para ver el contenido de una región contraída como información sobre herramientas, hay que mantener el mouse sobre la región contraída.

Captura de pantalla de un ejemplo de código contraído que muestra el margen de esquematización y un ejemplo del código expandido que se puede ver desde la información sobre herramientas.

Las regiones en el margen de esquematización también se resaltan cuando se mantiene el mouse sobre el margen. El color de resaltado predeterminado puede parecer bastante pálido en algunas configuraciones de color. Se puede cambiar en Herramientas>Opciones>Entorno>Fuentes y colores>Región contraíble.

Al trabajar en código esquematizado, se pueden expandir las secciones en las que se desea trabajar, contraerlas cuando se haya terminado y desplazarse a otras secciones. Cuando no desee que se muestre la esquematización, puede usar el comando Detener esquematización para quitar la información del esquema sin alterar el código subyacente.

Los comandos Deshacer y Rehacer del menú Edición afectan a estas acciones. Copiar, Cortar, Pegar y las operaciones de arrastrar y colocar conservan la información de esquematización, pero no el estado de la región contraíble. Por ejemplo, cuando se copia una región contraída, la operación Pegar pega el texto copiado como región expandida.

Precaución

Si se cambia una región esquematizada, se puede perder la esquematización. Por ejemplo, las eliminaciones o las operaciones Buscar y reemplazar pueden borrar el final de la región.

El submenú Edición>Esquematización contiene los siguientes comandos.

NOMBRE Descripción
Ocultar selección (Ctrl+M, Ctrl+H): contrae un bloque de código seleccionado que normalmente no estaría disponible para la esquematización, por ejemplo un bloque if Para quitar la región personalizada, use Detener ocultar actual (o Ctrl+M, Ctrl+U). No está disponible en Visual Basic.
Alternar expansión de esquematización (Ctrl+M, Ctrl+M): invierte el estado oculto o expandido actual de la sección de esquematización más interna cuando el cursor se encuentra en una sección contraída anidada.
Alternar toda la esquematización (Ctrl+M, Ctrl+L): establece todas las regiones en el mismo estado contraído o expandido. Si algunas regiones están expandidas y otras están contraídas, las regiones contraídas se expanden.
Detener esquematización (Ctrl+M, Ctrl+P): quita toda la información de esquematización del documento completo.
(para volver a activarlo, vaya a Editar>Esquematización y seleccione Iniciar esquematización automática).
Detener ocultar actual (Ctrl+M, Ctrl+U): quita la información de esquematización de la región definida por el usuario que está seleccionada actualmente. No está disponible en Visual Basic.
Contraer a definiciones (Ctrl+M, Ctrl+O): contrae los miembros de todos los tipos.
Contraer bloque:<límite lógico> (C++) Contrae una región en la función que contiene el punto de inserción. Por ejemplo, si el punto de inserción está dentro de un bucle, se oculta el bucle.
Contraer todo el contenido de: <estructuras lógicas> (C++) Contrae todas las estructuras dentro de la función.

Sugerencia

Para más información sobre cómo usar el teclado exclusivamente, vea Métodos abreviados de teclado en Visual Studio.

También puede utilizar Visual Studio SDK para definir las regiones de texto que desea expandir o contraer. Vea Tutorial: Esquematización.