Suscripciones de Visual Studio: ¿por qué mis suscriptores tienen cuentas personales?

A medida que las empresas se migran del Centro de servicios de licencias por volumen (VLSC) al nuevo Portal de administradores de suscripciones de Visual Studio, los administradores pueden sorprenderse de ver que la "dirección de correo electrónico de inicio de sesión" de algunos suscriptores es una dirección de correo electrónico personal, como Hotmail o Outlook.

Causa

Esta situación puede darse como consecuencia de los procesos de inicio de sesión asociados a la anterior experiencia de suscriptor de MSDN. Los usuarios se migraron desde Microsoft Business Center hasta el Portal de administradores de suscripciones de Visual Studio sin modificaciones. Es posible que los administradores no sepan que los usuarios utilizan cuentas personales para acceder a sus ventajas de suscripción. Antes de las migraciones de suscriptores de Visual Studio, que se completaron en 2016, se requerían dos acciones para usar correctamente una suscripción a Visual Studio:

  1. El administrador "asignaba" la suscripción a un suscriptor individual, que usaba su dirección de correo electrónico profesional o educativa.
  2. El suscriptor "activaba" la suscripción.

Durante el proceso de activación del suscriptor se requería una cuenta Microsoft (MSA) para iniciar sesión. En caso de que el suscriptor no intentara usar su cuenta profesional o educativa (por ejemplo, tasha@contoso.com) como MSA, este podía crear una MSA o utilizar alguna existente. Usar un correo electrónico personal daba como resultado que la "dirección de correo electrónico de inicio de sesión" no coincidía con la "dirección de correo electrónico de asignación".

Nota:

La experiencia moderna de suscriptor en https://my.visualstudio.com admite los tipos de identidad profesional/educativa y de cuenta Microsoft (MSA).

Solución

Para corregir el problema, seleccione el botón Conectar correos electrónicos. El sistema intenta hacer coincidir las cuentas con MSA con los usuarios existentes en el Microsoft Entra ID de su organización basándose en la coincidencia del nombre y el apellido. Si se produce un error en una asociación, puede seleccionar la X situada a la derecha de la asociación para quitarla.

Vea este vídeo o siga leyendo para saber cómo solucionar este problema.

Botón Conectar correos electrónicos

También puede utilizar el Directorio de Búsqueda para corregir los errores o completar la información que falta de su Microsoft Entra ID. Si todas las coincidencias son correctas, puede elegir el botón Current identity (Identidad actual) para seleccionar todas las entradas coincidentes en lugar de seleccionarlas de una en una.

Ventana flotante Conectar correos electrónicos

Después, seleccione Continuar para ir a una lista de los cambios que van a realizarse. Si está de acuerdo, seleccione Guardar para aplicar los cambios. El suscriptor también recibirá un mensaje que le informa del cambio la próxima vez que inicie sesión en su suscripción. Observe que en esta lista solo aparecen los dos abonados que coincidían en el ID de Microsoft Entra. En nuestro ejemplo, como Frederick no tenía una dirección correspondiente en el Microsoft Entra ID, la cuenta Microsoft (MSA) no se emparejó con una cuenta de trabajo.

Nota:

Al editar la dirección de correo electrónico de inicio de sesión, solo se actualiza la dirección que usa el suscriptor para iniciar sesión en su suscripción en https://my.visualstudio.com. Si el suscriptor ha usado las otras direcciones de correo electrónico para activar beneficios como Azure o Pluralsight, deberá seguir usando esas direcciones de correo electrónico para acceder a ellos. Si acceden a nuevas ventajas, deberán usar la nueva dirección de correo electrónico.

Recursos de soporte técnico

Para obtener ayuda con la administración de suscripciones de Visual Studio, póngase en contacto el soporte técnico de suscripciones de Visual Studio.

Consulte también

Pasos siguientes

  • Si actualiza las direcciones de correo electrónico de los suscriptores, debería informarles de que ha cambiado su información de inicio de sesión. Reciben un correo electrónico con la información actualizada.
  • Puede ser útil filtrar la lista de suscriptores de su organización para buscar direcciones de correo electrónico de inicio de sesión que deban modificarse.