Dispositivo de audio USB que no se reproduce
En este artículo se describe el error "Servicios de audio que no responden" y el dispositivo de audio USB no funciona en Windows 10 versión 1703.
Síntomas
Considere el caso siguiente:
- Conecta un dispositivo de audio de bus serie universal (USB), como un adaptador de audio o un convertidor digital a analógico USB (DAC), a un equipo Windows por primera vez.
- El sistema operativo detecta el dispositivo y carga el controlador estándar de audio USB 2.0 (usbaudio2.sys).
- A continuación, Windows descarga el controlador específico del dispositivo desde Windows Update.
- El controlador de dispositivo descargado reemplaza al controlador de usbaudio2.sys.
En este escenario, el dispositivo no se puede usar y el equipo no tiene sonido. El icono del altavoz de la barra de tareas se marca con una marca X. Al seleccionar el icono, recibirá el siguiente mensaje:
Los servicios de audio no responden. Tanto el audio de Windows como los servicios del Generador de puntos de conexión de audio de Windows deben ejecutarse para que el audio funcione correctamente.
Causa
Este problema de "audio no reproduciendo" se produce porque el controlador predeterminado de audio USB 2.0 (usbaudio2.sys) usa el puerto WaveRT para la operación, pero el controlador específico del dispositivo no. Sin embargo, ambos controladores usan la cadena de referencia "wave" cuando se registra la interfaz del dispositivo.
Cuando el controlador específico del dispositivo reemplaza al controlador predeterminado, la interfaz de dispositivo creada por usbaudio2.sys se sigue usando porque las cadenas de referencia se superponen. Por lo tanto, el sistema operativo asume que el nuevo controlador también admite el puerto WaveRT. Dado que el nuevo controlador no admite el puerto WaveRT, el sistema no puede acceder al controlador.
Resolución
Para solucionar este problema, use uno de los métodos siguientes.
Método 1
Siga estos pasos para desinstalar el dispositivo:
- Abra el Administrador de dispositivos.
- Haga doble clic en el nombre del dispositivo.
- Seleccione la pestaña Controlador .
- Seleccione Desinstalar dispositivo.
Nota
No active la casilla Eliminar el software del controlador para este dispositivo .
Método 2
Conecte el dispositivo a otro puerto USB. Es posible que el problema no se produzca si el dispositivo está conectado a un puerto USB diferente.
Método 3
Si el dispositivo aún no está conectado, instale primero el controlador específico del dispositivo mediante el instalador del dispositivo. A continuación, conecte el dispositivo. Windows selecciona ahora el controlador específico del dispositivo en lugar del controlador de audio USB 2.0 predeterminado. Este método funciona porque el problema solo se produce si el controlador específico del dispositivo reemplaza el controlador predeterminado después de que el dispositivo esté conectado.