Comprobación de error 0xC000021A: WINLOGON_FATAL_ERROR

La comprobación de errores WINLOGON_FATAL_ERROR tiene un valor de 0xC000021A. Esto significa que el proceso de Winlogon finalizó inesperadamente.

Importante

Este artículo es para programadores. Si es un cliente que ha recibido un código de error de pantalla azul mientras usa el equipo, consulte Solución de errores de pantalla azul.

parámetros de WINLOGON_FATAL_ERROR

Parámetro Descripción

1

Cadena que identifica el problema

2

Código de error.

3

Reserved

4

Reserved

Causa

Este error se produce cuando un subsistema en modo de usuario, como WinLogon o el Subsistema de tiempo de ejecución del servidor cliente (CSRSS), se ha puesto en peligro gravemente y la seguridad ya no se puede garantizar. En respuesta, el sistema operativo cambia al modo kernel. Microsoft Windows no se puede ejecutar sin WinLogon ni CSRSS. Por lo tanto, se trata de uno de los pocos casos en los que el error de un servicio en modo de usuario puede apagar el sistema.

Los archivos del sistema no coincidendo también pueden provocar este error. Esta falta de coincidencia puede producirse si ha restaurado el disco duro desde una copia de seguridad. Algunos programas de copia de seguridad pueden omitir la restauración de archivos del sistema que determinan que están en uso.

Solución

La ejecución del depurador de kernel puede no ser útil en esta situación porque se produjo el error real en un proceso en modo de usuario.

Resolución de un error en un controlador de dispositivo en modo de usuario, servicio del sistema o aplicación de terceros

Dado que la comprobación de errores 0xC000021A se produce en un proceso en modo de usuario, los culpables más comunes son aplicaciones de terceros. Si se produjo el error después de la instalación de un controlador de dispositivo nuevo o actualizado, servicio del sistema o aplicación de terceros, el nuevo software debe quitarse o deshabilitarse para aislar la causa. Póngase en contacto con el fabricante del software sobre una posible actualización.

Resolución de un problema de archivo del sistema no coincidente

Si ha restaurado recientemente el disco duro desde una copia de seguridad, compruebe si hay una versión actualizada del programa de copia de seguridad o restauración disponible en el fabricante.

  • Examine las aplicaciones instaladas más recientemente. Para ello, vaya a "Desinstalar o cambiar un programa" en el panel de control y ordene las aplicaciones instaladas por fecha de instalación.

  • Compruebe el inicio de sesión del sistema Visor de eventos si hay mensajes de error adicionales que podrían ayudar a identificar el dispositivo o el controlador que está causando el error. Para obtener más información, consulte Abrir Visor de eventos. Busque en el registro del sistema errores críticos que se hayan producido en la misma ventana de tiempo que la pantalla azul.

  • Compruebe el inicio de sesión del sistema Visor de eventos si hay mensajes de error adicionales que podrían ayudar a identificar el dispositivo o el controlador que está causando el error. Busque en el registro del sistema errores críticos que se hayan producido en la misma ventana de tiempo que la pantalla azul.

Comentarios

  • Use la herramienta Comprobador de archivos del sistema para reparar los archivos del sistema que faltan o están dañados. El Comprobador de archivos del sistema es una utilidad en Windows que permite a los usuarios buscar daños en los archivos del sistema de Windows y restaurar archivos dañados. Use el siguiente comando para ejecutar la herramienta Comprobador de archivos del sistema (SFC.exe).

    SFC /scannow
    

    Para obtener más información, vea Usar la herramienta Comprobador de archivos del sistema para reparar archivos del sistema que faltan o están dañados.

  • Ejecute un programa de detección de virus. Los virus pueden infectar todos los tipos de discos duros con formato para Windows, y los daños en el disco resultante pueden generar códigos de comprobación de errores del sistema. Asegúrese de que el programa de detección de virus comprueba el registro de arranque maestro para detectar infecciones.

  • Compruebe que el sistema tiene instaladas las actualizaciones más recientes. Para detectar qué versión está instalada en el sistema, seleccione Iniciar, ejecutar, escriba winver y presione ENTRAR. El cuadro de diálogo Acerca de Windows muestra el número de versión de Windows (y el número de versión del Service Pack, si se instala uno).

Uso del modo Caja fuerte

Considere la posibilidad de usar Caja fuerte Modo para aislar los elementos para solucionar problemas y, si es necesario, usar Windows. El uso del modo Caja fuerte solo carga los controladores y servicios del sistema mínimos necesarios durante el inicio de Windows.

Para entrar en modo Caja fuerte, use Actualizar y seguridad en Configuración. Seleccione Inicio avanzado de recuperación>para arrancar en modo de mantenimiento. En el menú resultante, elija Solucionar problemas>de opciones>avanzadas de inicio Configuración> Reiniciar. Después de que Windows se reinicie y muestre la pantalla Inicio Configuración, seleccione la opción 4, 5 o 6 para arrancar en modo Caja fuerte.

Caja fuerte Modo también puede estar disponible presionando una tecla de función en el arranque, por ejemplo F8. Consulte la información del fabricante del equipo para obtener opciones de inicio específicas.