Comment supprimer des dossiers en double dans Outlook lorsqu’il est connecté à une boîte aux lettres Exchange Server

Symptômes

Dans Microsoft Outlook, vous voyez des dossiers en double dans votre boîte aux lettres Microsoft Exchange Server lorsque vous affichez la liste des dossiers Outlook ou lorsque vous affichez la liste des dossiers à l’aide d’Outlook Web App (OWA).

Cause

Un appareil mobile ou une application serveur tierce qui se synchronise avec la boîte aux lettres Exchange Server peut introduire de manière inattendue la duplication. Ou bien, la duplication inattendue peut être le résultat de Exchange Server maintenance de boîte aux lettres ou d’autres modifications effectuées sur l’ordinateur qui exécute Exchange Server. D’autres facteurs peuvent également contribuer au problème décrit dans la section Symptômes de cet article.

Résolution

Les étapes suivantes peuvent entraîner une perte de données si vous ne les suivez pas exactement comme écrit. Nous vous recommandons de sauvegarder les données Outlook ou de vous assurer que la boîte aux lettres Exchange Server a été sauvegardée avant de procéder à ces étapes.

Pour supprimer les éléments en double, procédez comme suit :

  1. Quittez Outlook et fermez OWA sur toutes les stations de travail connectées à la boîte aux lettres de l’utilisateur.

  2. Utilisez MFCMapi pour identifier les dossiers en double. Pour cela, procédez comme suit :

    1. Téléchargez MFCMAPI (faites défiler vers le bas, puis sélectionnez Dernière version).
    2. Exécutez MFCMAPI.exe.
    3. Sélectionnez le menu Outils , puis sélectionnez Options.
    4. Activez l’option suivante :
      • Utiliser MDB_ONLINE lors de l’appel d’OpenMsgStore
    5. Sélectionnez OK.
    6. Dans le menu Session, cliquez sur Ouverture de session.
    7. Si vous êtes invité à entrer un profil, sélectionnez votre nom de profil, puis sélectionnez OK.
    8. Dans le volet supérieur, recherchez la ligne qui correspond à votre boîte aux lettres, puis double-cliquez dessus.
    9. Dans le volet de navigation (volet gauche), développez Conteneur racine, puis En haut de la banque d’informations.
    10. Pour identifier le dossier en double, sélectionnez l’un des dossiers en double dans le volet gauche. Dans le volet droit, recherchez la colonne Valeur de la PR_CREATION_TIME propriété . Comparez cette valeur au dossier dupliqué portant le même nom. Le dossier en double aura une date et une heure de création plus récentes. Utilisez une paire de dossiers à la fois (par exemple, commencez par les deux dossiers Calendrier qui s’affichent).
  3. Utilisez MFCMAPI pour copier tous les éléments du dossier dupliqué vers le dossier d’origine. Il s’agit d’éléments créés après la création des dossiers en double. Cela peut inclure le courrier électronique reçu dans la boîte de réception, les contacts qui ont été créés, les rendez-vous du calendrier que vous avez planifiés et les réunions que vous avez acceptées.

    1. Dans le volet gauche de MFCMAPI, double-cliquez sur le dossier dupliqué, qui a la date et l’heure de création les plus récentes.

    2. Dans la fenêtre qui s’ouvre, sélectionnez le volet supérieur, puis appuyez sur Ctrl+A pour sélectionner tous les éléments.

      Si aucun élément n’apparaît dans le volet supérieur, le dossier est déjà vide ; passez à l’étape 7.

    3. Sélectionnez le menu Actions , puis sélectionnez la commande Copier les messages .

    4. Fermez la fenêtre dossier, puis double-cliquez sur le dossier d’origine, dont la date et l’heure de création sont plus anciennes.

    5. Sélectionnez le menu Actions , puis sélectionnez la commande Coller les messages .

    6. Activez la case à cocher MESSAGE_MOVE , puis sélectionnez OK.

    7. Fermez la fenêtre dossier.

  4. Dans MFCMAPI, revenez au dossier dupliqué, qui est maintenant vide. Utilisez MFCMAPI pour le supprimer.

    1. Cliquez avec le bouton droit sur le dossier dupliqué, puis sélectionnez Supprimer le dossier.
    2. Activez l’option Suppression définitive , puis sélectionnez OK.
  5. Répétez les étapes 2 à 4 pour les autres dossiers Outlook courants (Contacts, Éléments supprimés, Brouillons, Boîte de réception, Journal, Courrier indésirable, Notes, Éléments envoyés et Tâches).

  6. Fermez MFCMAPI.

  7. Démarrez Outlook avec le resetfolders commutateur :

    1. Ouvrez la boîte de dialogue Exécuter. Pour cela, utilisez l’une des procédures suivantes en fonction de votre version de Windows :

      Windows 10, Windows 8.1 et Windows 8 : appuyez sur Touche Windows+R.
      Windows 7 et Windows Vista : Sélectionnez le bouton Démarrer , pointez sur Tous les programmes, sélectionnez Accessoires, puis sélectionnez Exécuter.
      Windows XP : Sélectionnez le bouton Démarrer de Windows, puis sélectionnez Exécuter.

    2. Dans la boîte de dialogue Exécuter , tapez ce qui suit, puis sélectionnez OK :

      Outlook.exe /resetfolders

Informations supplémentaires

Pour plus d’informations sur les commutateurs de ligne de commande dans Outlook, voir Commutateurs de ligne de commande pour les produits Microsoft Office