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La fonctionnalité Absence du bureau dans Outlook ne fonctionne pas correctement dans Microsoft 365

Symptômes

Lorsque vous essayez d’utiliser la fonctionnalité Absence du bureau (OOF) dans Outlook dans Microsoft 365, vous rencontrez les symptômes suivants :

  • Impossible d’enregistrer le message OOF.
  • Un message OOF ancien ou dupliqué est envoyé.
  • Un message OOF n’est pas envoyé même si vous activez le message OOF.

Cause

Ce problème se produit pour l’une des raisons suivantes :

  • Cause 1 : Il existe un backlog d’événements de assistant de boîte aux lettres (Exchange 2010 uniquement).
  • Cause 2 : Les modèles de règles OOF sont incorrects ou endommagés.
  • Cause 3 : Le quota de règles OOF est dépassé et de nouvelles règles ne peuvent pas être créées.
  • Cause 4 : Le paramètre Domaine distant pour le domaine par défaut (ou spécifique) n’est pas défini pour autoriser les messages OOF.

Résolution

Remarque

L’une des quatre causes peut entraîner l’échec d’une réponse OOF. Par conséquent, chaque cause doit être exclue une par une.

Avertissement

L’utilisation de l’Microsoft Exchange Server MAPI Rédacteur (MFCMapi) peut endommager Microsoft Exchange Server et les boîtes aux lettres du serveur Exchange. Téléchargez MFCMAPI à partir de github (faites défiler vers le bas, puis sélectionnez Dernière version).

Pour résoudre ce problème, suivez les étapes correspondant à la cause spécifique.

Résolution 1

  1. Configurez la fonctionnalité OOF. Pour ce faire, exécutez l’une des applets de commande suivantes dans Windows PowerShell, le cas échéant :

    Set-MailboxAutoReplyConfiguration <identity> -AutoReplyState Disabled
    Set-MailboxAutoReplyConfiguration <identity> -AutoReplyState Enabled

  2. Utilisez MFCMapi pour case activée la PR_OOF_STATE valeur. Pour cela, procédez comme suit :

    1. Dans la fenêtre main de MFCMapi, sélectionnez Session, puis Ouvrir une session et Afficher la table du magasin pour ouvrir la boîte aux lettres.

    2. Sélectionnez le profil auquel vous accédez, puis faites défiler vers le bas dans le volet inférieur jusqu’à ce que la valeur s’affiche PR_OOF_STATE . Cette valeur doit être True si vous avez activé la fonctionnalité OOF dans Windows PowerShell ou False si vous avez désactivé la fonctionnalité OOF. Par exemple, si vous avez désactivé la fonctionnalité OOF, envisagez la capture d’écran suivante :

      Capture d’écran de la valeur PR_OOF_STATE.

  3. Si la PR_OOF_STATE valeur n’est pas le résultat attendu, contactez Support Microsoft pour qu’ils case activée pour les événements en file d’attente (Exchange 2010 uniquement).

Résolution 2

Remarque

Les symptômes dans votre cas peuvent différer légèrement de ceux-ci. Par exemple, le message OOF ne peut pas être envoyé comme prévu, bien que le message OOF puisse être défini sans erreur. Toutefois, ces étapes s’appliquent toujours.

Pour résoudre ce problème, supprimez les règles OOF et les modèles de règles OOF de la boîte aux lettres. Ensuite, réactivez la fonctionnalité OOF et testez le comportement. Pour cela, procédez comme suit.

Remarque

Vous n’avez pas besoin de sauvegarder le message OOF lorsque vous suivez ces étapes.

  1. Dans la fenêtre main de MFCMapi, sélectionnez Session, puis Ouvrir une session et Afficher la table du magasin pour ouvrir la boîte aux lettres.

  2. Développez le conteneur racine et le haut de la banque d’informations.

  3. Supprimez les règles OOF. Pour cela, procédez comme suit :

    1. Cliquez avec le bouton droit sur Boîte de réception, puis sélectionnez Afficher la table des règles.

      • Si la fonctionnalité OOF est désactivée, une règle OOF est répertoriée dans la table des règles avec le nom de règle suivant :
        MSFT : Règles OOF TDX

      • Si la fonctionnalité OOF est activée, deux règles OOF différentes sont répertoriées dans la table des règles. Les règles répertoriées varient selon que la règle est activée uniquement en interne ou à la fois en interne et en externe. Par exemple, considérez la capture d’écran suivante :

        Capture d’écran des détails de la boîte de dialogue Table de règles.

      • Si les modèles OOF sont endommagés ou mal formés, ces modèles OOF sont répertoriés dans la table des règles. Vous pouvez voir d’autres entrées si d’autres règles sont activées pour l’utilisateur.

    2. Cliquez avec le bouton droit sur les règles OOF, puis sélectionnez Supprimer.

      Remarque

      Ne supprimez aucune règle OOF à l’exception de celles qui sont référencées.

    3. Fermez la fenêtre Table de règles.

  4. Supprimez les modèles OOF. Pour cela, procédez comme suit :

    • Cliquez avec le bouton droit sur Boîte de réception, puis sélectionnez Ouvrir la table de contenu associée.
    • Faites défiler vers la droite, puis développez la colonne Classe de message .
    • Pour trier les éléments, sélectionnez la colonne Classe de message .
    • Recherchez les éléments dont la classe message est l’une des valeurs suivantes :
      • IPM. Remarque.Rules.ExternalOofTemplate.Microsoft
      • IPM. Remarque.Rules.OofTemplate.Microsoft

Par exemple, considérez la capture d’écran suivante :

Capture d’écran des règles OOF qui peuvent être supprimées.

  • Cliquez avec le bouton droit sur les éléments qui appartiennent à l’une de ces deux classes de messages, puis sélectionnez Supprimer le message.

    Remarque

    Ne supprimez aucun élément, sauf ceux qui sont référencés.

    Capture d’écran des règles OOF qui peuvent être supprimées.

  • Dans la boîte de dialogue Supprimer l’élément , sélectionnez Suppression définitive en passant DELETE_HARD_DELETE (irrécupérable) sous Style de suppression, puis sélectionnez OK.

    Sélectionnez l’option Suppression définitive passant DELETE_HARD_DELETE (irrécupérable) sous Style de suppression.

  • Désactivez, puis réactivez la fonctionnalité OOF à l’aide des commandes suivantes :

    Set-MailboxAutoReplyConfiguration \<identity> -AutoReplyState Disabled
    Set-MailboxAutoReplyConfiguration \<identity> -AutoReplyState Enabled

  • Vérifiez si la fonctionnalité OOF fonctionne comme prévu et si les symptômes ne se produisent plus.

Résolution 3

Si une réponse OOF n’est plus retournée, il est probable que le quota de règles soit dépassé. Par conséquent, les règles OOF internes et externes ne peuvent pas être créées. Pour résoudre ce problème, procédez comme suit :

  1. Augmentez votre quota de règles. Pour ce faire, suivez les étapes décrites dans l’article suivant :

    Un utilisateur ne peut pas créer de règles dans Outlook ou Outlook Web App

  2. En raison de la mise en cache des informations de quota dans la banque d’informations, les valeurs de quota mises à jour peuvent nécessiter jusqu’à deux heures pour prendre effet.

  3. Répétez la résolution 2.

Résolution 4

Si la valeur AllowedOFFType pour le domaine distant est None, les messages OOF ne se déclenchent pas en externe. Cette valeur doit être définie sur Externe pour autoriser les fichiers OOF externes. Par défaut, cette valeur est définie sur Aucun. N’oubliez pas que lorsque vous effectuez une recherche dans les domaines distants, la valeur par défaut est remplacée par des entrées spécifiques. Par conséquent, si l’utilisateur envoie à un @contoso.com utilisateur et qu’il existe une Contoso.com entrée dans les paramètres du domaine distant, la valeur AllowedOOFType est utilisée pour cette entrée spécifique. S’il n’existe aucune entrée pour Contoso.com, le domaine distant par défaut (*) est utilisé.

Get-RemoteDomain | select Name,AllowedOOFType