Erreur « L’exception RPC 1726 s’est produite dans la session 10 » lorsque vous passez en revue le journal des applications sur l’ordinateur qui exécute les services Microsoft Dynamics AX AOS

Cet article fournit une résolution des erreurs qui se produisent lorsque vous passez en revue le journal des applications sur un ordinateur qui exécute les services AOS (Application Object Server) Microsoft Dynamics AX 4.0.

S’applique à : Microsoft Dynamics AX
Numéro de la base de connaissances d’origine : 937873

Symptômes

Lorsque vous passez en revue le journal des applications sur un ordinateur qui exécute les services Microsoft Dynamics AX 4.0 Application Object Server (AOS), vous pouvez voir des messages d’erreur qui ressemblent aux suivants :

Message d’erreur 1

Type d'événement : information
Source de l’événement : Dynamics Server 17
Date : 4/07/2007
Heure :12 :30 :14 PM
Catégorie d’événement : Aucun
Description :
Serveur d’objets 01 : erreur RPC : l’exception RPC 1726 s’est produite dans la session 10

Message d’erreur 2

Type d'événement : information
Source de l’événement : Dynamics Server 01
Catégorie d’événement : Aucun
ID d’événement : 110
Date : 4/07/2007
Heure :12 :30 :33 AM
Utilisateur : N/A
Ordinateur : ComputerName
Description :
Object Server 01 : aucun test ping à partir de 10. Mettre fin à la session.

Le premier message d’erreur peut être associé au deuxième message d’erreur. Jusqu’à ce que le serveur AOS termine la session 10, chaque session qui retourne des messages d’erreur RPC cesse de répondre. Si trop de sessions cessent de répondre et retournent des messages d’erreur RPC, le serveur AOS peut s’arrêter.

Cause

Ce problème peut se produire parce que les utilisateurs quittent Microsoft Dynamics AX sans autorisation. Par exemple, les utilisateurs terminent le processus Microsoft Dynamics AX à l’aide du Gestionnaire des tâches.

RPC 1726 est un message d’erreur de connexion général. Toutefois, le message d’erreur RPC 1726 peut être associé au ping No de 10. Fin du message d’erreur de session . Dans ce cas, le problème est généralement dû au fait que les utilisateurs quittent Microsoft Dynamics AX sans honte.

Résolution

Si vous rencontrez ce problème sur le client Microsoft Dynamics AX, ne quittez pas le client en appuyant sur Ctrl+Alt+Suppr. Nous vous recommandons d’utiliser Ctrl+Arrêt, puis d’attendre que le système redevient réactif ou de contacter l’administrateur Microsoft Dynamics AX ou un autre utilisateur disposant des droits sur le formulaire d’utilisateurs en ligne. L’administrateur ou l’autre utilisateur peut sélectionner Terminer la session pour arrêter la session cliente.

Informations supplémentaires

Si vous rencontrez ce problème sur le serveur AOS, il est important de déterminer quelle session est la cause et ce que les utilisateurs font pour provoquer le problème.

Pour ce faire, exécutez le script suivant :

select * from sysuserlog where logouttime = 0 and sessionid = <X>

Remarque

Remplacez X> par< la session indiquée dans le message d’erreur RPC. Dans les résultats de la requête, notez les colonnes USERID et COMPUTERNAME . Les valeurs de colonne indiquent qui se connecte et d’où.

En règle générale, les exceptions RPC sont provoquées par le fait de quitter l’application de manière incorrecte. Toutefois, les exceptions peuvent également indiquer qu’un processus métier est suspendu ou prend beaucoup de temps.

References

Pour plus d’informations, consultez Comment rechercher un ID utilisateur associé à un ID de session dans un message d’erreur dans le journal des applications sur le serveur AOS dans Microsoft Dynamics AX : « Erreur RPC : exception RPC 1726 s’est produite dans sessionID <>».