Partager via


Erreur d’accès refusé lorsque vous essayez de vous connecter Microsoft Dynamics CRM pour Office Outlook

Cet article fournit une solution à une erreur qui se produit lorsque vous essayez de vous connecter Microsoft Dynamics CRM pour Office Outlook.

S’applique à : Microsoft Dynamics CRM 2015, Microsoft Dynamics CRM 2013
Numéro de la base de connaissances d’origine : 3088205

Symptômes

Lorsque vous essayez de vous connecter à Microsoft Dynamics CRM pour Office Outlook avec un organization CRM local et que vous n’incluez pas le nom du organization dans l’URL d’authentification basée sur les revendications, le message d’erreur suivant s’affiche :

« Impossible de se connecter à Microsoft Dynamics CRM serveur, car nous ne pouvons pas authentifier vos informations d’identification.

Vérifiez votre connexion ou contactez votre administrateur pour obtenir de l’aide. »

Cause

Microsoft Dynamics CRM pour Office Outlook n’a pas pu vous authentifier, car le nom du organization n’était pas inclus dans l’URL.

Résolution

Fournissez le nom organization dans le cadre de l’URL d’authentification basée sur les revendications lors de la configuration du Microsoft Dynamics CRM pour le client Office Outlook.

Exemple de format d’URL : https://<crmservername>.<domain>.<domainsuffix>/<orgname>
Exemple d’URL : https://crmserver.contoso.com/contoso

Remarque

Si votre Microsoft Dynamics CRM organization est configuré en tant que déploiement accessible sur Internet (IFD), vous pouvez également y accéder via votre URL IFD qui inclut le nom organization :

Exemple de format d’URL IFD : https://<orgname>.<domain>.<domainsuffix>
Exemple d’URL IFD : https://contoso.contoso.com

Informations supplémentaires

Lorsque vous sélectionnez Détails, les informations supplémentaires suivantes s’affichent et sont également disponibles dans le fichier journal :

L’accès est refusé.

Trace de la pile du serveur :
sur System.ServiceModel.Channels.ServiceChannel.ThrowIfFaultUnderstood(Message reply, MessageFault fault, String action, MessageVersion version, FaultConverter faultConverter)
sur System.ServiceModel.Channels.ServiceChannel.HandleReply(ProxyOperationRuntime operation, ProxyRpc& rpc)
dans System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeSpan)
sur System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, opération ProxyOperationRuntime)
sur System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)

L’exception a resserpé à [0] :
dans System.Windows.Forms.Control.MarshaledInvoke(Control caller, Delegate method, Object[] args, Boolean synchronous)
sur System.Windows.Forms.Control.Invoke(Delegate method, Object[] args)
sur System.Windows.Forms.Control.Invoke(Delegate method)
sur Microsoft.Crm.Outlook.ClientAuth.ClientAuthProvider'1.RetrieveUserCredentialsAndSignIn(Control parentWindow, Boolean retryOnError, IClientOrganizationContext context)
sur Microsoft.Crm.Outlook.ClientAuth.ClientAuthProvider'1.SignIn(AuthUIMode uiMode, IClientOrganizationContext context, Control parentWindow, Boolean retryOnError)
Microsoft.Crm.Application.Outlook.Config. DeploymentsInfo'1.DeploymentInfo'1.LoadOrganizationsInternal(AuthUIMode uiMode, Control parentWindow)
Microsoft.Crm.Application.Outlook.Config. DeploymentsInfo'1.DeploymentInfo'1.LoadOrganizations(AuthUIMode uiMode, Control parentWindow, IClientAuthProvider'1 authenticatedProvider)
Microsoft.Crm.Application.Outlook.Config. DeploymentsInfo'1.InternalLoadOrganizations(DataCollection'1 orgs, AuthUIMode uiMode, Control parentWindow)