L’entité personnalisée n’apparaît pas après l’importation d’une solution

Cet article fournit une solution à un problème où les entités personnalisées ne s’affichent pas après l’importation d’une solution.

S’applique à : Microsoft Dynamics CRM 2011
Numéro de la base de connaissances d’origine : 2500942

Symptômes

Après avoir importé une solution dans un autre organization, l’entité personnalisée n’apparaît pas.

Cause

Cela se produit lorsque la solution n’a pas SiteMap comme composant.

Cela peut également se produire si vous ne publiez pas vos personnalisations après l’importation de la solution.

Résolution

Résolution 1 :

Incluez SiteMap dans le cadre de la solution et réexportez la solution. Ensuite, importez la solution dans un autre organization.

  1. Sélectionnez Paramètres, Solutions, puis ouvrez la solution que vous souhaitez modifier.
  2. Sélectionnez Extensions clientes, Ajouter existant, puis Plan de site.
  3. Sélectionnez Enregistrer.
  4. Sélectionnez Exporter la solution et suivez l’Assistant Exportation pour exporter votre solution.

Résolution 2 :

Personnalisez l’entité personnalisée importée sur le organization où la solution a été importée pour afficher l’entité dans la zone souhaitée, comme Workplace.

  1. Sélectionnez Paramètres, Personnalisations, puis Personnaliser le système.
  2. Sous Composants, développez Entités, puis sélectionnez l’entité que vous souhaitez modifier.
  3. Sous Zones qui affichent cette entité, sélectionnez les zones pour afficher l’entité personnalisée.

Résolution 3 :

Publier toutes les personnalisations :

  1. Sélectionnez Paramètres, Personnalisations, puis Personnaliser le système.
  2. Sélectionnez Publier toutes les personnalisations.

Publiez uniquement l’entité personnalisée :

  1. Sélectionnez Paramètres, Personnalisations, puis Personnaliser le système.
  2. Sous Composants, développez Entités et sélectionnez l’entité que vous souhaitez publier.
  3. Sélectionnez Publier dans le ruban.