Nous sommes désolés. Votre serveur n’est pas disponible ou ne prend pas en charge cette application. Une erreur se produit lors de la connexion à l’application CRM sur un iPad ou un iPhone

Cet article fournit une solution à une erreur qui se produit lorsque vous connectez un iPhone ou un iPad à l’application Dynamics CRM.

S’applique à : Microsoft Dynamics CRM 2013, Microsoft Dynamics CRM 2015
Numéro de la base de connaissances d’origine : 3069747

Symptômes

Lorsque vous essayez de connecter un iPhone ou un iPad à l’application Dynamics CRM, vous pouvez recevoir l’erreur :

« Nous sommes désolés. Votre serveur n’est pas disponible ou ne prend pas en charge cette application. »

Cause

Les certificats SSL générés par certaines autorités de certification externes peuvent rencontrer des problèmes avec la confiance de l’ensemble de la chaîne de certificats lors de la configuration de l’application CRM sur un iPhone ou un iPad.

Informations supplémentaires

L’accès au site Microsoft Dynamics CRM via une application web fonctionne correctement. Toutefois, sur les appareils iOS, le certificat SSL configuré pour AD FS et CRM peut être considéré comme non approuvé. Vous verrez des erreurs similaires liées aux certificats lors de l’utilisation d’applications iOS qui restituent les pages web à l’aide d’UIWebViews et WKWebViews.

Les journaux d’activité de l’appareil iOS affichent :

Authentification : authentification interrompue.

Cela a été rencontré lorsque le certificat SSL est un certificat générique pour l’ensemble du domaine, tel que *.contoso.com. Le domaine racine tel que https://contoso.com fonctionne correctement. Les sous-domaines tels que https://crm.contoso.com ne fonctionnent pas comme prévu. Cela peut être dû à la compatibilité avec les appareils iOS et les certificats qui répertorient les autres noms d’objet génériques. Il est recommandé de tester avec des certificats dont le niveau racine inclut le sous-domaine CRM tel que *.crm.domain.com.