« L’action n’est pas disponible. Pour utiliser cette action, vous devez d’abord sélectionner l’ancienne solution, puis réessayer » s’affiche dans Dynamics 365.
Cet article fournit une solution à une erreur qui se produit lorsque vous sélectionnez une solution dans Dynamics 365, puis sélectionnez le bouton Appliquer la mise à niveau de la solution.
S’applique à : Microsoft Dynamics 365
Numéro de base de connaissances d’origine : 4457887
Symptômes
Lorsque vous sélectionnez une solution dans Dynamics 365, puis sélectionnez le bouton Appliquer la mise à niveau de la solution, vous recevez l’erreur suivante :
« L’action n’est pas disponible.
Pour utiliser cette action, vous devez d’abord sélectionner l’ancienne solution, puis réessayer. »
Si vous sélectionnez Télécharger le fichier journal, le fichier journal inclut une référence au code d’erreur -2147187396.
Cause
Ce message s’affiche si la solution que vous avez sélectionnée est la mise à jour de la solution et non la solution parente.
Le bouton Appliquer la mise à niveau de la solution est destiné à être utilisé lorsque vous avez importé une mise à jour pour une autre solution déjà installée. Lors de l’importation de la solution mise à jour, une option Étape de mise à niveau s’affiche. Si cette case à cocher est cochée, l’action de mise à niveau n’est pas effectuée lors de l’importation de la solution. Un bouton Appliquer la mise à niveau de la solution s’affiche à la fin du processus d’importation. Si vous n’avez pas sélectionné ce bouton, vous pouvez trouver la solution parente dans la liste des solutions, puis sélectionner Appliquer la mise à niveau de la solution.
Exemple : Vous avez précédemment importé une solution appelée SolutionA version 1.0.0.0. Plus tard, vous importez une version plus récente de SolutionA qui est la version 1.0.1.0. Lors de l’importation de la solution, l’option Étape de mise à niveau a été sélectionnée. Si vous n’avez pas sélectionné le bouton Appliquer la mise à niveau de la solution qui s’est affiché à la fin du processus d’importation, vous verrez SolutionA et SolutionA_Upgrade également dans la vue Toutes les solutions . Si vous avez sélectionné SolutionA_Upgrade, puis sélectionné Appliquer la mise à niveau de la solution, cette erreur s’affiche. Au lieu de cela, vous devez sélectionner la solution parente (SolutionA), puis sélectionner Appliquer la mise à niveau de la solution.
Résolution
Sélectionnez la solution parente, puis sélectionnez Appliquer la mise à niveau de la solution.