Les scripts côté client ne fonctionnent plus dans Microsoft Dynamics CRM Online après la mise à jour du service de décembre 2012

Cet article vous aide à corriger les erreurs de script une fois que votre organisation Microsoft Dynamics CRM Online a été mise à jour vers la mise à jour du service de décembre 2012.

S’applique à : Microsoft Dynamics CRM Online
Numéro de base de connaissances d’origine : 2804561

Symptômes

Si vos formulaires utilisent l’API cliente V4.0 (crmForm), vous pouvez rencontrer des erreurs de script après la mise à jour de votre organisation Microsoft Dynamics CRM Online vers la mise à jour du service de décembre 2012. Vous pouvez voir apparaître une boîte de dialogue indiquant « Non défini » ou une erreur dans le coin inférieur gauche du formulaire indiquant « Erreur sur la page ». D’autres erreurs de script peuvent apparaître.

Cause

La mise à jour du service de décembre 2012 pour Microsoft Dynamics CRM a introduit un nouveau paramètre système qui contrôle si les composants HTML (HTC) sont inclus dans Microsoft Dynamics CRM formulaires. Ce paramètre est désactivé par défaut dans Microsoft Dynamics CRM Online.

Les propriétés crmForm suivantes nécessitent HTC :

Propriétés CrmForm
. Enregistrer(
. SaveAndClose(
. FormType
. ObjectTypeCode
. Objectid
. ObjectTypeName
. RequiredLevel
. SetFocus(
. FireOnChange
. Min
. Max
. DataValue
.isDirty
. Handicapés
. SelectedOption
. SelectedText
. SortingEnum
. Sorte
. SelectedIndex
. InnerText
. OptionsXml
. Précision
. DataXml
. Texte
. Valeur
. DisplayValue
. WillSubmit
. DataChangeHandler
. BypassValidation
. AllowFormFocus
._bSaving
._htcInitCompleted
. SubmitFormId
.NO_DATA
. RefreshOnSave
. Visible
. ForceSubmit
. Forme
. Timecontrol
.isInitialized
.allowblankdate
. IsMoney
. IsBaseCurrency
. CurrencySymbol
. CurrencyPrecision
. IgnoreCurrencySymbol
. IgnoreRange
. PrecisionChangeHandler
. TrimValue
. Maxlength
Énumérateur

Résolution

  1. Connectez-vous à l’application web Microsoft Dynamics CRM en tant qu’administrateur système.
  2. Cliquez sur Paramètres, sur Administration, puis sur Paramètres système.
  3. Cliquez sur l’onglet Personnalisation .
  4. Cochez la case en regard du paramètre intitulé Inclure la prise en charge de HTC dans Microsoft Dynamics CRM formulaires.
  5. Cliquez sur OK.

Plus d’informations

L’API crmForm a été déconseillée avec la version Microsoft Dynamics CRM 2011. Pour plus d’informations sur cette rubrique et d’autres causes potentielles d’erreurs de script après la mise à jour du service de décembre 2012, consultez les billets de blog suivants :