Code d’erreur : 2147209462 consigné dans l’enregistrement de boîte aux lettres Microsoft Dynamics 365

Cet article vous aide à résoudre le problème qui se produit lorsque l’enregistrement de file d’attente correspondant dans Microsoft Dynamics 365 appartient à une équipe qui n’a pas de rôles de sécurité attribués.

S’applique à : Microsoft Dynamics 365 Customer Engagement Online
Numéro de base de connaissances d’origine : 4500778

Symptômes

L’alerte suivante est consignée dans l’enregistrement de boîte aux lettres d’une boîte aux lettres Dynamics 365 :

Une erreur inconnue s’est produite lors de la réception de messages électroniques via la boîte aux lettres « Votre boîte aux lettres est maintenant connectée à Dynamics 365 ». Le propriétaire du profil de serveur de messagerie associé [Nom de boîte aux lettres] a été averti. Le système essaiera de recevoir des e-mails ultérieurement.
Email code d’erreur du serveur : le serveur Exchange a renvoyé l’exception UnknownIncomingEmailIntegrationError -2147209462.

Cause

Cette erreur est consignée si l’enregistrement file d’attente correspondant dans Dynamics 365 appartient à une équipe qui n’a pas de rôles de sécurité attribués.

Résolution

Pour résoudre ce problème, procédez comme suit :

  1. Dans l’enregistrement de boîte aux lettres dans Dynamics 365, cliquez sur la valeur dans la recherche Concernant pour ouvrir l’enregistrement file d’attente correspondant.
  2. Vérifiez que le propriétaire de cet enregistrement de file d’attente a un rôle de sécurité attribué.
  3. Pour ce faire, cliquez sur la valeur dans le champ Propriétaire pour ouvrir l’enregistrement du propriétaire.
  4. Cliquez sur le bouton Gérer les rôles et attribuez un rôle de sécurité disposant d’un accès suffisant.