L’installation de la solution échoue en raison de dépendances qui n’existent pas dans un environnement CDS

Cet article fournit une solution à un problème où l’installation de la solution échoue en raison de dépendances qui n’existent pas dans un environnement CDS.

S’applique à : Microsoft Dynamics 365
Numéro de base de connaissances d’origine : 4499731

Symptômes

Lorsque vous tentez d’importer une solution dans Dynamics 365, l’importation échoue en raison de dépendances manquantes. Si vous installez la solution à partir du centre d’administration, il se peut qu’un message indiquant l’échec de l’installation s’affiche. Si vous importez une solution à partir de l’application web Dynamics 365, vous pouvez voir plus de détails, tels que les dépendances manquantes.

Cause

Cela peut se produire si la solution nécessite des composants qui n’existent pas dans un environnement CDS (Common Data Service). Un environnement CDS uniquement n’inclut pas toutes les entités et inclut uniquement certaines entités standard. Si la solution que vous tentez d’installer dépend d’une entité qui n’existe pas dans votre environnement (par exemple, une entité qui n’existe que dans l’application de vente), l’installation de la solution échoue.

Résolution

Essayez uniquement d’installer la solution dans un environnement qui inclut les composants requis. De nombreuses solutions disponibles dans le Centre d’administration et AppSource ne peuvent être installées que si vous disposez de certaines licences, telles qu’une licence incluant l’application Sales.