L’installation de la solution échoue en raison de dépendances qui n’existent pas dans un environnement CDS

Cet article fournit une solution à un problème où l’installation de la solution échoue en raison de dépendances qui n’existent pas dans un environnement CDS.

S’applique à : Microsoft Dynamics 365
Numéro de la base de connaissances d’origine : 4499731

Symptômes

Lorsque vous tentez d’importer une solution dans Dynamics 365, l’importation échoue en raison de dépendances manquantes. Si vous installez la solution à partir du centre d’administration, vous pouvez simplement voir un message indiquant que l’installation a échoué. Si vous importez une solution à partir de l’application web Dynamics 365, vous pouvez voir plus de détails, tels que les dépendances manquantes.

Cause

Cela peut se produire si la solution nécessite des composants qui n’existent pas dans un environnement CDS (Common Data Service). Un environnement CDS uniquement n’a pas toutes les entités incluses et inclut uniquement certaines entités standard. Si la solution que vous essayez d’installer dépend d’une entité qui n’existe pas dans votre environnement (par exemple, une entité qui n’existe que dans l’application de vente), l’installation de la solution échoue.

Résolution

Essayez uniquement d’installer la solution dans un environnement qui inclut les composants requis. Il existe de nombreuses solutions disponibles dans le Centre d’administration et AppSource qui ne peuvent être installées que si vous disposez de certaines licences, telles qu’une licence qui inclut l’application Ventes.