Impossible d’importer la solution Dynamics 365 ou d’installer une application en raison de la taille des ressources web

Cet article fournit une solution à un problème où vous ne pouvez pas importer de solution Dynamics 365 ou installer une application en raison de la taille des ressources web.

S’applique à : Microsoft Dynamics 365 Customer Engagement Online
Numéro de base de connaissances d’origine : 4499713

Symptômes

Lorsque vous tentez d’importer une solution Dynamics 365 ou d’installer une application, l’importation/installation échoue. Si vous importez une solution à partir de l’application web Dynamics 365, vous pouvez voir une référence au code d’erreur 8004f114. Si vous installez une application à partir du centre d’administration, vous ne verrez peut-être qu’un message indiquant que l’installation a échoué.

Cause

Si vous avez modifié la limite de taille de pièce jointe dans les paramètres système pour qu’elle soit inférieure à la valeur par défaut de 5 Mo, ce qui peut entraîner l’échec de l’importation de la solution si elle contient une ressource web supérieure à la limite que vous avez configurée.

Résolution

Pour résoudre ce problème, procédez comme suit :

  1. En tant qu’utilisateur disposant du rôle de sécurité Administrateur système, accédez à l’application web Dynamics 365, accédez à Paramètres , puis sélectionnez Administration.
  2. Sélectionnez Paramètres système, puis sélectionnez l’onglet Email.
  3. Recherchez la section intitulée Définir la limite de taille de fichier pour les pièces jointes afin de trouver l’option Taille maximale du fichier.
  4. Si le paramètre actuel est inférieur à la limite par défaut de 5 120 ko, revenez à 5 120, puis sélectionnez OK.
  5. Réessayez d’importer la solution.