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Résoudre les problèmes liés au code d’erreur « PublicIPCountLimitReached »

Cet article explique comment identifier et résoudre l’erreur « PublicIPCountLimitReached » qui se produit lorsque vous essayez de mettre à niveau un cluster Azure Kubernetes Service (AKS).

Conditions préalables

Cet article nécessite Azure CLI version 2.0.65 ou ultérieure. Pour rechercher le numéro de version, exécutez az --version. Si vous devez installer ou mettre à niveau Azure CLI, consultez Guide pratique pour installer Azure CLI.

Pour plus d’informations sur le processus de mise à niveau, consultez la section « Mettre à niveau un cluster AKS » dans Mettre à niveau un cluster Azure Kubernetes Service (AKS).

Symptômes

Une mise à niveau de cluster AKS échoue et vous recevez un message d’erreur « PublicIPCountLimitReached ».

Cause

L’erreur se produit si vous avez atteint le nombre maximal d’adresses IP publiques autorisées pour votre abonnement.

Solution

Pour augmenter la limite ou le quota de votre abonnement, accédez à la Portail Azure, créez un ticket de prise en charge des limites de service et d’abonnement (quotas), puis définissez le type de quota sur Mise en réseau.

Une fois le changement de quota appliqué, essayez de mettre à niveau le cluster vers la même version que celle vers laquelle vous avez précédemment essayé de procéder à la mise à niveau. Ce processus déclenche un rapprochement.

az aks upgrade --resource-group <ResourceGroupName> --name <AKSClusterName> --kubernetes-version <KUBERNETES_VERSION>

Contactez-nous pour obtenir de l’aide

Pour toute demande ou assistance, créez une demande de support ou posez une question au support de la communauté Azure. Vous pouvez également soumettre des commentaires sur les produits à la communauté de commentaires Azure.