MSSQLSERVER_3201
S’applique à : SQL Server
Détails
Attribut | Valeur |
---|---|
Nom du produit | SQL Server |
ID de l’événement | 3201 |
Source de l’événement | MSSQLSERVER |
Composant | SQLEngine |
Nom symbolique | BADOPEN |
Texte du message | Impossible d'ouvrir l'unité de sauvegarde '%ls'. Erreur %ls du système d'exploitation. |
Explication
L’erreur se produit lorsque SQL Server n’est pas en mesure de créer ou d’ouvrir un périphérique de sauvegarde existant pour effectuer une opération de sauvegarde. Les périphériques de sauvegarde incluent des fichiers, des bandes, un appareil virtuel pour VDI. Le message inclut l’erreur du système d’exploitation déclenchée et retournée lorsque l’accès à l’appareil est effectué. Cette erreur de système d’exploitation fournit des informations clés pour vous aider à comprendre la cause racine de l’échec.
L’état de l’erreur peut également fournir des informations utiles. Voici quelques états utiles :
- État 1 et 3 - Créer un fichier de sauvegarde
- État 2 - ouvrir le fichier de sauvegarde
- État 5 - bande ouverte
- État 7 : initialiser un appareil virtuel
- État 6 - Ouvrir un appareil virtuel
- État 8 : ouvrir et obtenir la propriété d’un périphérique de bande
Causes possibles
Plusieurs raisons peuvent exister pour ne pas pouvoir accéder à un appareil de sauvegarde. Exemples courants :
- L’appareil de sauvegarde n’est pas disponible ou n’est pas valide. Les exemples classiques d’erreurs de système d’exploitation associés à ce scénario sont : erreur 2 (Le système ne trouve pas le fichier spécifié.), erreur 6 (Le handle n’est pas valide.), erreur 3 (Le système ne trouve pas le chemin spécifié.)
- Les autorisations insuffisantes empêchent SQL Server d’y accéder à l’erreur de système d’exploitation 5 (Accès refusé.), erreur de système d’exploitation 1117 (Impossible d’effectuer la requête en raison d’une erreur d’appareil d’E/S.)
- L’appareil est endommagé ou contient des données endommagées ou endommagées - Erreur de système d’exploitation 1117 (La demande n’a pas pu être effectuée en raison d’une erreur d’appareil d’E/S.), erreur de système d’exploitation 21 (L’appareil n’est pas prêt.), erreur de système d’exploitation 23 (Erreur de données (vérification de redondance cyclique).), Erreur de système d’exploitation 27 (Le lecteur ne trouve pas le secteur demandé.)
Action de l’utilisateur
Pour résoudre les erreurs où l’appareil n’est pas disponible ou non valide, vérifiez que vous spécifiez l’emplacement correct de l’appareil (chemin, nom) et vérifiez que l’appareil existe et qu’il est en ligne. Par exemple, utilisez l’Explorateur Windows pour accéder à un fichier de sauvegarde et vérifiez qu’il est présent. Pour la sauvegarde vers l’URL sur un compte de stockage Azure, vous pouvez effectuer un test ping ou PsPing sur le port 443 pour vérifier la connectivité.
Pour résoudre les erreurs d’autorisations insuffisantes, assurez-vous que le compte de démarrage SQL Server a reçu l’accès en lecture et en écriture à l’appareil de sauvegarde. Pour la sauvegarde vers l’URL vers le cloud, comme Azure, assurez-vous qu’un jeton de signature d’accès partagé valide (SAP) ou des identités managées existent pour accéder à une ressource Azure.
Les données endommagées ou endommagées sur les appareils sont généralement des problèmes avec le matériel ou moins couramment avec le système d’exploitation. Examinez avec votre administrateur système si l’appareil est intact et si vous pouvez lire ou écrire des données de test sur celui-ci, et réparer ou remplacer l’appareil endommagé.