Articles de la base de connaissances sur le service de traduction automatique de SharePoint Server
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Découvrez comment résoudre les alertes relatives au service de traduction automatique dans le pack d’administration SharePoint Servers 2019, 2016 et 2013 pour Systems Center Operations Manager (SCOM).
Les articles de cette section sont des articles de la base de connaissances pour le service de traduction automatique dans SharePoint Server. En principe, vous accédez à ces articles après avoir cliqué sur un lien figurant dans une alerte de la console Operations Manager. Vous pouvez également recourir à ces articles pour résoudre des problèmes liés au service de traduction automatique.
Téléchargez et installez :
Pack d’administration System Center pour SharePoint Server 2019
Pack d’analyse System Center pour SharePoint Foundation 2013
Utilisez les éléments suivants pour résoudre les alertes relatives au service de traduction automatique :
Service de traduction automatique : base de données de file d'attente inaccessible
Service de traduction automatique : échec de la traduction automatique - #1
Service de traduction automatique : Échec de la traduction automatique - #2
Service de traduction automatique : échec du processus de travail
Service de traduction automatique : base de données de file d’attente inaccessible
**Nom de l’alerte :**Service de traduction automatique : base de données de file d’attente non accessible
Résumé : Un état critique de ce moniteur indique que le service de traduction automatique ne peut pas accéder au contenu qu'il doit traduire.
Symptômes :
Les nouveaux travaux ne peuvent pas être envoyés correctement.
Les éléments de travail existants ne se terminent jamais ou semblent être « bloqués » et ne progressent pas dans la file d'attente des travaux.
Cause
La ou les causes peuvent être les suivantes :
La base de données de file d’attente ne répond pas suffisamment vite, en raison de l’activité sur le réseau ou sur le serveur SQL Server physique.
Les autorisations d’accès à la base de données personnalisée ne sont plus valides.
La base de données de file d’attente est inaccessible.
Résolution
Résolution 1 : Vérifiez l’état de la base de données du service de traduction automatique de SQL Server :
Sur le site web Administration centrale de SharePoint, dans la section Paramètres système du volet de lecture, cliquez sur Gérer les serveurs de cette batterie.
Dans la section Informations sur la batterie de serveurs, notez le serveur de la base de données du Service de traduction automatique, ainsi que le nom et la version de la base de données de configuration.
Démarrez SQL Server Management Studio et connectez-vous au serveur de base de données de configuration.
Si la base de données de configuration n’existe pas, exécutez l’Assistant Configuration des produits et technologies SharePoint.
Résolution 2 : Vérifiez la connexion réseau au serveur SQL Server.
Sur le site web Administration centrale, dans la section Paramètres système du volet de lecture, cliquez sur Gérer les serveurs de cette batterie.
Dans la section Informations sur la batterie de serveurs, notez le serveur de la base de données du Service de traduction automatique, ainsi que le nom et la version de la base de données de configuration.
Ouvrez une fenêtre Invite de commandes et tapez ping pour confirmer la connexion au serveur.
Si la tentative de contact du serveur échoue, cela signifie qu’un problème affecte la connexion réseau ou empêche le serveur de répondre.
Connectez-vous au serveur et résolvez le problème.
Service de traduction automatique : échec de la traduction automatique - #1
**Nom de l’alerte :**Service de traduction automatique : échec de la traduction automatique
Résumé : Un état critique de ce moniteur indique que la traduction automatique via le service de traduction automatique est défectueuse.
Symptômes :
Tant qu’une connexion au service de traduction en ligne n’est pas établie, le service fonctionne correctement mais le traitement de chaque élément de traduction échoue.
Cause
La ou les causes peuvent être les suivantes :
Le service de traduction automatique n’est pas connecté à Internet.
Le service de traduction en ligne est inactif.
Le service de traduction en ligne a subi un certain nombre d’échecs intermittents (au-delà d’un seuil défini).
Résolution
Vérifiez que l’application du service de traduction automatique a accès à Internet :
Vérifiez que le compte d’utilisateur qui exécute cette procédure est membre du groupe Administrateurs de batterie.
Sur le site web Administration centrale, dans la section Gestion des applications, cliquez sur Gérer les applications de service.
Dans la page Gérer les applications de service, dans la liste des applications de service, cliquez sur Service de traduction automatique.
Dans la section Connexion à la traduction en ligne, dans la boîte de dialogue du serveur proxy web, procédez comme suit :
Cliquez sur Utiliser les paramètres Internet par défaut.
Cliquez sur Utiliser le proxy spécifié, puis entrez un nom de serveur proxy web et un numéro de port.
Validez les valeurs de MachineTranslationAddress, MachineTranslationClientId et MachineTranslationCategory pour l’application de service de traduction automatique :
Vérifiez que le compte d’utilisateur qui exécute cette procédure est membre du groupe Administrateurs de batterie.
Dans l’invite de commandes PowerShell, tapez la commande suivante :
Get-SPServiceApplication -Name "name" | ft MachineTranslationAddress, MachineTranslationClientId, MachineTranslationCategory
où « name » est le nom de votre application de service de traduction automatique.
Validez les valeurs renvoyées en les comparant à la documentation ou en effectuant un appel de test.
Corrigez toutes les valeurs pour qu'elles soient validées. Si une valeur ne peut pas être validée, utilisez la valeur par défaut.
Service de traduction automatique : Échec de la traduction automatique - #2
**Nom de l’alerte :**Service de traduction automatique : échec de la traduction automatique
**Résumé :**Un état critique de ce moniteur indique que le travail du minuteur du service de traduction automatique échoue.
Symptômes :
Les nouveaux travaux entrent correctement dans la base de données. Toutefois, les éléments de traduction de ce travail ne démarreront jamais.
Les travaux existants sont susceptibles de ne pas se terminer : tous les éléments de traduction qui sont déjà affectés à des serveurs d'applications peuvent encore se terminer correctement, mais ceux qui ne sont pas affectés à des serveurs d'applications ne démarreront pas. Le travail reste donc indéfiniment incomplet.
Cause
Le travail du minuteur de file d’attente du service de traduction automatique n’est pas en cours d’exécution.
Résolution
Résolution 1 : Redémarrez le service de traduction automatique.
Sur le site web Administration centrale, dans la section Paramètres système du volet de lecture, cliquez sur Gérer les serveurs de cette batterie.
Dans la colonne Serveur, cliquez sur le nom du serveur d'applications défectueux. La page Services sur le serveur s'ouvre.
Dans la colonne Service, recherchez le Service de traduction automatique. Cliquez sur Arrêter, puis sur Démarrer.
Résolution 2 : Créez une application de service de traduction automatique.
Sur le site web Administration centrale, dans la section Gestion des applications du volet de lecture, cliquez sur Gérer les applications de service.
Dans la colonne Type , cliquez sur le nom de l’application de service de traduction automatique qui a l’instance de service défaillante.
Sur le ruban, cliquez sur Supprimer.
Dans la boîte de dialogue Supprimer l’application de service , cliquez sur OK.
Créez une application de service de traduction automatique.
Service de traduction automatique inaccessible
**Nom de l’alerte :**Le service de traduction automatique n’est pas accessible
Résumé : Un état critique de ce moniteur indique que le service de traduction automatique est inaccessible.
Symptômes : Si les appels au service de traduction automatique n'aboutissent pas, aucun travail ne peut être envoyé au serveur d'applications pour son traitement immédiat ou son envoi à la file d'attente des travaux. En d’autres termes, le service est inaccessible et ne fonctionne pas.
Cause
La ou les causes peuvent être les suivantes :
Le serveur d’applications SharePoint Server spécifié est inaccessible.
Le serveur d’applications spécifié répond lentement en raison d’une activité réseau soutenue ou parce qu’il est soumis à une forte charge.
Résolution
Résolution 1 : vérifiez les journaux des erreurs :
Ouvrez l’Observateur d’événements Windows.
Recherchez l’ID d’événement 8049 dans Windows. Journal des événements de l’application.
Dans la description de l’événement, notez le serveur d’applications défectueux.
Résolution 2 : Vérifiez la connexion du serveur d’applications :
À partir du serveur d’applications défectueux, ouvrez le site web Administration centrale de SharePoint.
Si vous ne pouvez pas accéder au site Administration centrale à partir du serveur défectueux, vérifiez que les paramètres réseau sont corrects et que le serveur dispose des autorisations appropriées pour rejoindre la batterie de serveurs SharePoint.
Résolution 3 : Vérifiez que le service de traduction automatique s’exécute sur le serveur défectueux :
Sur le site web Administration centrale, dans le volet de lecture, dans la section Paramètres système, cliquez sur Gérer les serveurs de cette batterie.
Vérifiez que le service de traduction automatique s’exécute sur le serveur d’applications défectueux.
S’il existe un proxy d’application de service pour l’application de service défectueuse, créez une application de service.
Résolution 4 : Redémarrez le service de traduction automatique :
Sur le site web Administration centrale, dans le volet de lecture, dans la section Paramètres système, cliquez sur Gérer les serveurs de cette batterie.
Dans la colonne Serveur, cliquez sur le nom du serveur d'applications défectueux. La page Services sur le serveur s'ouvre.
Dans la colonne Service, recherchez le Service de traduction automatique, cliquez sur Arrêter, puis sur Démarrer.
Résolution 5 : Créez une application de service de traduction automatique :
Sur le site web Administration centrale, dans le volet de lecture, dans la section Gestion des applications, cliquez sur Gérer les applications de service.
Dans la colonne Type , cliquez sur le nom de l’application de service de traduction automatique qui a l’instance de service défaillante.
Sur le ruban, cliquez sur Supprimer.
Dans la boîte de dialogue Supprimer l’application de service , cliquez sur OK.
Créez une application de service de traduction automatique.
Service de traduction automatique : contenu inaccessible
**Nom de l’alerte :**Service de traduction automatique : le contenu n’est pas accessible
Résumé : Un état critique de ce moniteur indique que les appels du modèle CSOM principal au modèle CSOM frontal sont défectueux.
Symptômes : Aucun fichier ne peut être récupéré pour le traitement et les éléments déjà traités ne sont pas écrits. En d’autres termes, les fichiers sont inaccessibles et les éléments échouent en permanence.
Cause
La ou les causes peuvent être les suivantes :
L’authentification serveur à serveur n’est pas correctement configurée.
La base de données de contenu ne répond pas suffisamment vite, en raison de l’activité sur le réseau ou sur le serveur SQL Server physique.
Les autorisations d’accès à la base de données de contenu ne sont plus valides.
La base de données de contenu est inaccessible.
Résolution
Résolution 1 : Vérifiez le statut de la base de données de contenu SQL Server :
Sur le site web Administration centrale de SharePoint, dans la section Paramètres système du volet de lecture, cliquez sur Gérer les serveurs de cette batterie.
Dans la section Informations sur la batterie de serveurs, notez le serveur de la base de données de contenu, ainsi que le nom et la version de la base de données de configuration.
Démarrez SQL Server Management Studio et connectez-vous au serveur de base de données de contenu.
Si la base de données de contenu n’existe pas, exécutez l’Assistant Configuration des produits et technologies SharePoint.
Résolution 2 : Vérifiez la connexion réseau au serveur SQL Server.
Sur le site web Administration centrale, dans la section Paramètres système du volet de lecture, cliquez sur Gérer les serveurs de cette batterie.
Dans la section Informations sur la batterie de serveurs, notez le serveur de la base de données de contenu, ainsi que le nom et la version de la base de données de contenu.
Ouvrez une fenêtre Invite de commandes et tapez ping pour confirmer la connexion au serveur.
Si la tentative de contact du serveur échoue, cela signifie qu’un problème affecte la connexion réseau ou empêche le serveur de répondre.
Connectez-vous au serveur et résolvez le problème.
Résolution 3 : Vérifiez que l’authentification serveur à serveur est correctement configurée :
Reportez-vous à Configure server-to-server authentication in SharePoint Server.
Service de traduction automatique : échec du processus de travail
**Nom de l’alerte :**Service de traduction automatique : Échec du worker
Résumé : Un état critique de ce moniteur indique que les processus de traitement du service de traduction automatique sont défectueux.
Symptômes : Ces erreurs doivent être surveillées pour que les utilisateurs finaux ne voient pas tous les éléments échouer sur une période de temps donnée.
Cause
La ou les causes peuvent être les suivantes :
Fichier d’entrée corrompu
Arrêt intempestif du processus de travail de traduction
Erreur lors de l’enregistrement du fichier dans le magasin local
Résolution
Résolution 1 : vérifiez les journaux des erreurs :
Ouvrez l’Observateur d’événements Windows.
Recherchez l’ID d’événement 8049 dans le journal des événements de l’application Windows.
Dans la description de l’événement, notez le serveur d’applications défectueux.
Résolution 2 : Vérifiez la connexion du serveur d’applications :
À partir du serveur d'applications défectueux, ouvrez le site web Administration centrale de SharePoint.
Si vous ne pouvez pas accéder au site Administration centrale à partir du serveur défectueux, vérifiez que les paramètres réseau sont corrects et que le serveur dispose des autorisations appropriées pour rejoindre la batterie de serveurs SharePoint.
Résolution 3 : Vérifiez que le service de traduction automatique s’exécute sur le serveur défectueux :
Sur le site web Administration centrale, dans le volet de lecture, dans la section Paramètres système, cliquez sur Gérer les serveurs de cette batterie.
Vérifiez que le service de traduction automatique s’exécute sur le serveur d’applications défectueux.
S’il existe un proxy d’application de service pour l’application de service défectueuse, créez une application de service.
Résolution 4 : Redémarrez le service de traduction automatique :
Sur le site web Administration centrale, dans le volet de lecture, dans la section Paramètres système, cliquez sur Gérer les serveurs de cette batterie.
Dans la colonne Serveur, cliquez sur le nom du serveur d'applications défectueux. La page Services sur le serveur s'ouvre.
Dans la colonne Service, recherchez le Service de traduction automatique, cliquez sur Arrêter, puis sur Démarrer.
Résolution 5 : Créez une application de service de traduction automatique.
Sur le site web Administration centrale, dans le volet de lecture, dans la section Gestion des applications, cliquez sur Gérer les applications de service.
Dans la colonne Type , cliquez sur le nom de l’application de service de traduction automatique qui a l’instance de service défaillante.
Sur le ruban, cliquez sur Supprimer.
Dans la boîte de dialogue Supprimer l’application de service , cliquez sur OK.
Créez une application de service de traduction automatique.
Voir aussi
Concepts
Plan de surveillance de SharePoint Server
Autres ressources
System Center Monitoring Pack for SharePoint Foundation
System Center Monitoring Pack for SharePoint Server 2013
Pack d'administration System Center pour SharePoint Server 2016