0xc0c01b15 fail to start BizTalk service
<><><><><><><><><><><><><><><><><><><><><><><><><><><><><><><><><><><><><><><><><><><><><>
NOTE: This article is migrated from Blog AsiaTech
Date: 2009-11-19 3:31 PM
Orignal URL: https://blogs.msdn.com/b/asiatech/archive/2009/11/19/0xc0c01b15-fail-to-start-biztalk-service.aspx
<><><><><><><><><><><><><><><><><><><><><><><><><><><><><><><><><><><><><><><><><><><><><>
Problem:
After recovering the BizTalk databases from a disaster in BTS2K6 R2 or after upgrade from BTS2K6 to BTS2K6 R2, the BizTalk service could fail to start and the following error is reported
Event Type: Error
Event Source: BizTalk Server 2006
Event Category: BizTalk Server 2006
Event ID: 5410
Description:
A failure occurred when executing a Windows service request.
Service request: Start
BizTalk host name: BizTalkServerApplication
Windows service name: BTSSvc$ BizTalkServerApplication
Additional error information:
Error code: 0xc0c0153a
Error source: BizTalk Server 2006
Error description: A BizTalk subservice has failed while executing a service request.
Subservice: Caching Service
Service request: Start
Additional error information:
Error code: 0xc0c01b15
Error source:
Error description: The configuration information for the running service could not be retrieved from the database. Please check the installation.
Cause:
In BTS2K6 R2 and BTS2K9, a database consistence checking will be done when a BizTalk service is started, BizTalkMgmtDb.adm_Group. SubscriptionDBServerName and BizTalkMgmtDb.adm_Group. SubscriptionDBName will be checked to see if they match with BizTalkMgmtDb.adm_MessageBox.DBServerName and BizTalkMgmtDb.adm_MessageBox.DBName for the column BizTalkMgmtDb.adm_MessageBox.IsMasterMsgBox = ‘-1’, Please note this comparing is case sensitive. Normally this consistence checking should be fine as these entries in BizTalk management DB should be completely the same since they can only be entered once through the BizTalk Configuration wizard. However should you need to recover these databases from a disaster or should you upgrade from BTS2K6 to BTS2K6 R2, you could manually enter the DB names of the BizTalk GROUP again, if the name was entered the same but in a different case (lower or upper) , the above problem should occur due to the consistence comparing failure.
Solution:
Manually update the BizTalkMgmtDb.adm_Group. SubscriptionDBServerName and BizTalkMgmtDb.adm_Group. SubscriptionDBName or BizTalkMgmtDb.adm_MessageBox.DBServerName and BizTalkMgmtDb.adm_MessageBox.DBName for the column BizTalkMgmtDb.adm_MessageBox.IsMasterMsgBox = ‘-1’ and make they are the same in case sensitive.
Regards,
XiaoDong Zhu
Comments
- Anonymous
October 08, 2011
Thanks for sharing. - Anonymous
February 14, 2012
Thank's a ton had the same problem on an imaged BTS 2010, this resolved it.