Name resolution for the name outlook.office365.com timed out after none of the configured DNS servers responded.
Users may report they are unable to open their Exchange Online hosted mailbox with Outlook or Outlook Web Access and the follow event may be logged multiple times in the Windows system log. Users reports they have no other issues accessing other websites and your DNS team reports there are no issues with the DNS servers.
Log Name: System
Source: Microsoft-Windows-DNS-Client
Date: 3/27/2016 11:38:07 AM
Event ID: 1014
Task Category: (1014)
Level: Warning
Keywords: (268435456)
User: NETWORK SERVICE
Computer: Windows.contoso.com
Description:
Name resolution for the name outlook.office365.com timed out after none of the configured DNS servers
Cause:
The time to live (TTL) on the outlook.office365.com DNS record is 5 minutes. Because of this the Windows will refresh this record at the interval of 5 minutes. Third party malware and internet protection suites have been found to block request at this frequent of an interval, in turn preventing users from using Outlook or Outlook Web Access to connect to their Exchange Online mailbox.
Resolution:
Work with third party vendor to setup proper exclusions for outlook.office365.com, or disable third party malware/internet protection suites.