[お知らせ] Windows Azure 請求書の内容が文字化けする現象について
皆さんこんにちは、Windows Azureサポートチームです。本日は、請求書をご利用いただいている方から時々お受けする請求書の文字化けのご質問についてお答えをいたします。
もし同じ問題に該当することが起きましたら、こちらの件をご参考いただければ幸いです。
問題
Windows Azureアカウントポータルから、特定のサブスクリプション(従量課金など)のPDFの請求書をダウンロードすると、一部の請求書で、請求書内のひらがな・漢字が文字化けしている。半角数字については問題なく表示がされている。
補足
Windows XPをご利用のマシンで比較的多くのお問い合わせをいただいています。
図:再現例
原因
PDFファイル内部では、MS ゴシックをベースとしたフォントが利用されています。利用されているフォントが対象マシンにインストールされていないと、今回の現象が発生することがあります。
対応策
以下をお試しいただきまして、現象が改善されるかお試しください。
- Windows XP の場合は、弊社Windows Azureサービスの請求書に利用しているフォントが、インストールされていない可能性があります。以下の記事の「インストールおよびアンインストール方法」をご参考に、フォントをインストールしてお試しください。
Windows XP および Windows Server 2003 向けJIS2004 対応 MS ゴシック & MS 明朝 - ご利用 OS のセキュリティ更新プログラム適用状況を確認し、最新のサービスパック、修正プログラムがインストールされているかご確認ください。
- Acrobat Reader は他社製品とはなりますが、ご利用いただいているOSにて、最新版のAcrobat Readerがインストールされているかご確認ください。
補足 – Windows XP について
Windows XPについては、現在延長サポートフェーズであり、2014年4月9日に正式にサポートが終了します。サポート終了後には、セキュリティ更新プログラムなどが提供されなくなるため、現在ご利用の場合には、早めにOSのアップグレードをよろしくお願いいたします。
--
Windows Azure サポートチーム