Partager via


Résolution des problèmes d’installation et de configuration

Le programme d’installation ne peut pas déployer l’assembly RuntimeSchemas

Symptôme

Le programme d’installation A4SWIFT n’a pas pu déployer RuntimeSchemas.dll. Si l’assembly n’est pas déployé manuellement après l’installation, l’Assistant Configuration A4SWIFT échoue.

Cause possible

L’une des conditions suivantes existe :

  • L’assembly Runtime Schemas a déjà été déployé lorsque vous avez essayé d’effectuer une installation initiale de A4SWIFT.

  • Microsoft SQL Server n’a pas démarré sur l’ordinateur sur lequel vous avez essayé d’installer A4SWIFT.

  • L’assembly Runtime Schemas a déjà été déployé lorsque vous avez essayé de mettre à niveau A4SWIFT et a été référencé par un autre assembly. Cela a empêché l’annulation du déploiement de l’assembly de schémas d’exécution par le programme de mise à niveau A4SWIFT.

Solution

Procédez comme suit, selon la nature du problème :

  • Si l’assembly Runtime Schemas a déjà été déployé lorsque vous avez tenté d’exécuter une installation initiale de A4SWIFT, ouvrez BizTalk Explorer dans Microsoft Visual Studio.NET, cliquez avec le bouton droit sur l’assembly Microsoft . Solutions.FinancialServices.SWIFT.RuntimeSchemas, puis cliquez sur Annuler le déploiement. Utilisez l’Assistant Déploiement de BizTalk pour déployer la dernière version de RuntimeSchemas.dll à partir de %programfiles%\Microsoft BizTalk Accelerator pour SWIFT\Assemblys.

  • Si SQL Server n’a pas démarré, démarrez SQL Server dans le SQL Server Service Manager. Utilisez l’Assistant Déploiement de BizTalk pour déployer la dernière version de RuntimeSchemas.dll à partir de %programfiles%\Microsoft BizTalk Accelerator pour SWIFT\Assemblys.

  • Si l’assembly Runtime Schemas a déjà été déployé lorsque vous avez essayé de mettre à niveau A4SWIFT et qu’il a été référencé par un autre assembly, supprimez le déploiement de l’assembly de référence dans BizTalk Explorer et désactivez le déploiement d'RuntimeSchemas.dll dans BizTalk Explorer. Utilisez l’Assistant Déploiement de BizTalk pour déployer la dernière version de RuntimeSchemas.dll à partir de %programfiles%\Microsoft BizTalk Accelerator pour SWIFT\Assemblys.

Une fois la fonctionnalité composants web supprimée, la réparation et la réconciliation des messages sont incorrectement affichées comme désinstallées

Symptôme

Une fois que vous avez supprimé les composants web pour la réparation des messages et la fonctionnalité Nouvelle soumission de A4SWIFT, vous ne pouvez pas désinstaller, installer ou configurer la fonctionnalité de réparation et de rapprochement des messages (ou A4SWIFT composants). Si la réparation et le rapprochement des messages sont installés, A4SWIFT ne reconnaît pas que la fonctionnalité est installée. Si vous tentez d’installer, de modifier ou de supprimer la réparation et le rapprochement des messages dans Ajout/Suppression de programmes (affichés à partir de Panneau de configuration), l’ajout/la suppression de programmes indique que la fonctionnalité n’est pas installée.

Cause possible

Vous avez été supprimé du groupe administrateurs BizTalk Server après avoir installé les composants web pour la réparation des messages et la fonctionnalité Nouvelle soumission et la fonctionnalité réparation et rapprochement des messages. Si vous supprimez ensuite la fonctionnalité Composants web (ce que vous pouvez faire sans être membre du groupe administrateurs BizTalk Server), le programme d’installation A4SWIFT supprime les fichiers sur lesquels la fonctionnalité De réparation et de rapprochement des messages a une dépendance. Ces fichiers incluent ConfigFramework.exe.

Solution

Si vous rencontrez ce problème, procédez comme suit :

  1. Dans la fenêtre Gestion de l’ordinateur, ajoutez-vous de nouveau au groupe Administrateur BizTalk Server, déconnectez-vous de l’ordinateur, puis reconnectez-vous.

  2. Réinstallez les composants web pour la réparation des messages et la fonctionnalité Nouvelle soumission.

    Notes

    L’étape 2 ajoute ConfigFramework.exe à l’installation A4SWIFT.

  3. Réinstallez la fonctionnalité MRSR.

  4. Si vous ne souhaitez toujours pas la fonctionnalité Composants web pour la réparation des messages et la nouvelle soumission, supprimez-la.

La réparation de A4SWIFT pour ajouter le dossier Service peut entraîner des autorisations d’accès incorrectes pour ce dossier

Symptôme

Si vous supprimez le dossier %programfiles%\Microsoft BizTalk Accelerator for SWIFT\Service à partir d’une installation de A4SWIFT correctement configurée, puis exécutez la fonctionnalité De réparation de A4SWIFT installation pour ajouter le dossier Serveur dans le A4SWIFT installation, les autorisations d’accès pour le dossier Service ne sont pas correctes. Les autorisations appropriées sont Contrôle total pour les administrateurs A4SWIFT et Lecture & Exécuter pour les utilisateurs A4SWIFT.

Cela se produit également si vous exécutez la fonctionnalité De réparation de A4SWIFT installation lorsque le dossier Service existe. Les autorisations d’accès, telles que définies par l’Assistant Configuration A4SWIFT, seront remplacées par des valeurs incorrectes.

Cause possible

L’installation des composants web pour la réparation des messages et la fonctionnalité Nouvelle soumission ajoute le dossier Service. Si vous supprimez le dossier, puis exécutez l’option Réparer de A4SWIFT programme d’installation pour ajouter les composants web pour la réparation des messages et la nouvelle soumission, A4SWIFT programme d’installation n’exécute pas l’Assistant configuration (ConfigFramework.exe) pour définir les autorisations pour le dossier. Étant donné que l’Assistant Configuration a déjà été exécuté, il est très difficile de réexécuter l’Assistant pour réinitialiser la configuration. Par conséquent, l’option Réparer recréera tous les fichiers et dossiers supprimés, mais elle ne définira pas correctement les autorisations d’accès.

Le processus de réparation remplace également les autorisations pour le dossier Service si le dossier existe lors de l’exécution de la réparation. Comme dans le cas de la suppression du dossier Service avant d’exécuter la réparation, il sera très difficile d’exécuter le programme de configuration pour définir les autorisations. Dans cette instance également, les autorisations sont incorrectes et vous devez les définir manuellement.

Solution

Si vous rencontrez ce problème, définissez manuellement les autorisations d’accès suivantes pour le dossier Service :

Groupe ou nom d'utilisateur Autorisation
administrateurs A4SWIFT Contrôle total
utilisateurs A4SWIFT Lire et exécuter

Pour définir ces autorisations, procédez comme suit :

Dans Windows Explorer, accédez à %programfiles%\Accélérateur Microsoft BizTalk pour SWIFT\Service.

  1. Cliquez avec le bouton droit sur le dossier Service, cliquez sur Propriétés, puis sur l’onglet Sécurité .

  2. Dans le volet Noms de groupes ou d’utilisateurs de la boîte de dialogue Propriétés du service, cliquez sur Ajouter, entrez <nom> du serveur\A4SWIFT Administrateurs, puis cliquez sur OK.

    Notes

    Si le groupe Administrateurs A4SWIFT est un groupe de domaines, entrez <nom> de domaine\A4SWIFT Administrateurs.

  3. Répétez l’étape 2 pour <nom> de serveur\A4SWIFT Utilisateurs ou <nom> de domaine\A4SWIFT Utilisateurs si le groupe Utilisateurs A4SWIFT est un groupe de domaines.

  4. Dans le volet Noms de groupes ou d’utilisateurs, sélectionnez A4SWIFT Administrateurs. Dans le volet Autorisations, sélectionnez Autoriser pour le contrôle total.

  5. Dans le volet Noms de groupes ou d’utilisateurs, sélectionnez A4SWIFT Utilisateurs. Dans le volet Autorisations, cliquez sur Autoriser la lecture & Exécuter, Répertorier le contenu du dossier et Lire.

  6. Cliquez sur OK.

La mise à niveau entraîne une installation côte à côte de deux versions de A4SWIFT

Symptôme

Lorsque vous tentez de mettre à niveau vers A4SWIFT, les versions précédentes de A4SWIFT peuvent ne pas être entièrement supprimées. Si vous exécutez Ajout/Suppression de programmes à partir du Panneau de configuration, la liste des programmes actuellement installés peut afficher les versions actuelles et précédentes.

Cause possible

L’une des conditions suivantes peut provoquer l’événement ci-dessus :

  • L’utilisateur qui tente de mettre à niveau n’est pas membre du groupe administrateurs BizTalk Server.

  • Le service SQL Server (MSSQLSERVER) est arrêté.

  • Vous avez effectué une mise à niveau en mode silencieux à l’aide de la commande setup.exe /addlocal .

Solution

Pour éviter qu’une installation côte à côte de A4SWIFT 2.1 et A4SWIFT 3.0 ne se produise pendant la mise à niveau, vérifiez que vous (l’utilisateur connecté) êtes membre du groupe Administrateurs BizTalk Server et que le service SQL Server (MSSQLSERVER) est démarré.

Si vous vous retrouvez avec une installation côte à côte de A4SWIFT 2.1 ou A4SWIFT 2.3 et A4SWIFT 3.0, procédez comme suit :

  1. Sauvegardez les données dans le dossier Messages SWIFT.

  2. Connectez-vous au BizTalk Server en tant que membre du groupe Administrateurs BTS et vérifiez que le service MSSQLSERVER est en cours d’exécution.

  3. Supprimez la version précédente de A4SWIFT.

  4. Effectuez une nouvelle mise à niveau vers la dernière version de A4SWIFT. Cette fois, la mise à niveau fonctionnera et aucune installation côte à côte n’est créée.

  5. À l’aide de l’utilitaire de déploiement BizTalk, désactivez le déploiement manuel de Microsoft .Solutions.FinancialServices.SWIFT.RuntimeSchemas.dll, puis redéployez-le à partir du dossier Assemblys de votre emplacement d’installation A4SWIFT. Pour plus d’informations sur cet outil, consultez Utilitaire de déploiement BRE.

Le processus de désinstallation ou de mise à niveau peut ne pas se terminer correctement si vous ne redémarrez pas lorsque vous y êtes invité

Symptôme

Les processus de désinstallation ou de mise à niveau ne se terminent pas correctement.

Cause possible

Si vous n’avez pas déclassé un projet qui fait référence à un assembly déployé existant, vous pouvez recevoir une invite indiquant que vous devez redémarrer votre système pour que A4SWIFT modifications de configuration prennent effet. Si vous ne cliquez pas sur Oui pour redémarrer immédiatement, certains assemblys qui ont été affectés à la suppression dans le global assembly cache peuvent ne pas être supprimés, ce qui entraîne l’échec des processus de désinstallation ou de mise à niveau supplémentaires.

Solution

Annulez le déploiement de tout projet qui fait référence à un assembly déployé existant, puis réexécutez le processus de désinstallation ou de mise à niveau.

Si le service de Administration IIS est arrêté pendant l’installation, vous devez reconfigurer la fonctionnalité WebService

Symptôme

L’Assistant Configuration A4SWIFT ne configure pas correctement la fonctionnalité WebService. Vous recevez l’erreur suivante :

« Impossible de créer des artefacts MRSR : Impossible de se connecter au serveur distant. »

Cause possible

Le service Administration IIS a été arrêté lorsque vous avez exécuté l’Assistant Configuration A4SWIFT.

Solution

Pour terminer le processus de configuration, procédez comme suit :

  1. Fermez la console A4SWIFT Configuration.

  2. Redémarrez le service Administration IIS.

  3. Exécutez %programfiles%\Microsoft BizTalk Accelerator pour SWIFT\Configuration.exe.

  4. Dans la console de configuration A4SWIFT, sélectionnez Annuler la configuration des fonctionnalités , puis WebService.

  5. Vérifiez que le status de la fonctionnalité WebService dans la console de configuration est affiché comme non configuré.

  6. Sélectionnez Appliquer la configuration.

    Notes

    L’Assistant Configuration A4SWIFT configure désormais correctement la fonctionnalité WebService.

A4SWIFT configuration échoue si l’hôte BizTalkServerApplication n’a pas été créé dans BizTalk Server configuration

Symptôme

L’Assistant Configuration A4SWIFT ne configure pas correctement la fonctionnalité WebService. Vous recevez l’erreur suivante :

« Impossible de créer des artefacts MRSR : la référence d’objet n’est pas définie sur un instance d’un objet . »

Cause possible

Aucun hôte In-Process et aucune instance d’hôte n’ont été créés pendant BizTalk Server configuration du runtime.

Solution

Pour réparer la configuration A4SWIFT, procédez comme suit :

  • Créez un hôte dans BizTalk Server Administration. Il n’est pas nécessaire d’avoir une instance en cours d’exécution maintenant.

  • Exécutez l’outil RepairBAS dans le dossier %programfiles%\Microsoft BizTalk Accelerator for SWIFT\SDK\Tools de l’installation A4SWIFT.

    Pour ce faire, procédez comme suit :

  1. Démarrez BizTalk Server console Administration.

  2. Dans la console d’administration BizTalk Server, développez BizTalk Server Administration, puis Groupe BizTalk, puis Paramètres de plateforme.

  3. Cliquez avec le bouton droit sur Hôtes, pointez sur Nouveau, puis sélectionnez Hôte.

  4. Dans l’écran Propriétés de l’hôte, dans le volet Général, entrez les éléments suivants :

    • Nom d’hôte : BizTalkServerApplication

    • Type : In-Process

    • Groupe Windows : <domaine>\Utilisateurs d’application BizTalk (ou le compte que vous avez configuré pendant BizTalk Server configuration pour l’exécution d’applications BizTalk In-Process)

    • Dans la section Options, sélectionnez Autoriser le suivi de l’hôte et En faire l’hôte par défaut dans le groupe.

  5. Cliquez sur OK.

  6. Cliquez sur Démarrer , puis sur Exécuter. Tapez cmd , puis cliquez sur OK.

  7. À l’invite de commandes, accédez à %programfiles%\Microsoft BizTalk Accelerator for SWIFT\SDK\Tools.

  8. Tapez RepairBAS.exe , puis appuyez sur Entrée.

Vous devez modifier le fichier de configuration de déploiement BRE lors de l’exécution de l’utilitaire de déploiement BRE sur un ordinateur 64 bits

Symptôme

L’utilitaire de déploiement BRE ne fonctionne pas correctement lorsque vous l’exécutez sur un ordinateur 64 bits ou dans un répertoire autre que celui par défaut (autre que C :\Program Files\Microsoft BizTalk Accelerator for SWIFT) sur un ordinateur 32 bits.

Cause possible

L’utilitaire de déploiement BRE ne fonctionnera pas correctement tant que vous ne modifierez pas les chemins d’accès dans le fichier BREDeployment.exe.config situé dans le <dossier lecteur> :\Program Files\Microsoft BizTalk Accelerator for SWIFT\SDK\Tools.

Solution

Mettez à jour la configuration de l’utilitaire en ouvrant BREDeployment.exe.config dans le Bloc-notes et en modifiant les dossiers des répertoires de stratégies, schémas et vocabulaires de base.

Voir aussi

Dépannage : problèmes et résolutions