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Ajouter une instance d’hôte

Vue d’ensemble

Vous pouvez utiliser la console d’administration BizTalk Server ou Windows Management Instrumentation (WMI) pour ajouter des instances d’hôte. Dans BizTalk Server vous ne pouvez ajouter qu’un instance hôte à un serveur à la fois. Pour plus d’informations sur les instances hôtes, consultez Instances d’hôte. Pour plus d’informations sur l’utilisation de WMI pour ajouter un instance hôte, consultez MSBTS_HostInstance (WMI) dans l’aide de l’interface utilisateur et informations de référence sur l’espace de noms d’API des développeurs.

L'ajout d'une instance d'hôte mappe l'instance d'un hôte donné sur une instance de BizTalk Server. Lorsqu'une instance d'hôte existante doit être réparée, vous pouvez mettre à jour ses propriétés. Avant d'ajouter à nouveau une instance d'hôte existante, vous devez l'arrêter. Pour plus d’informations sur l’arrêt d’un hôte instance, consultez Comment arrêter une instance d’hôte.

Notes

Si vous souhaitez créer plus de 26 instances d’hôte, vous devez suivre les instructions de l’article de la Base de connaissances 184802« User32.dll ou Kernel32.dll ne parvient pas à initialiser », disponible à l’adresse https://go.microsoft.com/fwlink/?LinkId=26176. Si vous avez besoin d'instances d'hôte supplémentaires après avoir appliqué les recommandations de cet article de la Base de connaissances, vous pouvez essayer de réduire la quantité de mémoire disponible pour chaque instance du service BTSNTSvc. Cette opération fournira la mémoire supplémentaire requise pour créer plus d'instances.

Notes

Le compte de service disposera automatiquement de l'autorisation « Ouvrir une session en tant que service » sur le serveur où l'instance d'hôte est installée.

Prérequis

Pour exécuter cette procédure, vous devez avoir ouvert une session en tant que membre du groupe des administrateurs BizTalk Server ou du groupe des administrateurs Windows.

Vous devez également être un membre du rôle de la base de données SQL Server db_securityadmin et du rôle SQL Server securityadmin sur les serveurs sur lesquels se trouvent les bases de données suivantes :

  • importation principale BAM (BAMPrimaryImport).

  • gestion BizTalk (BizTalkMgmtDb) ;

  • MessageBox BizTalk (BizTalkMsgBoxDb) (tout) ;

  • suivis BizTalk (BizTalkDTADb) ;

  • moteur des règles (BizTalkRuleEngineDb) ;

Attention

Nous vous recommandons de mettre à jour les informations de compte des instances d'hôte à l'aide de la console Administration de BizTalk Server ou d'un script WMI (Windows Management Instrumentation). De cette manière, BizTalk Server peut mettre à jour les informations de compte dans les bases de données BizTalk Server et peut synchroniser la configuration de sécurité entre les bases de données et l'instance d'hôte.

Étapes

  1. Cliquez sur Démarrer, sur Tous les programmes, sur Microsoft BizTalk Server 20xx, puis sur administration BizTalk Server.

  2. Dans l’arborescence de la console, développez BizTalk Server Administration, développez le groupe BizTalk, puis cliquez sur Paramètres de la plateforme.

  3. Cliquez avec le bouton droit sur Instances d’hôte, cliquez sur Nouveau, puis sur Instance d’hôte.

  4. Dans la boîte de dialogue Propriétés de l’instance d’hôte , procédez comme suit, puis cliquez sur OK :

    Propriété Pour
    Nom d’hôte Afficher le nom de l'hôte associé au serveur sélectionné.
    Serveur Afficher le serveur associé à l'hôte sélectionné.
    Ouverture de session Afficher le nom de compte du nouveau service sous lequel l'instance de l'hôte doit s'exécuter.
    Configurer Cliquez pour afficher la boîte de dialogue Informations d’identification d’ouverture de session, dans laquelle vous pouvez entrer le nom et le mot de passe du compte sous lequel le instance hôte s’exécutera.
    Désactiver le démarrage de l'instance de l'hôte Activer cette case à cocher pour faire passer l'état de l'hôte sélectionné de « Activé » à « Désactivé ». La désactivation d'une instance de l'hôte est utile lorsque vous ne souhaitez pas que l'instance démarre, mais que vous voulez tout de même conserver sa configuration.

    Après avoir installé une instance d'hôte, vous devez la démarrer pour qu'elle puisse acheminer des messages vers la base de données MessageBox. Pour plus d’informations sur le démarrage d’un instance hôte, consultez Guide pratique pour démarrer une instance d’hôte.

Problèmes connus

Une instance d'hôte BizTalk Host est créée avec l'état « Échec de la désinstallation » si l'ordinateur d'exécution BizTalk Server désigné n'est pas disponible lors de sa création.

Problème

Si la console d’administration BizTalk est installée sur un ordinateur distant d’un ordinateur d’exécution BizTalk Server, il est possible de tenter de créer un instance hôte sur l’ordinateur BizTalk Server distant, même si l’ordinateur BizTalk Server n’est pas disponible.

Si vous tentez de créer un instance d’un hôte BizTalk sur un ordinateur BizTalk Server qui n’est pas disponible, une boîte de dialogue avec le message d’erreur suivant s’affiche :

L’installation de l’instace du nom >d’hôte< sur le < nom >du serveur a échoué.

Informations complémentaires :

Le serveur RPC est indisponible. (WinMgmt)

Lorsque vous cliquez sur OK pour refermer la boîte de dialogue, une autre s'affiche avec le message d'erreur suivant :

Le nettoyage de l’installation abandonnée du nom d’hôte< sur le <nom>> du serveur a échoué.

Informations complémentaires :

Une erreur s’est produite lors de la suppression du service Windows NT BTSSvc{<GUID>}. (WinMgmt)

Lorsque vous cliquez sur OK pour ignorer cette boîte de dialogue, la instance de l’hôte BizTalk est visible dans la console d’administration BizTalk avec l’état Échec de la désinstallation.

Cause

Lorsqu’un instance hôte est créé, une entrée est effectuée dans la base de données de gestion BizTalk avant que le instance hôte soit installé sur l’ordinateur BizTalk Server désigné. Si l’installation de l’hôte instance sur l’ordinateur BizTalk Server désigné échoue, le programme d’administration BizTalk tente de désinstaller le instance hôte, mais étant donné que l’ordinateur BizTalk Server désigné n’est pas disponible, la désinstallation échoue également.

Résolution

Si un instance hôte BizTalk est créé dans la console d’administration BizTalk avec un status de Désinstallation ayant échoué, supprimez le instance hôte et recréez l’hôte instance une fois que l’ordinateur BizTalk Server désigné est disponible.

Notes

Si un instance hôte BizTalk est créé dans la console d’administration BizTalk avec l’état Désinstallationa échoué, l’hôte instance ne sera pas fonctionnel même après que l’ordinateur BizTalk Server désigné redevient disponible.

Voir aussi

Gestion des hôtes BizTalk et des instances d’hôteDémarrer une instance d’hôteArrêter une instance d’hôteSupprimer une instance d’hôteModifier les propriétés de l’instance d’hôte