Partager via


Optimiser les performances grâce aux tâches automatiques de nettoyage

S’applique aux applications Dynamics 365 suivantes :
Human Resources

Sortie

Microsoft Dynamics 365 Human Resources peut faire l’expérience de problèmes de performances si l’historique des traitements par lots se développe de trop.

Cause

Les traitements par lots qui fonctionnent souvent peuvent entraîner la croissance insoutenable de l’historique des traitements par lots. Cela peut entraîner des problèmes de performances.

Résolution

Planifiez une tâche automatique pour nettoyer votre historique des traitements par lots. Nous vous recommandons de paramétrer la tâche à exécuter chaque semaine, mais vous devez exécuter le nettoyage plus ou moins souvent, selon votre environnement. La procédure suivante contient nos paramètres recommandés, mais vous pouvez les modifier selon vos besoins.

  1. Dans Human Resources, sélectionnez Administration du système.

  2. Dans la barre Recherche, entrez Nettoyage de l’historique des traitements par lots.

    Rechercher le nettoyage de l’historique des traitements par lots.

  3. Dans Limite de l’historique (jours), saisissez 30.

    Définir la limite de l’historique sur 30.

  4. Sélectionnez Exécuter en arrière-plan, puis sélectionnez Récurrence.

    Définir la récurrence.

  5. Sous Définir la récurrence, définissez Date de début et Heure de début pour qu’elles se produisent pendant les heures creuses ou le week-end, puis sélectionnez PAS DE DATE DE FIN.

    Définir la date et heure de début de la récurrence.

  6. Sous PÉRIODICITÉ, sélectionnez Jours et définissez RÉPÉTER APRÈS L’INTERVALLE SPÉCIFIÉ sur 7.

    Définir le nettoyage afin qu’il se répète de manière hebdomadaire.

  7. Cliquez sur OK.

  8. Modifiez les autres paramètres sous Exécuter en arrière-plan au besoin, et sélectionnez OK.