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SCOM signale des jeux d’intégrité non sains

Symptômes

Vous recevez une notification de Microsoft System Center Operations Manager (SCOM) indiquant que certains des groupes d’intégrité à haute disponibilité managés de votre environnement ne sont pas sains.

Lorsque vous effectuez une recherche dans le journal des événements des applications et services Microsoft Windows sur les serveurs affectés, vous constatez que certains événements répertoriés sous Microsoft>Exchange>ActiveMonitoring>ProbeResult contiennent le message d’erreur suivant :

System.ApplicationException: monitoring mailbox <UPN of health mailbox account> not found!
at Microsoft.Exchange.Monitoring.ActiveMonitoring.Common.CommonAccessTokenHelper.
ResolveRootOrgUser(String emailAddress, IRecipientSession& recipientSession)

En outre, les journaux de suivi de surveillance active qui se trouvent dans le ActiveMonitoringTraceLogs dossier sur les serveurs affectés contiennent une entrée qui affiche les informations suivantes :

Component: "Common"
LogLevel: "Warning"
Method: "CreateMonitoringMailbox"
Source: "DirectoryAccessor.cs:1380"
Message: "Exception is caught trying to disable email address policy in OnPrem for monitoring mailbox: 
<UPN of health mailbox account>, error : Microsoft.Exchange.Data.Directory.ADNoSuchObjectException: 
Active Directory operation failed on <FQDN of domain controller>. The object <DN of health mailbox account> 
does not exist."

Remarque : Le dossier ActiveMonitoringTraceLogs se trouve à l’emplacement %ExchangeInstallPath%\Logging\Monitoring\Monitoring\MSExchangeHMWorker\ActiveMonitoringTraceLogs.

Cause

Lorsque le processus de travail du Gestionnaire d’intégrité Exchange (MSExchangeHMWorker.exe) crée une boîte aux lettres d’intégrité, il tente de définir la EmailAddressPolicyEnabled valeur du paramètre de la boîte aux lettres sur False. Toutefois, dans les environnements qui ont plusieurs contrôleurs de domaine, les retards de réplication Active Directory peuvent entraîner EmailAddressPolicyEnabled le maintien de la valeur True. Dans ce scénario, les problèmes suivants se produisent :

  • L’échec de la tentative de MSExchangeHMWorker.exe de désactiver la stratégie d’adresse e-mail génère le message d’erreur du journal de suivi de surveillance active mentionné dans la section « Symptômes ».

  • La stratégie d’adresse e-mail reste activée, car le processus de travail Du gestionnaire d’intégrité Exchange ne retent pas l’opération ayant échoué. Selon la stratégie d’adresse e-mail de votre organization, l’adresse SMTP de la boîte aux lettres peut se voir attribuer une valeur différente de celle de l’UPN.

  • Certaines sondes de surveillance active génèrent des erreurs dans le journal des événements applications et services si l’adresse SMTP d’une boîte aux lettres ne correspond pas à l’UPN. Par exemple, la RpsDeepTestPSProxyProbe/CertificateSid.<CN of health mailbox> sonde génère le message d’erreur dans le journal des événements applications et services qui s’affiche dans la section « Symptômes ». Ces erreurs font qu’Operations Manager signale certains jeux d’intégrité comme non sains.

Résolution

Pour résoudre ce problème, procédez comme suit :

  1. Exécutez la commande suivante pour définir la EmailAddressPolicyEnabled valeur de paramètre de chaque boîte aux lettres d’intégrité sur False:

    Get-Mailbox -Monitoring | Set-Mailbox -EmailAddressPolicyEnabled $False
    
  2. Exécutez la commande suivante pour vous assurer que l’adresse SMTP principale de chaque boîte aux lettres d’intégrité correspond à l’UPN :

    Get-Mailbox -Monitoring | Select-Object UserPrincipalName | foreach {Set-Mailbox -Identity $_.UserPrincipalName -PrimarySmtpAddress $_.UserPrincipalName}