ID d’événement 1309 et vous ne pouvez pas accéder à OWA et ECP après avoir installé Exchange Server 2016 ou Exchange Server 2013

Numéro de la base de connaissances d’origine : 3099532

Symptômes

Vous avez correctement installé Microsoft Exchange Server 2016 ou Exchange Server 2013. Le processus d’installation a peut-être échoué ou a été interrompu à un moment donné, puis a repris et s’est finalement terminé avec succès. Toutefois, lorsque vous essayez d’accéder à Exchange Panneau de configuration (ECP) ou Outlook Web App (OWA), vous recevez le message d’erreur suivant :

une erreur s’est produite

Désolé, nous ne pouvons pas obtenir cette information pour le moment. Recommencez ultérieurement. Si le problème persiste, contactez votre support technique.

Capture d’écran du message d’erreur : nous ne pouvons pas obtenir ces informations pour le moment.

En outre, l’événement suivant peut être enregistré dans le journal des applications :

Log Name:  Application
Source:  ASP.NET 4.0.30319.0
Event ID:  1309
Task Category:  Web Event
Level:  Warning
Keywords:  Classic
User:  N/A
Computer:  Exch2.contoso.com
Description:

Event code: 3005
Event message: An unhandled exception has occurred.

Event ID: f23d9d455f3145068c57286262ac517f
Event sequence: 1
Event occurrence: 1
Event detail code: 0

Application information:
  Application domain: /LM/W3SVC/2/ROOT/owa-5-130879214460462920
  Trust level: Full
  Application Virtual Path: /owa
  Application Path: C:\Program Files\Microsoft\Exchange Server\V15\ClientAccess\owa\
  Machine name: EXCH2

Process information:
  Process ID: 4348
  Process name: w3wp.exe
  Account name: NT AUTHORITY\SYSTEM

Exception information:
  Exception type: TargetInvocationException
  Exception message: Exception has been thrown by the target of an invocation.
  at System.RuntimeTypeHandle.CreateInstance(RuntimeType type, Boolean publicOnly, Boolean noCheck,
  Boolean&canBeCached, RuntimeMethodHandleInternal&ctor, Boolean&bNeedSecurityCheck)

    * SharedWebConfig.config is missing from either of these locations:
      C:\Program Files\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy
      C:\Program Files\Microsoft\Exchange Server\V15\ClientAccess

Cause

Ce problème se produit si SharedWebConfig.config est manquant dans l’un des emplacements suivants :

  • C:\Program Files\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy
  • C:\Program Files\Microsoft\Exchange Server\V15\ClientAccess

Résolution

Pour résoudre ce problème, procédez comme suit :

  1. Sur le serveur qui rencontre le problème, identifiez l’emplacement dans lequel le fichier est manquant.

  2. Génération du fichier manquant :

    1. Exécutez cd %ExchangeInstallPath%\bin pour remplacer le répertoire actif par le dossier bin qui se trouve sous le chemin d’installation d’Exchange.

    2. Utilisez l’outil DependentAssemblyGenerator.exe pour générer le fichier :

      • Si le fichier ne se trouve pas dans C:\Program Files\Microsoft\Exchange Server\V15\ClientAccess, exécutez la commande suivante :
      DependentAssemblyGenerator.exe -exchangePath "%ExchangeInstallPath%\bin" -exchangePath "%ExchangeInstallPath%\ClientAccess" -configFile "%ExchangeInstallPath%\ClientAccess\SharedWebConfig.config"
      
      • Si le fichier ne se trouve pas dans C:\Program Files\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy, exécutez la commande suivante :
      DependentAssemblyGenerator.exe -exchangePath "%ExchangeInstallPath%\bin" -exchangePath "%ExchangeInstallPath%\FrontEnd\HttpProxy" -configFile "%ExchangeInstallPath%\FrontEnd\HttpProxy\SharedWebConfig.config"
      
  3. Exécutez IISRESET ou redémarrez le serveur.

Informations supplémentaires

Le fichier SharedWebConfig.config est généré pendant la phase de post-installation de l’installation. Si le programme d’installation reprend après une interruption, il n’effectue pas les étapes de post-installation pour les rôles qui ont été correctement installés avant l’interruption.