Impossible d’ouvrir OWA, ECP ou EMS après la suppression d’un certificat auto-signé du site web principal Exchange

Numéro de la base de connaissances d’origine : 2779694

Symptômes

Considérez le scénario suivant lorsque vous utilisez Microsoft Exchange Server 2013 ou Exchange Server 2016 :

  • Vous supprimez le certificat Microsoft Exchange Self-Signed du site web principal Exchange à l’aide de Certificats MMC, Remove-Exchangecertificatedu Gestionnaire des services Internet ou d’une autre méthode.
  • Vous effacez le cache IIS en redémarrant ou IISReset.

Dans ce scénario, plusieurs protocoles clients tels qu’Exchange Panneau de configuration (ECP), Outlook Web App (OWA), Exchange ActiveSync et Exchange Management Shell (EMS) ne peuvent pas se connecter. Les problèmes suivants peuvent se produire :

  • OWA et ECP affichent une page vierge.

  • Exchange ActiveSync utilisateurs ne peuvent pas recevoir d’e-mails.

  • EMS ne peut pas se connecter et affiche l’erreur suivante :

    New-PSSession : [xy.local.contoso.com] Processing data from remote server xy.local.contoso.com failed with the
    following error message: The WinRM Shell client cannot process the request. The shell handle passed to the WSMan Shell
    function is not valid. The shell handle is valid only when WSManCreateShell function completes successfully. Change
    the request including a valid shell handle and try again. For more information, see the about_Remote_Troubleshooting
    Help topic.
    At line:1 char:1
    + New-PSSession -ConnectionURI "$connectionUri" -ConfigurationName Microsoft.Excha ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [New-PSSession], PSRemotin
       gTransportException
        + FullyQualifiedErrorId : -2144108212,PSSessionOpenFailed
    Failed to connect to an Exchange server in the current site.
    Enter the server FQDN where you want to connect.:
    

Cause

Pendant le processus d’installation, un certificat auto-signé appelé Microsoft Exchange est lié au site web principal Exchange sur le port 444. Le certificat est destiné à la communication entre le site web par défaut et les sites web principaux Exchange. Lorsque le certificat est supprimé, le site web par défaut ne peut pas proxyer les connexions au site web principal Exchange.

Résolution

Pour résoudre ce problème, rajoutez le certificat au site web principal Exchange en créant un certificat auto-signé, puis liez-le au site web principal Exchange.

Remarque

Ces étapes doivent être effectuées sur le rôle serveur de boîtes aux lettres Exchange.

  1. Démarrez Management Shell sur le serveur de boîtes aux lettres.
  2. Tapez New-ExchangeCertificate.

    Remarque

    Si vous êtes invité à remplacer le certificat par défaut, sélectionnez Non.

  3. Démarrez le Gestionnaire des services Internet sur le serveur de boîtes aux lettres.
  4. Développez Site, mettez en surbrillance le serveur principal Exchange, puis sélectionnez Liaisons dans le volet Actions de la colonne de droite.
  5. Sélectionnez Typehttps sur le port 444.
  6. Sélectionnez Modifier , puis sélectionnez le certificat Microsoft Exchange.
  7. À partir d’une invite de commandes administrateur, exécutez IISReset.