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Outlook Web App publié via WAP avec la pré-authentification ADFS ne redirige pas vers la connexion ADFS après l’expiration du jeton DSO ADFS

Numéro de la base de connaissances d’origine : 4012524

Symptômes

Dans un environnement Exchange Server 2013 ou Exchange Server 2016, vous publiez Outlook Web App via WAP et activez la pré-authentification ADFS. Lorsque vous vous connectez à Outlook Web App mais que vous n’effectuez aucune action après un certain temps, vous rencontrez les symptômes suivants :

  • Vous ne recevez aucun nouvel e-mail ou notification, sauf si vous actualisez manuellement la page web.

  • Lorsque vous cliquez sur le menu de navigation ou sur un bouton dans Outlook Web App, vous recevez des messages d’erreur de connectivité comme le suivant :

    Votre demande ne peut pas être effectuée pour l’instant. Veuillez réessayer plus tard.

Cause

Ce problème se produit car le jeton d’authentification Sign-On unique (SSO) d’ADFS (qui est géré par l’attribut SsoLifetime d’ADFS) a expiré. WAP renvoie une réponse HTTP 307 à Outlook Web App pour rediriger l’utilisateur vers ADFS pour la réauthentification, mais Outlook Web App ne traite pas cette réponse et l’utilisateur reste non authentifié.

Solution de contournement

Il s’agit d’un problème connu qui sera résolu dans une version ultérieure. Pour contourner ce problème, publiez Outlook Web App via WAP en utilisant l’authentification directe au lieu de la pré-authentification ADFS.